New upstream version 1.16.0.
- Remove patches which are now upstream. - GObject: Move *.typelib file to base gobject package.
This commit is contained in:
parent
c6613f1d9d
commit
89a91a84cc
1
.gitignore
vendored
1
.gitignore
vendored
@ -133,3 +133,4 @@ libguestfs-1.5.3.tar.gz
|
||||
/libguestfs-1.15.17.tar.gz
|
||||
/libguestfs-1.15.18.tar.gz
|
||||
/libguestfs-1.15.19.tar.gz
|
||||
/libguestfs-1.16.0.tar.gz
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 4f868b84d6e7c387e27f50aae54476bc97a70bc2 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 22 Jan 2012 14:38:07 +0000
|
||||
Subject: [PATCH 1/2] php: Enable 'make clean' in extension subdirectory.
|
||||
|
||||
---
|
||||
php/Makefile.am | 8 ++++----
|
||||
1 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/php/Makefile.am b/php/Makefile.am
|
||||
index 828960c..7652b66 100644
|
||||
--- a/php/Makefile.am
|
||||
+++ b/php/Makefile.am
|
||||
@@ -49,10 +49,10 @@ extension/config.h: extension/config.m4 ../config.status
|
||||
|
||||
TESTS = run-php-tests.sh
|
||||
|
||||
-# Amazingly the PHP-installed extension Makefile doesn't have a
|
||||
-# 'make clean' rule.
|
||||
-#clean-local:
|
||||
-# $(MAKE) -C extension clean
|
||||
+# Before PHP 5.4.0, the extension directory didn't have a 'make clean'
|
||||
+# rule. Therefore, don't die if this fails.
|
||||
+clean-local:
|
||||
+ -$(MAKE) -C extension clean
|
||||
|
||||
install-data-hook:
|
||||
$(MAKE) -C extension INSTALL_ROOT=$(DESTDIR) install
|
||||
--
|
||||
1.7.6
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 5cfd3e7b3e1a7a4031f676d5b65392c7de113164 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 22 Jan 2012 14:47:43 +0000
|
||||
Subject: [PATCH 2/2] php: function_entry -> zend_function_entry.
|
||||
|
||||
function_entry was left over from PHP 3.
|
||||
|
||||
See: http://news.php.net/php.pecl.dev/7123
|
||||
---
|
||||
generator/generator_php.ml | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/generator/generator_php.ml b/generator/generator_php.ml
|
||||
index 5e7294c..6038fb7 100644
|
||||
--- a/generator/generator_php.ml
|
||||
+++ b/generator/generator_php.ml
|
||||
@@ -106,7 +106,7 @@ PHP_MINIT_FUNCTION (guestfs_php)
|
||||
NULL, PHP_GUESTFS_HANDLE_RES_NAME, module_number);
|
||||
}
|
||||
|
||||
-static function_entry guestfs_php_functions[] = {
|
||||
+static zend_function_entry guestfs_php_functions[] = {
|
||||
PHP_FE (guestfs_create, NULL)
|
||||
PHP_FE (guestfs_last_error, NULL)
|
||||
";
|
||||
--
|
||||
1.7.6
|
||||
|
@ -29,22 +29,18 @@
|
||||
Summary: Access and modify virtual machine disk images
|
||||
Name: libguestfs
|
||||
Epoch: 1
|
||||
Version: 1.15.19
|
||||
Version: 1.16.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
URL: http://libguestfs.org/
|
||||
Source0: http://libguestfs.org/download/1.15-development/%{name}-%{version}.tar.gz
|
||||
Source0: http://libguestfs.org/download/1.16-stable/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
||||
%if 0%{?rhel} >= 7
|
||||
ExclusiveArch: x86_64
|
||||
%endif
|
||||
|
||||
# Two upstream patches for PHP 5.4.
|
||||
Patch1: 0001-php-Enable-make-clean-in-extension-subdirectory.patch
|
||||
Patch2: 0002-php-function_entry-zend_function_entry.patch
|
||||
|
||||
# Basic build requirements:
|
||||
BuildRequires: /usr/bin/pod2man
|
||||
BuildRequires: /usr/bin/pod2text
|
||||
@ -629,9 +625,6 @@ for %{name}.
|
||||
|
||||
mkdir -p daemon/m4
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
# Replace developer-specific README that ships with libguestfs, with
|
||||
# our replacement file.
|
||||
mv README README.orig
|
||||
@ -1005,13 +998,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%files gobject
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libguestfs-gobject-1.0.so.0*
|
||||
%{_libdir}/girepository-1.0/Guestfs-1.0.typelib
|
||||
|
||||
|
||||
%files gobject-devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libguestfs-gobject-1.0.so
|
||||
%{_includedir}/guestfs-gobject.h
|
||||
%{_libdir}/girepository-1.0/Guestfs-1.0.typelib
|
||||
%{_datadir}/gir-1.0/Guestfs-1.0.gir
|
||||
|
||||
|
||||
@ -1022,6 +1015,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 23 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.16.0-1
|
||||
- New upstream version 1.16.0.
|
||||
- Remove patches which are now upstream.
|
||||
- GObject: Move *.typelib file to base gobject package.
|
||||
|
||||
* Sun Jan 22 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.15.19-1
|
||||
- New upstream version 1.15.19.
|
||||
- +BR psmisc for the appliance.
|
||||
|
Loading…
Reference in New Issue
Block a user