import libguestfs-1.38.4-15.module+el8.2.0+5297+222a20af

This commit is contained in:
CentOS Sources 2020-01-21 13:49:47 -05:00 committed by Stepan Oksanichenko
parent 7becdcac66
commit 8211d91639
23 changed files with 115 additions and 129 deletions

View File

@ -26,13 +26,13 @@ API of our OCaml Yajl module.
contrib/p2v/aux-scripts/do-build.sh | 8 +-
contrib/p2v/build-p2v-iso.sh | 3 +-
daemon/Makefile.am | 4 +-
daemon/ldm.c | 113 ++++++++++++----------------
daemon/ldm.c | 115 ++++++++++++----------------
docs/guestfs-building.pod | 2 +-
lib/Makefile.am | 4 +-
lib/info.c | 113 +++++++++++-----------------
lib/info.c | 113 +++++++++++----------------
lib/qemu.c | 64 ++++++----------
m4/guestfs-libraries.m4 | 4 +-
12 files changed, 168 insertions(+), 230 deletions(-)
12 files changed, 169 insertions(+), 231 deletions(-)
diff --git a/appliance/packagelist.in b/appliance/packagelist.in
index 8ded2588a..f92a6ce95 100644
@ -472,6 +472,10 @@ index 2f4d2aef3..be4fb9701 100644
- if (! YAJL_IS_OBJECT (tree))
+ if (!json_is_object (tree))
+ goto bad_type;
+
+ node = json_object_get (tree, key);
+ if (node == NULL)
goto bad_type;
- len = YAJL_GET_OBJECT (tree)->len;
@ -491,10 +495,7 @@ index 2f4d2aef3..be4fb9701 100644
- reply_with_perror ("strdup");
-
- yajl_tree_free (tree);
+ node = json_object_get (tree, key);
+ if (node == NULL)
+ goto bad_type;
-
- return ret;
- }
+ if ((flags & GET_STRING_NULL_TO_EMPTY) && json_is_null (node))
@ -796,10 +797,10 @@ index 93fadcd39..2eadc1c11 100644
- /* 'input' is not \0-terminated; we have to make it so. */
- input_copy = safe_strndup (g, input, len);
-
- debug (g, "%s: qemu-img info JSON output:\n%s\n", __func__, input_copy);
+ debug (g, "%s: qemu-img info JSON output:\n%.*s\n", __func__, (int) len, input);
- debug (g, "%s: qemu-img info JSON output:\n%s\n", __func__, input_copy);
-
- *tree_ret = yajl_tree_parse (input_copy, parse_error, sizeof parse_error);
+ *tree_ret = json_loadb (input, len, 0, &err);
if (*tree_ret == NULL) {

View File

@ -0,0 +1,49 @@
From 06e5cfb90bc63f1d6c56821f0745c6fa8d3f8259 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 25 Jul 2019 14:52:42 +0100
Subject: [PATCH] v2v: -i vmx: Use scp -T option if available to unbreak scp
(RHBZ#1733168).
Tested using:
cd v2v
LIBGUESTFS_BACKEND=direct ../run virt-v2v -i vmx -it ssh "ssh://localhost/$PWD/test-v2v-i-vmx-1.vmx" -o null -v -x
and manually examining the debug output.
Thanks: Ming Xie, Jakub Jelen.
(cherry picked from commit 7692c31494f7b1d37e380eed9eb99c5952940dbf)
---
v2v/input_vmx.ml | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/v2v/input_vmx.ml b/v2v/input_vmx.ml
index f79e89139..695266313 100644
--- a/v2v/input_vmx.ml
+++ b/v2v/input_vmx.ml
@@ -61,6 +61,11 @@ let server_of_uri { Xml.uri_server } =
let path_of_uri { Xml.uri_path } =
match uri_path with None -> assert false | Some p -> p
+let scp_supports_T_option = lazy (
+ let cmd = "LANG=C scp -T |& grep \"unknown option\"" in
+ shell_command cmd <> 0
+)
+
(* 'scp' a remote file into a temporary local file, returning the path
* of the temporary local file.
*)
@@ -68,8 +73,9 @@ let scp_from_remote_to_temporary uri tmpdir filename =
let localfile = tmpdir // filename in
let cmd =
- sprintf "scp%s%s %s%s:%s %s"
+ sprintf "scp%s%s%s %s%s:%s %s"
(if verbose () then "" else " -q")
+ (if Lazy.force scp_supports_T_option then " -T" else "")
(match port_of_uri uri with
| None -> ""
| Some port -> sprintf " -P %d" port)
--
2.21.0

View File

@ -1,4 +1,4 @@
From 971869bb41ae36b15c7379d05c3159359ebf2161 Mon Sep 17 00:00:00 2001
From 23dcb04f1c8365df1a8ed7c0dd25081169f41571 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 21 Dec 2012 15:50:11 +0000
Subject: [PATCH] RHEL 8: Remove libguestfs live (RHBZ#798980).

View File

@ -1,4 +1,4 @@
From a04c7fcc8215bba8b513a5585760c9ed3ac7acdd Mon Sep 17 00:00:00 2001
From 192ac41979f7b7b1f029843a7915cf40b0535e5f Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 18 Jul 2013 18:31:53 +0100
Subject: [PATCH] RHEL 8: Remove 9p APIs from RHEL (RHBZ#921710).

View File

@ -1,4 +1,4 @@
From d170b6103d7f4665ec03dd09c57ab143750961cd Mon Sep 17 00:00:00 2001
From 2555618f32772df00f3ceb4a780d6c13f7b3d93c Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 29 Jul 2013 14:47:56 +0100
Subject: [PATCH] RHEL 8: Disable unsupported remote drive protocols

View File

@ -1,4 +1,4 @@
From 34e859c5be365b8fcc3b1820510827d47225fbfd Mon Sep 17 00:00:00 2001
From 8d63a3e4116dfe165b7d68086195b5ed2be5cd14 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 19 Sep 2014 13:38:20 +0100
Subject: [PATCH] RHEL 8: Remove User-Mode Linux (RHBZ#1144197).

View File

@ -1,4 +1,4 @@
From ca22b5f7dadb68377930983df5022bd18dafd9d4 Mon Sep 17 00:00:00 2001
From 21ef3ee84af1b42d19659033132b2c22f7c611e4 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 28 Sep 2014 19:14:43 +0100
Subject: [PATCH] RHEL 8: v2v: Select correct qemu binary for -o qemu mode

View File

@ -1,4 +1,4 @@
From 87246cffca0acc026b44538b546fa8fb52f40b69 Mon Sep 17 00:00:00 2001
From 1219acf26ca0805cabe43c1841e4d4a82095f60d Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 30 Sep 2014 10:50:27 +0100
Subject: [PATCH] RHEL 8: v2v: Disable the --qemu-boot option (RHBZ#1147313).

View File

@ -1,4 +1,4 @@
From c949df01b8183a4add1c028a949573830b86be6c Mon Sep 17 00:00:00 2001
From 36cf9904d4a5f2662cb5ffcca732fc2b57450aba Mon Sep 17 00:00:00 2001
From: Pino Toscano <ptoscano@redhat.com>
Date: Fri, 24 Oct 2014 16:33:50 +0100
Subject: [PATCH] RHEL 8: Disable alternate Augeas lenses.

View File

@ -1,4 +1,4 @@
From acc1c8ac04db2aa30df5545c1b90bbca76715fed Mon Sep 17 00:00:00 2001
From 61ef6194eeb687b4fbfa73e6392091aaf2404241 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 24 Apr 2015 09:45:41 -0400
Subject: [PATCH] RHEL 8: Fix list of supported sound cards to match RHEL qemu

View File

@ -1,4 +1,4 @@
From b2f24b3168b1a521a07639c7db2179146aea2611 Mon Sep 17 00:00:00 2001
From 6ddcb894bc275079d1fb25554d91ca9f4b921406 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 7 Jul 2015 09:28:03 -0400
Subject: [PATCH] RHEL 8: Reject use of libguestfs-winsupport features except

View File

@ -1,4 +1,4 @@
From 7fe7632cbd7ac33b16d8657d8b7f5e10e39e6919 Mon Sep 17 00:00:00 2001
From 57bbc9d79d21c23becc9391b46944e8a992bd6ec Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 30 Aug 2015 03:21:57 -0400
Subject: [PATCH] RHEL 8: Fix tests for libguestfs-winsupport.

View File

@ -1,4 +1,4 @@
From cc529d518116d64c0646d56226dda338cdee12dd Mon Sep 17 00:00:00 2001
From b0399c4e709f9d94e796bbeda90d27e3ed0dc43d Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 21 Sep 2015 15:49:17 +0100
Subject: [PATCH] RHEL 8: Revert "v2v: Add a support matrix to the manual

View File

@ -1,4 +1,4 @@
From a693479f45f1abc1f5a4ce45573c8f72e020e3b8 Mon Sep 17 00:00:00 2001
From 6918c7618f6e1b48704e7aa6f6b05ed8b926d589 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 21 Sep 2015 13:12:43 -0400
Subject: [PATCH] RHEL 8: tests: Disable daemon tests that require the 'unix'

View File

@ -1,4 +1,4 @@
From 4bdd05ea3ca6cfdeda7a9917593287d6e5ca3504 Mon Sep 17 00:00:00 2001
From 690b8d0d2bcd7dc1b5f3c37a3133e89bae97863e Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 14 Jan 2016 11:53:42 -0500
Subject: [PATCH] RHEL 8: v2v: Disable the virt-v2v --in-place option.

View File

@ -1,4 +1,4 @@
From 420cc275e5b726036eba297cd8e233a8c0202900 Mon Sep 17 00:00:00 2001
From 86447cac9a58c0a6499fff76d45dd56423979bbe Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 2 Mar 2017 14:21:37 +0100
Subject: [PATCH] RHEL 8: v2v: -i disk: force VNC as display (RHBZ#1372671)

View File

@ -1,4 +1,4 @@
From e9420425661f7540abea2fecd3b96297d82f88f6 Mon Sep 17 00:00:00 2001
From 91c7b5c4042b07fb4e35669dec6d445252c8c9f6 Mon Sep 17 00:00:00 2001
From: Pino Toscano <ptoscano@redhat.com>
Date: Wed, 8 Mar 2017 11:03:40 +0100
Subject: [PATCH] RHEL 8: v2v: do not mention SUSE Xen hosts (RHBZ#1430203)

View File

@ -1,4 +1,4 @@
From f8744ea342d625d6b913d9e0ab55e51b67df41f7 Mon Sep 17 00:00:00 2001
From c7c2cc23088861d032a59d4886973eab78958962 Mon Sep 17 00:00:00 2001
From: Pino Toscano <ptoscano@redhat.com>
Date: Mon, 14 Aug 2017 10:02:13 +0200
Subject: [PATCH] RHEL 8: v2v: disable unconfig of manually installed VMware

View File

@ -1,33 +0,0 @@
From 487a2f29da2b1b7d11bed0299f766b81e6c5cea8 Mon Sep 17 00:00:00 2001
From: Pino Toscano <ptoscano@redhat.com>
Date: Thu, 19 Jul 2018 13:30:17 +0200
Subject: [PATCH] RHEL 8: p2v: ignore 'rhv-upload' driver (RHBZ#1590220)
The 'rhv-upload' output mode requires few options, and virt-p2v does not
have the GUI bits for specifying them.
---
p2v/ssh.c | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/p2v/ssh.c b/p2v/ssh.c
index 15f53b692..654121a22 100644
--- a/p2v/ssh.c
+++ b/p2v/ssh.c
@@ -1021,8 +1021,12 @@ add_input_driver (const char *name, size_t len)
static void
add_output_driver (const char *name, size_t len)
{
- /* Ignore the 'vdsm' driver, since that should only be used by VDSM. */
- if (len != 4 || memcmp (name, "vdsm", 4) != 0)
+ /* Ignore the 'vdsm' driver, since that should only be used by VDSM.
+ * Ignore the 'rhv-upload' driver, since we do not support passing all the
+ * options for it.
+ */
+ if ((len != 4 || memcmp (name, "vdsm", 4) != 0) &&
+ (len != 10 || memcmp (name, "rhv-upload", 10) != 0))
add_option ("output", &output_drivers, name, len);
}
--
2.21.0

View File

@ -1,4 +1,4 @@
From 9e1cdc63a5588b6b21924c9f5a5861a81a0e630c Mon Sep 17 00:00:00 2001
From a609448f0401c82b306c44fb015893a7d4a6be27 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 14 May 2018 10:16:58 +0100
Subject: [PATCH] RHEL 8: v2v: rhv-upload: Remove restriction on -oa sparse.

View File

@ -1,4 +1,4 @@
From d96615720d0e5b4bdf397275534544f2744f72a6 Mon Sep 17 00:00:00 2001
From ff4f831122bd04c77d4363042eab4b82ad789c6b Mon Sep 17 00:00:00 2001
From: Pino Toscano <ptoscano@redhat.com>
Date: Sun, 16 Dec 2018 16:32:46 +0100
Subject: [PATCH] RHEL 8: use "python3" as nbdkit plugin

View File

@ -1,4 +1,4 @@
From ccd28a6b0178c0bbd4a04e9a65932a9b3a1dbdd9 Mon Sep 17 00:00:00 2001
From 83e68a8844c9c20fbee98dc784fd82f60e225417 Mon Sep 17 00:00:00 2001
From: Pino Toscano <ptoscano@redhat.com>
Date: Sun, 16 Dec 2018 16:42:46 +0100
Subject: [PATCH] RHEL 8: use platform-python

View File

@ -37,7 +37,7 @@ Summary: Access and modify virtual machine disk images
Name: libguestfs
Epoch: 1
Version: 1.38.4
Release: 12%{?dist}
Release: 15%{?dist}
License: LGPLv2+
# Source and patches.
@ -118,24 +118,24 @@ Patch0060: 0060-inspect-fix-icon-of-RHEL.patch
Patch0061: 0061-inspect-fix-inspection-of-partition-less-devices-RHB.patch
Patch0062: 0062-v2v-update-documentation-on-nbdkit-RHBZ-1605242.patch
Patch0063: 0063-Use-proper-label-for-nbdkit-sockets.patch
Patch0064: 0064-RHEL-8-Remove-libguestfs-live-RHBZ-798980.patch
Patch0065: 0065-RHEL-8-Remove-9p-APIs-from-RHEL-RHBZ-921710.patch
Patch0066: 0066-RHEL-8-Disable-unsupported-remote-drive-protocols-RH.patch
Patch0067: 0067-RHEL-8-Remove-User-Mode-Linux-RHBZ-1144197.patch
Patch0068: 0068-RHEL-8-v2v-Select-correct-qemu-binary-for-o-qemu-mod.patch
Patch0069: 0069-RHEL-8-v2v-Disable-the-qemu-boot-option-RHBZ-1147313.patch
Patch0070: 0070-RHEL-8-Disable-alternate-Augeas-lenses.patch
Patch0071: 0071-RHEL-8-Fix-list-of-supported-sound-cards-to-match-RH.patch
Patch0072: 0072-RHEL-8-Reject-use-of-libguestfs-winsupport-features-.patch
Patch0073: 0073-RHEL-8-Fix-tests-for-libguestfs-winsupport.patch
Patch0074: 0074-RHEL-8-Revert-v2v-Add-a-support-matrix-to-the-manual.patch
Patch0075: 0075-RHEL-8-tests-Disable-daemon-tests-that-require-the-u.patch
Patch0076: 0076-RHEL-8-v2v-Disable-the-virt-v2v-in-place-option.patch
Patch0077: 0077-RHEL-8-v2v-i-disk-force-VNC-as-display-RHBZ-1372671.patch
Patch0078: 0078-RHEL-8-v2v-do-not-mention-SUSE-Xen-hosts-RHBZ-143020.patch
Patch0079: 0079-RHEL-8-v2v-disable-unconfig-of-manually-installed-VM.patch
Patch0080: 0080-RHEL-8-v2v-rhv-upload-Remove-restriction-on-oa-spars.patch
Patch0081: 0081-RHEL-8-p2v-ignore-rhv-upload-driver-RHBZ-1590220.patch
Patch0064: 0064-v2v-i-vmx-Use-scp-T-option-if-available-to-unbreak-s.patch
Patch0065: 0065-RHEL-8-Remove-libguestfs-live-RHBZ-798980.patch
Patch0066: 0066-RHEL-8-Remove-9p-APIs-from-RHEL-RHBZ-921710.patch
Patch0067: 0067-RHEL-8-Disable-unsupported-remote-drive-protocols-RH.patch
Patch0068: 0068-RHEL-8-Remove-User-Mode-Linux-RHBZ-1144197.patch
Patch0069: 0069-RHEL-8-v2v-Select-correct-qemu-binary-for-o-qemu-mod.patch
Patch0070: 0070-RHEL-8-v2v-Disable-the-qemu-boot-option-RHBZ-1147313.patch
Patch0071: 0071-RHEL-8-Disable-alternate-Augeas-lenses.patch
Patch0072: 0072-RHEL-8-Fix-list-of-supported-sound-cards-to-match-RH.patch
Patch0073: 0073-RHEL-8-Reject-use-of-libguestfs-winsupport-features-.patch
Patch0074: 0074-RHEL-8-Fix-tests-for-libguestfs-winsupport.patch
Patch0075: 0075-RHEL-8-Revert-v2v-Add-a-support-matrix-to-the-manual.patch
Patch0076: 0076-RHEL-8-tests-Disable-daemon-tests-that-require-the-u.patch
Patch0077: 0077-RHEL-8-v2v-Disable-the-virt-v2v-in-place-option.patch
Patch0078: 0078-RHEL-8-v2v-i-disk-force-VNC-as-display-RHBZ-1372671.patch
Patch0079: 0079-RHEL-8-v2v-do-not-mention-SUSE-Xen-hosts-RHBZ-143020.patch
Patch0080: 0080-RHEL-8-v2v-disable-unconfig-of-manually-installed-VM.patch
Patch0081: 0081-RHEL-8-v2v-rhv-upload-Remove-restriction-on-oa-spars.patch
Patch0082: 0082-RHEL-8-use-python3-as-nbdkit-plugin.patch
Patch0083: 0083-RHEL-8-use-platform-python.patch
@ -215,8 +215,6 @@ BuildRequires: /usr/bin/ping
BuildRequires: /usr/bin/wget
BuildRequires: curl
BuildRequires: xz
BuildRequires: gtk3-devel
BuildRequires: dbus-devel
BuildRequires: /usr/bin/qemu-img
BuildRequires: perl(Win::Hivex)
BuildRequires: perl(Win::Hivex::Regedit)
@ -636,32 +634,6 @@ Virt-v2v converts virtual machines from non-KVM hypervisors
to run under KVM.
To convert physical machines, see the virt-p2v-maker package.
%package -n virt-p2v-maker
Summary: Convert a physical machine to run on KVM
License: GPLv2+
Requires: gawk
Requires: gzip
# virt-p2v-make-disk runs virt-builder:
Requires: %{name}-tools-c = %{epoch}:%{version}-%{release}
# virt-p2v-make-kickstart runs strip:
Requires: binutils
%description -n virt-p2v-maker
Virt-p2v converts (virtualizes) physical machines so they can be run
as virtual machines under KVM.
This package contains the tools needed to make a virt-p2v boot CD or
USB key which is booted on the physical machine to perform the
conversion. You also need virt-v2v installed somewhere else to
complete the conversion.
To convert virtual machines from other hypervisors, see virt-v2v.
%endif
@ -881,6 +853,7 @@ export PYTHON=%{__python3}
--disable-haskell \
--disable-erlang \
--disable-golang \
--with-gtk=no \
$extra
# Building index-parse.c by hand works around a race condition in the
@ -996,12 +969,8 @@ cp %{SOURCE96} $RPM_BUILD_ROOT%{_datadir}/virt-tools/rhsrvany.exe
cp %{SOURCE97} $RPM_BUILD_ROOT%{_datadir}/virt-tools/rhev-apt.exe
%ifnarch %{v2v_arches}
rm $RPM_BUILD_ROOT%{_bindir}/virt-p2v*
rm $RPM_BUILD_ROOT%{_bindir}/virt-v2v*
rm $RPM_BUILD_ROOT%{_mandir}/man1/virt-p2v*
rm $RPM_BUILD_ROOT%{_mandir}/man1/virt-v2v*
rm -r $RPM_BUILD_ROOT%{_libdir}/virt-p2v
rm -r $RPM_BUILD_ROOT%{_datadir}/virt-p2v
rm -r $RPM_BUILD_ROOT%{_datadir}/virt-tools
%endif
@ -1012,15 +981,13 @@ rm -rf $RPM_BUILD_ROOT%{_libdir}/ocaml/v2v_test_harness
rm -rf $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllv2v_test_harness*
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/virt-v2v-test-harness.1*
%ifarch %{v2v_arches}
# Delete kiwi tools.
rm $RPM_BUILD_ROOT%{_bindir}/virt-p2v-make-kiwi
rm $RPM_BUILD_ROOT%{_mandir}/man1/virt-p2v-make-kiwi.1*
%endif
# Remove the .gitignore file from ocaml/html which will be copied to docdir.
rm ocaml/html/.gitignore
# Delete virt-p2v bash completion files, as virt-p2v was moved
# to its own source.
rm $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/virt-p2v-*
%ifarch %{benchmark_arches}
# Copy the benchmarking tools and man pages, since upstream doesn't
# install them by default. NB Don't install the libtool wrapper scripts.
@ -1190,17 +1157,6 @@ install -m 0644 utils/boot-benchmark/boot-benchmark.1 $RPM_BUILD_ROOT%{_mandir}/
%{_mandir}/man1/virt-v2v.1*
%{_mandir}/man1/virt-v2v-copy-to-local.1*
%{_datadir}/virt-tools
%files -n virt-p2v-maker
%doc COPYING README
%{_bindir}/virt-p2v-make-disk
%{_bindir}/virt-p2v-make-kickstart
%{_mandir}/man1/virt-p2v.1*
%{_mandir}/man1/virt-p2v-make-disk.1*
%{_mandir}/man1/virt-p2v-make-kickstart.1*
%{_datadir}/virt-p2v
%{_libdir}/virt-p2v
%endif
@ -1304,6 +1260,19 @@ install -m 0644 utils/boot-benchmark/boot-benchmark.1 $RPM_BUILD_ROOT%{_mandir}/
%changelog
* Tue Dec 10 2019 Pino Toscano <ptoscano@redhat.com> - 1:1.38.4-15
- Stop building virt-p2v-maker, as it will be built by its own source
resolves: rhbz#1777924
* Thu Aug 08 2019 Pino Toscano <ptoscano@redhat.com> - 1:1.38.4-14
- v2v: use -T as argument of scp when copying vmx files via ssh
resolves: rhbz#1738886
* Fri Jun 28 2019 Danilo de Paula <ddepaula@redhat.com>
- Rebuild all virt packages to fix RHEL's upgrade path
- Resolves: rhbz#1695587
(Ensure modular RPM upgrade path)
* Wed Jun 05 2019 Pino Toscano <ptoscano@redhat.com> - 1:1.38.4-12
- v2v: update nbdkit information in documentation
resolves: rhbz#1651115