New development branch 1.43.

Remove upstream patches.
This commit is contained in:
Richard W.M. Jones 2020-07-06 16:30:14 +01:00
parent f38735b278
commit 813ffc39ae
4 changed files with 9 additions and 110 deletions

View File

@ -1,58 +0,0 @@
From 94ff24b8800ebc79f19bd686ec2dda393906c454 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 6 May 2020 12:31:56 +0100
Subject: [PATCH] appliance: Set default guestfs appliance path to
$libdir/guestfs.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
For unclear reasons this broke recently, although the breakage is only
reproducible in Fedora Koji. It appears to be caused by the
calculation of the internal autoconf variable $acl_libdirstem
changing. In the reproducer system:
checking for the common suffixes of directories in the library search path... lib,lib,lib64
On my local system:
checking for the common suffixes of directories in the library search path... lib64,lib64
My local system would be the correct one. The actual code that
calculates this does some crazy stuff with gcc -print-search-dirs
which would hint that this output has changed in some way that subtly
breaks the generated configure script. However even with match GCC
versions on my local system I could still not reproduce the issue.
None of this matters, as the easiest fix here is simply to stop using
internal autoconf variables at all. I also added some AC_MSG_*
statements so we can more easily see what's going on in the configure
output.
Fixes commit 0f79400c7f3d69e1a5d67f7f56c9bd7e3584aae9.
---
m4/guestfs-appliance.m4 | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/m4/guestfs-appliance.m4 b/m4/guestfs-appliance.m4
index 3cb7f5b42..a7f7d8321 100644
--- a/m4/guestfs-appliance.m4
+++ b/m4/guestfs-appliance.m4
@@ -126,11 +126,13 @@ AC_ARG_WITH([extra-packages],
AC_SUBST([EXTRA_PACKAGES])
dnl Set guestfs default path
+AC_MSG_CHECKING([for guestfs path])
AC_ARG_WITH([guestfs-path],
[AS_HELP_STRING([--with-guestfs-path=PATH],
[specify guestfs path (default=$libdir/guestfs)])],
[GUESTFS_DEFAULT_PATH="$withval"],
- [GUESTFS_DEFAULT_PATH="${acl_final_exec_prefix}/${acl_libdirstem}/guestfs"])
+ [GUESTFS_DEFAULT_PATH="$libdir/guestfs"])
+AC_MSG_RESULT([$GUESTFS_DEFAULT_PATH])
AC_SUBST([GUESTFS_DEFAULT_PATH])
AC_DEFINE_UNQUOTED([GUESTFS_DEFAULT_PATH], ["$GUESTFS_DEFAULT_PATH"],
--
2.24.1

View File

@ -1,41 +0,0 @@
From 31e6b187100626cae44bcb505db153088245155c Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 9 Mar 2020 17:31:55 +0000
Subject: [PATCH] po: Remove virt-v2v related dependency from POTFILES-ml.
Causes this error if you compile libguestfs 1.42.0 from the tarball
without invoking the generator:
make[4]: *** No rule to make target '../common/mlv2v/uefi.ml', needed by 'libguestfs.pot'. Stop.
---
Makefile.am | 1 +
po/POTFILES-ml | 1 -
2 files changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index 27f2c6eed..2f0446d60 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -345,6 +345,7 @@ po/POTFILES-ml: configure.ac
cd $(srcdir); \
find builder common/ml* customize dib get-kernel resize sparsify sysprep -name '*.ml' | \
grep -v '^builder/templates/' | \
+ grep -v '^common/mlv2v/' | \
grep -v -E '.*_tests\.ml$$' | \
LC_ALL=C sort > $@-t
mv $@-t $@
diff --git a/po/POTFILES-ml b/po/POTFILES-ml
index a9b6efdaa..2fbdff03d 100644
--- a/po/POTFILES-ml
+++ b/po/POTFILES-ml
@@ -41,7 +41,6 @@ common/mltools/urandom.ml
common/mltools/xpath_helpers.ml
common/mlutils/c_utils.ml
common/mlutils/unix_utils.ml
-common/mlv2v/uefi.ml
common/mlvisit/visit.ml
common/mlxml/xml.ml
customize/append_line.ml
--
2.25.0

View File

@ -33,7 +33,7 @@
%global patches_touch_autotools 1
# The source directory.
%global source_directory 1.42-stable
%global source_directory 1.43-development
# Filter perl provides.
%{?perl_default_filter}
@ -44,8 +44,8 @@
Summary: Access and modify virtual machine disk images
Name: libguestfs
Epoch: 1
Version: 1.42.0
Release: 8%{?dist}
Version: 1.43.1
Release: 1%{?dist}
License: LGPLv2+
# No kernel https://fedoraproject.org/wiki/Changes/Stop_Building_i686_Kernels
@ -76,12 +76,6 @@ Source7: libguestfs.keyring
BuildRequires: autoconf, automake, libtool, gettext-devel
%endif
# Upstream patch which fixes build from tarball.
Patch1: 0001-po-Remove-virt-v2v-related-dependency-from-POTFILES-.patch
# Fix path to libguestfs appliance.
Patch2: 0001-appliance-Set-default-guestfs-appliance-path-to-libd.patch
# Basic build requirements for the library and virt tools.
BuildRequires: gcc, gcc-c++
BuildRequires: rpcgen
@ -1191,6 +1185,10 @@ rm ocaml/html/.gitignore
%changelog
* Mon Jul 6 2020 Richard W.M. Jones <rjones@redhat.com> - 1:1.43.1-1
- New development branch 1.43.
- Remove upstream patches.
* Thu Jun 25 2020 Jitka Plesnikova <jplesnik@redhat.com> - 1:1.42.0-8
- Perl 5.32 rebuild

View File

@ -1,2 +1,2 @@
SHA512 (libguestfs-1.42.0.tar.gz) = cb53377582506c3fd3dec27482bef60c9204f63f05bbab8317fb7a02169f0fe1a4c4fb816513e5fa296bda3791cde4155adca6f18759a98db17f6d9b63637a30
SHA512 (libguestfs-1.42.0.tar.gz.sig) = 68cef3d4d1cd6fd31b5f390ea55b1b03c789dfe85f3297cdb6214abec8be4833721ec8393b7d962931dd947df814613f4e22b4959817207b27bea4d02b775ac6
SHA512 (libguestfs-1.43.1.tar.gz) = 66a9c24d7cbf5feaf83563a4c6ad6bc7a8f4dacc98c53cf8c493140992f3bd2244f47b8e769c1f7c4052661daf6fc288ef0d489942fbf80900b824d737a8d15a
SHA512 (libguestfs-1.43.1.tar.gz.sig) = 77630060016c776b6127663b3a5e6b9cfc12409d53f47b9ee5acbd5225ee144616cf55674c896bbb24bdcf10f54df970160c3db56b068be7fef83c71489f89c6