Include further fixes to virt-resize from upstream.
This commit is contained in:
parent
c64aa4371e
commit
6659e73510
@ -1,7 +1,7 @@
|
|||||||
From 047173d18683a66cbe8949bc114833984898fed6 Mon Sep 17 00:00:00 2001
|
From 047173d18683a66cbe8949bc114833984898fed6 Mon Sep 17 00:00:00 2001
|
||||||
From: Richard W.M. Jones <rjones@redhat.com>
|
From: Richard W.M. Jones <rjones@redhat.com>
|
||||||
Date: Sat, 9 Apr 2011 22:50:15 +0100
|
Date: Sat, 9 Apr 2011 22:50:15 +0100
|
||||||
Subject: [PATCH] resize: Link with local copy of guestfs.
|
Subject: [PATCH 1/3] resize: Link with local copy of guestfs.
|
||||||
|
|
||||||
---
|
---
|
||||||
resize/Makefile.am | 4 ++--
|
resize/Makefile.am | 4 ++--
|
||||||
|
25
0002-resize-Missing-n-after-version.patch
Normal file
25
0002-resize-Missing-n-after-version.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 61a42ff551073daf345bd03941797e6af1e97128 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Richard W.M. Jones <rjones@redhat.com>
|
||||||
|
Date: Sun, 10 Apr 2011 11:06:58 +0100
|
||||||
|
Subject: [PATCH 2/3] resize: Missing \n after version.
|
||||||
|
|
||||||
|
---
|
||||||
|
resize/resize.ml | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/resize/resize.ml b/resize/resize.ml
|
||||||
|
index 9a4c86b..dc5540f 100644
|
||||||
|
--- a/resize/resize.ml
|
||||||
|
+++ b/resize/resize.ml
|
||||||
|
@@ -35,7 +35,7 @@ let infile, outfile, copy_boot_loader, debug, deletes, dryrun,
|
||||||
|
let display_version () =
|
||||||
|
let g = new G.guestfs () in
|
||||||
|
let version = g#version () in
|
||||||
|
- printf "virt-resize %Ld.%Ld.%Ld%s"
|
||||||
|
+ printf "virt-resize %Ld.%Ld.%Ld%s\n"
|
||||||
|
version.G.major version.G.minor version.G.release version.G.extra;
|
||||||
|
exit 0
|
||||||
|
in
|
||||||
|
--
|
||||||
|
1.7.4.1
|
||||||
|
|
41
0003-resize-Consistent-use-of-part-in-help-output.patch
Normal file
41
0003-resize-Consistent-use-of-part-in-help-output.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
From a6cb8fee205b1615d380456964bebe40bd840fb1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Richard W.M. Jones <rjones@redhat.com>
|
||||||
|
Date: Sun, 10 Apr 2011 11:12:03 +0100
|
||||||
|
Subject: [PATCH 3/3] resize: Consistent use of 'part' in help output.
|
||||||
|
|
||||||
|
---
|
||||||
|
resize/resize.ml | 8 ++++----
|
||||||
|
1 files changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/resize/resize.ml b/resize/resize.ml
|
||||||
|
index dc5540f..82fd765 100644
|
||||||
|
--- a/resize/resize.ml
|
||||||
|
+++ b/resize/resize.ml
|
||||||
|
@@ -72,12 +72,12 @@ let infile, outfile, copy_boot_loader, debug, deletes, dryrun,
|
||||||
|
"--no-copy-boot-loader", Arg.Clear copy_boot_loader, " Don't copy boot loader";
|
||||||
|
"-d", Arg.Set debug, " Enable debugging messages";
|
||||||
|
"--debug", Arg.Set debug, " -\"-";
|
||||||
|
- "--delete", Arg.String (add deletes), "dev Delete partition";
|
||||||
|
- "--expand", Arg.String set_expand, "dev Expand partition";
|
||||||
|
+ "--delete", Arg.String (add deletes), "part Delete partition";
|
||||||
|
+ "--expand", Arg.String set_expand, "part Expand partition";
|
||||||
|
"--no-expand-content", Arg.Clear expand_content, " Don't expand content";
|
||||||
|
"--no-extra-partition", Arg.Clear extra_partition, " Don't create extra partition";
|
||||||
|
"--format", Arg.Set_string format, "format Format of input disk";
|
||||||
|
- "--ignore", Arg.String (add ignores), "dev Ignore partition";
|
||||||
|
+ "--ignore", Arg.String (add ignores), "part Ignore partition";
|
||||||
|
"--lv-expand", Arg.String (add lv_expands), "lv Expand logical volume";
|
||||||
|
"--LV-expand", Arg.String (add lv_expands), "lv -\"-";
|
||||||
|
"--lvexpand", Arg.String (add lv_expands), "lv -\"-";
|
||||||
|
@@ -90,7 +90,7 @@ let infile, outfile, copy_boot_loader, debug, deletes, dryrun,
|
||||||
|
"--quiet", Arg.Set quiet, " -\"-";
|
||||||
|
"--resize", Arg.String (add resizes), "part=size Resize partition";
|
||||||
|
"--resize-force", Arg.String (add resizes_force), "part=size Forcefully resize partition";
|
||||||
|
- "--shrink", Arg.String set_shrink, "dev Shrink partition";
|
||||||
|
+ "--shrink", Arg.String set_shrink, "part Shrink partition";
|
||||||
|
"-V", Arg.Unit display_version, " Display version and exit";
|
||||||
|
"--version", Arg.Unit display_version, " -\"-";
|
||||||
|
] in
|
||||||
|
--
|
||||||
|
1.7.4.1
|
||||||
|
|
@ -30,7 +30,7 @@ Summary: Access and modify virtual machine disk images
|
|||||||
Name: libguestfs
|
Name: libguestfs
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.9.18
|
Version: 1.9.18
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
URL: http://libguestfs.org/
|
URL: http://libguestfs.org/
|
||||||
@ -40,9 +40,10 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
|||||||
# Disable FUSE tests, not supported in Koji at the moment.
|
# Disable FUSE tests, not supported in Koji at the moment.
|
||||||
Patch0: libguestfs-1.7.13-no-fuse-test.patch
|
Patch0: libguestfs-1.7.13-no-fuse-test.patch
|
||||||
|
|
||||||
# ocaml: Link with local copy of guestfs.
|
|
||||||
# Patch upstream in > 1.9.18.
|
# Patch upstream in > 1.9.18.
|
||||||
Patch1: 0001-resize-Link-with-local-copy-of-guestfs.patch
|
Patch1: 0001-resize-Link-with-local-copy-of-guestfs.patch
|
||||||
|
Patch2: 0002-resize-Missing-n-after-version.patch
|
||||||
|
Patch3: 0003-resize-Consistent-use-of-part-in-help-output.patch
|
||||||
|
|
||||||
# Basic build requirements:
|
# Basic build requirements:
|
||||||
BuildRequires: /usr/bin/pod2man
|
BuildRequires: /usr/bin/pod2man
|
||||||
@ -439,6 +440,8 @@ php-%{name} contains PHP bindings for %{name}.
|
|||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
mkdir -p daemon/m4
|
mkdir -p daemon/m4
|
||||||
|
|
||||||
@ -777,7 +780,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Apr 9 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.9.18-2
|
* Sun Apr 10 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.9.18-3
|
||||||
|
- Include further fixes to virt-resize from upstream.
|
||||||
|
|
||||||
|
* Sat Apr 9 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.9.18-2
|
||||||
- New upstream version 1.9.18.
|
- New upstream version 1.9.18.
|
||||||
- Requires ocaml-pcre for new virt-resize.
|
- Requires ocaml-pcre for new virt-resize.
|
||||||
- Remove libguestfs-test-tool-helper program which is no longer used.
|
- Remove libguestfs-test-tool-helper program which is no longer used.
|
||||||
|
Loading…
Reference in New Issue
Block a user