Remove unused patches.

Add -cpu max reversion patch again because RHEL 9 has libvirt < 7.1.

Fixes: commit 4ee6a19c6f
related: rhbz#1950627
This commit is contained in:
Richard W.M. Jones 2021-05-07 12:36:39 +01:00
parent 4ee6a19c6f
commit 241e9fe682
3 changed files with 7 additions and 187 deletions

View File

@ -1,60 +0,0 @@
From eb53d74ba2e5e9086a5ac8679d55e6a338397e07 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 23 Mar 2021 10:00:12 +0000
Subject: [PATCH 1/2] Don't include huge ChangeLog in the tarball.
Adds a few megabytes which people can easily get from the git
repository.
---
.gitignore | 1 -
Makefile.am | 9 +--------
2 files changed, 1 insertion(+), 9 deletions(-)
diff --git a/.gitignore b/.gitignore
index 716a9b2cd..f6e7d18e5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -81,7 +81,6 @@ Makefile.in
/build-aux/test-driver
/build-aux/ylwrap
/bundled/ocaml-augeas/.depend
-/ChangeLog
/compile
/config.cache
/config.guess
diff --git a/Makefile.am b/Makefile.am
index 9feac761b..743d2fbad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -215,15 +215,13 @@ maintainer-upload-website:
# When doing 'make dist' update a few files automatically.
#
# BUGS - list of bugs (created from Bugzilla)
-# ChangeLog - changelog (created from git)
# docs/C_SOURCE_FILES
# - source files scanned for internal documentation
# po/POTFILES - files with ordinary extensions, but not OCaml files
# po/POTFILES-ml - OCaml files, which need a special tool to translate
-dist-hook: BUGS ChangeLog docs/C_SOURCE_FILES po/POTFILES po/POTFILES-ml
+dist-hook: BUGS docs/C_SOURCE_FILES po/POTFILES po/POTFILES-ml
cp BUGS $(distdir)/BUGS
- cp ChangeLog $(distdir)/ChangeLog
BUGS: configure.ac
rm -f $@ $@-t
@@ -231,11 +229,6 @@ BUGS: configure.ac
$(top_srcdir)/update-bugs.sh > $@-t
mv $@-t $@
-ChangeLog: configure.ac
- rm -f $@ $@-t
- git log --decorate=false > $@-t
- mv $@-t $@
-
# This has to be in the top-level Makefile.am so that we have access
# to DIST_SUBDIRS.
docs/C_SOURCE_FILES: configure.ac
--
2.29.0.rc2

View File

@ -1,125 +0,0 @@
From 4991fe525961450704bbc80b5f2095bc8499f767 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 23 Mar 2021 11:08:42 +0000
Subject: [PATCH 2/2] bash-completion: Remove completion scripts for tools.
These have moved to guestfs-tools.
Fixes: commit 733d2182b64df7abc5c5cd7d78177baa6079628c
---
.gitignore | 19 ----------
bash/Makefile.am | 43 +---------------------
bash/{virt-alignment-scan => guestunmount} | 0
3 files changed, 2 insertions(+), 60 deletions(-)
rename bash/{virt-alignment-scan => guestunmount} (100%)
diff --git a/.gitignore b/.gitignore
index f6e7d18e5..a37ab0593 100644
--- a/.gitignore
+++ b/.gitignore
@@ -45,29 +45,10 @@ Makefile.in
/appliance/supermin.d
/AUTHORS
/autom4te.cache
-/bash/guestunmount
-/bash/virt-builder
-/bash/virt-cat
/bash/virt-copy-in
/bash/virt-copy-out
-/bash/virt-customize
-/bash/virt-df
-/bash/virt-dib
-/bash/virt-diff
-/bash/virt-edit
-/bash/virt-filesystems
-/bash/virt-format
-/bash/virt-get-kernel
-/bash/virt-inspector
-/bash/virt-log
-/bash/virt-ls
-/bash/virt-resize
-/bash/virt-sysprep
-/bash/virt-sparsify
-/bash/virt-tail
/bash/virt-tar-in
/bash/virt-tar-out
-/bash/virt-win-reg
/build-aux/.gitignore
/build-aux/ar-lib
/build-aux/compile
diff --git a/bash/Makefile.am b/bash/Makefile.am
index 23933806e..86f38d4af 100644
--- a/bash/Makefile.am
+++ b/bash/Makefile.am
@@ -20,35 +20,16 @@ include $(top_srcdir)/subdir-rules.mk
scripts = \
guestfish \
guestmount \
+ guestunmount \
libguestfs-test-tool \
- virt-alignment-scan \
virt-rescue
# Some of the scripts are simply symbolic links.
symlinks = \
- guestunmount \
- virt-builder \
- virt-cat \
virt-copy-in \
virt-copy-out \
- virt-customize \
- virt-diff \
- virt-df \
- virt-dib \
- virt-edit \
- virt-filesystems \
- virt-format \
- virt-get-kernel \
- virt-inspector \
- virt-log \
- virt-ls \
- virt-resize \
- virt-sparsify \
- virt-sysprep \
- virt-tail \
virt-tar-in \
- virt-tar-out \
- virt-win-reg
+ virt-tar-out
# Note: Don't distribute the symbolic links, only the real files.
EXTRA_DIST = \
@@ -59,26 +40,6 @@ EXTRA_DIST = \
CLEANFILES += \
$(symlinks)
-# Any tool that has --short-options and --long-options only is handled
-# by this common script.
-virt-win-reg:
- rm -f $@
- $(LN_S) libguestfs-test-tool $@
-
-# Any tool that has --short-options and --long-options and a few
-# common options like -d is handled by this common script. However
-# this script cannot deal with commands that use --ro/--rw
-# (eg. virt-rescue), nor commands that have lots of exceptions
-# (eg. guestfish). Those tools have to be handled individually.
-guestunmount \
-virt-builder virt-cat virt-customize virt-df virt-dib virt-diff \
-virt-edit virt-filesystems virt-format virt-get-kernel virt-inspector \
-virt-log virt-ls \
-virt-resize virt-sparsify virt-sysprep \
-virt-tail:
- rm -f $@
- $(LN_S) virt-alignment-scan $@
-
# guestfish is handled specially.
virt-copy-in virt-copy-out virt-tar-in virt-tar-out:
rm -f $@
diff --git a/bash/virt-alignment-scan b/bash/guestunmount
similarity index 100%
rename from bash/virt-alignment-scan
rename to bash/guestunmount
--
2.29.0.rc2

View File

@ -95,6 +95,11 @@ Source7: libguestfs.keyring
# Maintainer script which helps with handling patches. # Maintainer script which helps with handling patches.
Source8: copy-patches.sh Source8: copy-patches.sh
# Non-upstream patch which reverts (temporarily) libvirt cpu maximum.
# This feature requires libvirt 7.1 which is not currently available
# in Fedora 34.
Patch3: 0001-Revert-appliance-Use-cpu-mode-maximum-for-cpu-max-on.patch
# Downstream (RHEL-only) patches. # Downstream (RHEL-only) patches.
%if 0%{?rhel} %if 0%{?rhel}
Patch9001: 0001-RHEL-Remove-libguestfs-live-RHBZ-798980.patch Patch9001: 0001-RHEL-Remove-libguestfs-live-RHBZ-798980.patch
@ -146,7 +151,7 @@ BuildRequires: unzip
BuildRequires: systemd-units BuildRequires: systemd-units
BuildRequires: netpbm-progs BuildRequires: netpbm-progs
BuildRequires: icoutils BuildRequires: icoutils
BuildRequires: libvirt-daemon-kvm >= 7.1.0 #BuildRequires: libvirt-daemon-kvm >= 7.1.0
%if !0%{?rhel} %if !0%{?rhel}
BuildRequires: perl(Expect) BuildRequires: perl(Expect)
%endif %endif
@ -341,7 +346,7 @@ Suggests: qemu-block-iscsi
Suggests: qemu-block-rbd Suggests: qemu-block-rbd
Suggests: qemu-block-ssh Suggests: qemu-block-ssh
Recommends: libvirt-daemon-config-network Recommends: libvirt-daemon-config-network
Requires: libvirt-daemon-driver-qemu >= 7.1.0 #Requires: libvirt-daemon-driver-qemu >= 7.1.0
Requires: libvirt-daemon-driver-secret Requires: libvirt-daemon-driver-secret
Recommends: libvirt-daemon-driver-storage-core Recommends: libvirt-daemon-driver-storage-core
Requires: selinux-policy >= 3.11.1-63 Requires: selinux-policy >= 3.11.1-63