- New upstream version 1.3.13.
- Add BUGS to documentation. - Force update of hivex dependency to 1.2.2 since it contains important registry import fixes. - Remove patch1, now upstream.
This commit is contained in:
parent
c863b45761
commit
1be01b24c7
@ -1,38 +0,0 @@
|
|||||||
diff -ur libguestfs-1.3.12/appliance/Makefile.am libguestfs-1.3.12.new/appliance/Makefile.am
|
|
||||||
--- libguestfs-1.3.12/appliance/Makefile.am 2010-05-13 18:30:37.000000000 +0100
|
|
||||||
+++ libguestfs-1.3.12.new/appliance/Makefile.am 2010-05-14 15:44:54.941717073 +0100
|
|
||||||
@@ -87,13 +87,13 @@
|
|
||||||
if SUPERMIN
|
|
||||||
|
|
||||||
supermin.d/base.img supermin.d/hostfiles: stamp-supermin
|
|
||||||
-stamp-supermin: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/initramfs/init
|
|
||||||
+stamp-supermin: $(INITRAMFSIMG)
|
|
||||||
mkdir -p supermin.d
|
|
||||||
rm -f $@ supermin.d/base.img supermin.d/hostfiles
|
|
||||||
febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
|
|
||||||
touch $@
|
|
||||||
|
|
||||||
-supermin.d/daemon.img: $(top_builddir)/initramfs/sbin/guestfsd
|
|
||||||
+supermin.d/daemon.img: $(INITRAMFSIMG)
|
|
||||||
mkdir -p supermin.d
|
|
||||||
rm -f $@ $@-t
|
|
||||||
(cd $(top_builddir)/initramfs && \
|
|
||||||
diff -ur libguestfs-1.3.12/appliance/Makefile.in libguestfs-1.3.12.new/appliance/Makefile.in
|
|
||||||
--- libguestfs-1.3.12/appliance/Makefile.in 2010-05-14 12:19:39.000000000 +0100
|
|
||||||
+++ libguestfs-1.3.12.new/appliance/Makefile.in 2010-05-14 15:44:59.237342261 +0100
|
|
||||||
@@ -1275,13 +1275,13 @@
|
|
||||||
# to read the README file.
|
|
||||||
|
|
||||||
@SUPERMIN_TRUE@supermin.d/base.img supermin.d/hostfiles: stamp-supermin
|
|
||||||
-@SUPERMIN_TRUE@stamp-supermin: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/initramfs/init
|
|
||||||
+@SUPERMIN_TRUE@stamp-supermin: $(INITRAMFSIMG)
|
|
||||||
@SUPERMIN_TRUE@ mkdir -p supermin.d
|
|
||||||
@SUPERMIN_TRUE@ rm -f $@ supermin.d/base.img supermin.d/hostfiles
|
|
||||||
@SUPERMIN_TRUE@ febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
|
|
||||||
@SUPERMIN_TRUE@ touch $@
|
|
||||||
|
|
||||||
-@SUPERMIN_TRUE@supermin.d/daemon.img: $(top_builddir)/initramfs/sbin/guestfsd
|
|
||||||
+@SUPERMIN_TRUE@supermin.d/daemon.img: $(INITRAMFSIMG)
|
|
||||||
@SUPERMIN_TRUE@ mkdir -p supermin.d
|
|
||||||
@SUPERMIN_TRUE@ rm -f $@ $@-t
|
|
||||||
@SUPERMIN_TRUE@ (cd $(top_builddir)/initramfs && \
|
|
@ -41,8 +41,8 @@
|
|||||||
Summary: Access and modify virtual machine disk images
|
Summary: Access and modify virtual machine disk images
|
||||||
Name: libguestfs
|
Name: libguestfs
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.3.12
|
Version: 1.3.13
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
URL: http://libguestfs.org/
|
URL: http://libguestfs.org/
|
||||||
@ -52,14 +52,11 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
|||||||
# Disable FUSE tests, not supported in Koji at the moment.
|
# Disable FUSE tests, not supported in Koji at the moment.
|
||||||
Patch0: libguestfs-1.0.79-no-fuse-test.patch
|
Patch0: libguestfs-1.0.79-no-fuse-test.patch
|
||||||
|
|
||||||
# Small build fix for supermin backported from upstream.
|
|
||||||
Patch1: libguestfs-1.3.12-ensure-ordinary-appliance-is-updated.patch
|
|
||||||
|
|
||||||
# Basic build requirements:
|
# Basic build requirements:
|
||||||
BuildRequires: /usr/bin/pod2man
|
BuildRequires: /usr/bin/pod2man
|
||||||
BuildRequires: /usr/bin/pod2text
|
BuildRequires: /usr/bin/pod2text
|
||||||
BuildRequires: febootstrap >= 2.7
|
BuildRequires: febootstrap >= 2.7
|
||||||
BuildRequires: hivex-devel >= 1.2.1
|
BuildRequires: hivex-devel >= 1.2.2
|
||||||
BuildRequires: augeas-devel >= 0.5.0
|
BuildRequires: augeas-devel >= 0.5.0
|
||||||
BuildRequires: readline-devel
|
BuildRequires: readline-devel
|
||||||
BuildRequires: genisoimage
|
BuildRequires: genisoimage
|
||||||
@ -223,7 +220,7 @@ Requires: guestfish
|
|||||||
Requires: perl-Sys-Virt
|
Requires: perl-Sys-Virt
|
||||||
Requires: perl-String-ShellQuote
|
Requires: perl-String-ShellQuote
|
||||||
Requires: perl-XML-Writer
|
Requires: perl-XML-Writer
|
||||||
Requires: hivex >= 1.2.1
|
Requires: hivex >= 1.2.2
|
||||||
Requires: qemu-img
|
Requires: qemu-img
|
||||||
|
|
||||||
# Obsolete and replace earlier packages.
|
# Obsolete and replace earlier packages.
|
||||||
@ -392,7 +389,6 @@ Requires: jpackage-utils
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
mkdir -p daemon/m4
|
mkdir -p daemon/m4
|
||||||
|
|
||||||
@ -577,7 +573,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc ChangeLog HACKING TODO README ex html/guestfs.3.html html/pod.css
|
%doc BUGS ChangeLog HACKING TODO README ex html/guestfs.3.html html/pod.css
|
||||||
%doc installed-docs/*
|
%doc installed-docs/*
|
||||||
%{_libdir}/libguestfs.so
|
%{_libdir}/libguestfs.so
|
||||||
%{_mandir}/man3/guestfs.3*
|
%{_mandir}/man3/guestfs.3*
|
||||||
@ -695,6 +691,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun May 16 2010 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.13-1
|
||||||
|
- New upstream version 1.3.13.
|
||||||
|
- Add BUGS to documentation.
|
||||||
|
- Force update of hivex dependency to 1.2.2 since it contains
|
||||||
|
important registry import fixes.
|
||||||
|
- Remove patch1, now upstream.
|
||||||
|
|
||||||
* Fri May 14 2010 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.12-3
|
* Fri May 14 2010 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.12-3
|
||||||
- Backport supermin build fix from upstream.
|
- Backport supermin build fix from upstream.
|
||||||
- Further changes required for new layout of supermin appliance.
|
- Further changes required for new layout of supermin appliance.
|
||||||
|
Loading…
Reference in New Issue
Block a user