Remove ruby vendor patch.
Since 1.21.21 libguestfs upstream now supports 'make INSTALLDIRS=vendor install' for both Perl and Ruby libraries.
This commit is contained in:
parent
09dfa8acdb
commit
1a61c3309a
@ -28,11 +28,6 @@ Group: Development/Libraries
|
||||
URL: http://libguestfs.org/
|
||||
Source0: http://libguestfs.org/download/1.21-development/%{name}-%{version}.tar.gz
|
||||
|
||||
%if 0%{?fedora} >= 17
|
||||
Patch1: ruby-1.9-vendor-not-site.patch
|
||||
BuildRequires: autoconf, automake, libtool, gettext-devel
|
||||
%endif
|
||||
|
||||
# Basic build requirements:
|
||||
BuildRequires: perl(Pod::Simple)
|
||||
BuildRequires: perl(Pod::Man)
|
||||
@ -683,11 +678,6 @@ if [ "$(getenforce | tr '[A-Z]' '[a-z]')" != "disabled" ]; then
|
||||
chcon --reference=/tmp tmp
|
||||
fi
|
||||
|
||||
%if 0%{?fedora} >= 17
|
||||
%patch1 -p1
|
||||
autoreconf -i
|
||||
%endif
|
||||
|
||||
mkdir -p daemon/m4
|
||||
|
||||
# Replace developer-centric README that ships with libguestfs, with
|
||||
@ -737,8 +727,8 @@ EOF
|
||||
--enable-install-daemon \
|
||||
%{extra}
|
||||
|
||||
# 'INSTALLDIRS' ensures that perl libs are installed in the vendor dir
|
||||
# not the site dir.
|
||||
# 'INSTALLDIRS' ensures that Perl and Ruby libs are installed in the
|
||||
# vendor dir not the site dir.
|
||||
make V=1 INSTALLDIRS=vendor %{?_smp_mflags}
|
||||
|
||||
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -ur libguestfs-1.21.1.old/ruby/Makefile.am libguestfs-1.21.1/ruby/Makefile.am
|
||||
--- libguestfs-1.21.1.old/ruby/Makefile.am 2012-12-15 19:42:02.000000000 +0000
|
||||
+++ libguestfs-1.21.1/ruby/Makefile.am 2012-12-17 14:03:27.396861323 +0000
|
||||
@@ -51,14 +51,14 @@
|
||||
$(RAKE) build
|
||||
$(RAKE) rdoc
|
||||
|
||||
-RUBY_SITELIB := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['sitelibdir']")
|
||||
-RUBY_SITEARCH := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['sitearchdir']")
|
||||
+RUBY_VENDORLIB := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['vendorlibdir']")
|
||||
+RUBY_VENDORARCH := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['vendorarchdir']")
|
||||
|
||||
install:
|
||||
- $(MKDIR_P) $(DESTDIR)$(RUBY_SITELIB)
|
||||
- $(MKDIR_P) $(DESTDIR)$(RUBY_SITEARCH)
|
||||
- $(INSTALL) -p -m 0644 $(srcdir)/lib/guestfs.rb $(DESTDIR)$(RUBY_SITELIB)
|
||||
- $(INSTALL) -p -m 0755 $(builddir)/ext/guestfs/_guestfs.so $(DESTDIR)$(RUBY_SITEARCH)
|
||||
+ $(MKDIR_P) $(DESTDIR)$(RUBY_VENDORLIB)
|
||||
+ $(MKDIR_P) $(DESTDIR)$(RUBY_VENDORARCH)
|
||||
+ $(INSTALL) -p -m 0644 $(srcdir)/lib/guestfs.rb $(DESTDIR)$(RUBY_VENDORLIB)
|
||||
+ $(INSTALL) -p -m 0755 $(builddir)/ext/guestfs/_guestfs.so $(DESTDIR)$(RUBY_VENDORARCH)
|
||||
|
||||
TESTS = run-bindtests run-ruby-tests
|
||||
|
Loading…
Reference in New Issue
Block a user