- New upstream development branch 1.11.0.
- New Source URL. - Remove patches which are now upstream.
This commit is contained in:
parent
c8007bb93e
commit
040600dc8a
1
.gitignore
vendored
1
.gitignore
vendored
@ -66,3 +66,4 @@ libguestfs-1.5.3.tar.gz
|
|||||||
/libguestfs-1.9.16.tar.gz
|
/libguestfs-1.9.16.tar.gz
|
||||||
/libguestfs-1.9.17.tar.gz
|
/libguestfs-1.9.17.tar.gz
|
||||||
/libguestfs-1.9.18.tar.gz
|
/libguestfs-1.9.18.tar.gz
|
||||||
|
/libguestfs-1.11.0.tar.gz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From 047173d18683a66cbe8949bc114833984898fed6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Richard W.M. Jones <rjones@redhat.com>
|
|
||||||
Date: Sat, 9 Apr 2011 22:50:15 +0100
|
|
||||||
Subject: [PATCH 1/4] resize: Link with local copy of guestfs.
|
|
||||||
|
|
||||||
---
|
|
||||||
resize/Makefile.am | 4 ++--
|
|
||||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/resize/Makefile.am b/resize/Makefile.am
|
|
||||||
index 1d341d8..3740a4a 100644
|
|
||||||
--- a/resize/Makefile.am
|
|
||||||
+++ b/resize/Makefile.am
|
|
||||||
@@ -42,12 +42,12 @@ OBJECTS = \
|
|
||||||
|
|
||||||
bin_SCRIPTS = virt-resize
|
|
||||||
|
|
||||||
-OCAMLPACKAGES = -package guestfs,pcre
|
|
||||||
+OCAMLPACKAGES = -package pcre -I ../ocaml
|
|
||||||
OCAMLCFLAGS = -g -warn-error CDEFLMPSUVYZX $(OCAMLPACKAGES)
|
|
||||||
OCAMLOPTFLAGS = $(OCAMLCFLAGS)
|
|
||||||
|
|
||||||
virt-resize: $(OBJECTS)
|
|
||||||
- $(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) -linkpkg $^ -o $@
|
|
||||||
+ $(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) mlguestfs.cmxa -linkpkg $^ -o $@
|
|
||||||
|
|
||||||
.mli.cmi:
|
|
||||||
$(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -c $< -o $@
|
|
||||||
--
|
|
||||||
1.7.4.1
|
|
||||||
|
|
@ -1,25 +0,0 @@
|
|||||||
From 61a42ff551073daf345bd03941797e6af1e97128 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Richard W.M. Jones <rjones@redhat.com>
|
|
||||||
Date: Sun, 10 Apr 2011 11:06:58 +0100
|
|
||||||
Subject: [PATCH 2/4] resize: Missing \n after version.
|
|
||||||
|
|
||||||
---
|
|
||||||
resize/resize.ml | 2 +-
|
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/resize/resize.ml b/resize/resize.ml
|
|
||||||
index 9a4c86b..dc5540f 100644
|
|
||||||
--- a/resize/resize.ml
|
|
||||||
+++ b/resize/resize.ml
|
|
||||||
@@ -35,7 +35,7 @@ let infile, outfile, copy_boot_loader, debug, deletes, dryrun,
|
|
||||||
let display_version () =
|
|
||||||
let g = new G.guestfs () in
|
|
||||||
let version = g#version () in
|
|
||||||
- printf "virt-resize %Ld.%Ld.%Ld%s"
|
|
||||||
+ printf "virt-resize %Ld.%Ld.%Ld%s\n"
|
|
||||||
version.G.major version.G.minor version.G.release version.G.extra;
|
|
||||||
exit 0
|
|
||||||
in
|
|
||||||
--
|
|
||||||
1.7.4.1
|
|
||||||
|
|
@ -1,41 +0,0 @@
|
|||||||
From a6cb8fee205b1615d380456964bebe40bd840fb1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Richard W.M. Jones <rjones@redhat.com>
|
|
||||||
Date: Sun, 10 Apr 2011 11:12:03 +0100
|
|
||||||
Subject: [PATCH 3/4] resize: Consistent use of 'part' in help output.
|
|
||||||
|
|
||||||
---
|
|
||||||
resize/resize.ml | 8 ++++----
|
|
||||||
1 files changed, 4 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/resize/resize.ml b/resize/resize.ml
|
|
||||||
index dc5540f..82fd765 100644
|
|
||||||
--- a/resize/resize.ml
|
|
||||||
+++ b/resize/resize.ml
|
|
||||||
@@ -72,12 +72,12 @@ let infile, outfile, copy_boot_loader, debug, deletes, dryrun,
|
|
||||||
"--no-copy-boot-loader", Arg.Clear copy_boot_loader, " Don't copy boot loader";
|
|
||||||
"-d", Arg.Set debug, " Enable debugging messages";
|
|
||||||
"--debug", Arg.Set debug, " -\"-";
|
|
||||||
- "--delete", Arg.String (add deletes), "dev Delete partition";
|
|
||||||
- "--expand", Arg.String set_expand, "dev Expand partition";
|
|
||||||
+ "--delete", Arg.String (add deletes), "part Delete partition";
|
|
||||||
+ "--expand", Arg.String set_expand, "part Expand partition";
|
|
||||||
"--no-expand-content", Arg.Clear expand_content, " Don't expand content";
|
|
||||||
"--no-extra-partition", Arg.Clear extra_partition, " Don't create extra partition";
|
|
||||||
"--format", Arg.Set_string format, "format Format of input disk";
|
|
||||||
- "--ignore", Arg.String (add ignores), "dev Ignore partition";
|
|
||||||
+ "--ignore", Arg.String (add ignores), "part Ignore partition";
|
|
||||||
"--lv-expand", Arg.String (add lv_expands), "lv Expand logical volume";
|
|
||||||
"--LV-expand", Arg.String (add lv_expands), "lv -\"-";
|
|
||||||
"--lvexpand", Arg.String (add lv_expands), "lv -\"-";
|
|
||||||
@@ -90,7 +90,7 @@ let infile, outfile, copy_boot_loader, debug, deletes, dryrun,
|
|
||||||
"--quiet", Arg.Set quiet, " -\"-";
|
|
||||||
"--resize", Arg.String (add resizes), "part=size Resize partition";
|
|
||||||
"--resize-force", Arg.String (add resizes_force), "part=size Forcefully resize partition";
|
|
||||||
- "--shrink", Arg.String set_shrink, "dev Shrink partition";
|
|
||||||
+ "--shrink", Arg.String set_shrink, "part Shrink partition";
|
|
||||||
"-V", Arg.Unit display_version, " Display version and exit";
|
|
||||||
"--version", Arg.Unit display_version, " -\"-";
|
|
||||||
] in
|
|
||||||
--
|
|
||||||
1.7.4.1
|
|
||||||
|
|
@ -1,24 +0,0 @@
|
|||||||
From d600d53868237e0f2828a912d9672dbd480e315f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Richard W.M. Jones <rjones@redhat.com>
|
|
||||||
Date: Sun, 10 Apr 2011 20:42:42 +0100
|
|
||||||
Subject: [PATCH 4/4] resize: Don't build this directory in parallel.
|
|
||||||
|
|
||||||
---
|
|
||||||
resize/Makefile.am | 4 ++++
|
|
||||||
1 files changed, 4 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/resize/Makefile.am b/resize/Makefile.am
|
|
||||||
index 3740a4a..93c193e 100644
|
|
||||||
--- a/resize/Makefile.am
|
|
||||||
+++ b/resize/Makefile.am
|
|
||||||
@@ -98,3 +98,7 @@ include .depend
|
|
||||||
|
|
||||||
endif
|
|
||||||
endif
|
|
||||||
+
|
|
||||||
+# Parallel builds don't obey dependencies for some reason we
|
|
||||||
+# don't understand.
|
|
||||||
+.NOTPARALLEL:
|
|
||||||
--
|
|
||||||
1.7.4.1
|
|
||||||
|
|
@ -29,23 +29,17 @@
|
|||||||
Summary: Access and modify virtual machine disk images
|
Summary: Access and modify virtual machine disk images
|
||||||
Name: libguestfs
|
Name: libguestfs
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.9.18
|
Version: 1.11.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
URL: http://libguestfs.org/
|
URL: http://libguestfs.org/
|
||||||
Source0: http://libguestfs.org/download/1.9-development/%{name}-%{version}.tar.gz
|
Source0: http://libguestfs.org/download/1.11-development/%{name}-%{version}.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
|
|
||||||
# Disable FUSE tests, not supported in Koji at the moment.
|
# Disable FUSE tests, not supported in Koji at the moment.
|
||||||
Patch0: libguestfs-1.7.13-no-fuse-test.patch
|
Patch0: libguestfs-1.7.13-no-fuse-test.patch
|
||||||
|
|
||||||
# Patch upstream in > 1.9.18.
|
|
||||||
Patch1: 0001-resize-Link-with-local-copy-of-guestfs.patch
|
|
||||||
Patch2: 0002-resize-Missing-n-after-version.patch
|
|
||||||
Patch3: 0003-resize-Consistent-use-of-part-in-help-output.patch
|
|
||||||
Patch4: 0004-resize-Don-t-build-this-directory-in-parallel.patch
|
|
||||||
|
|
||||||
# Basic build requirements:
|
# Basic build requirements:
|
||||||
BuildRequires: /usr/bin/pod2man
|
BuildRequires: /usr/bin/pod2man
|
||||||
BuildRequires: /usr/bin/pod2text
|
BuildRequires: /usr/bin/pod2text
|
||||||
@ -440,10 +434,6 @@ php-%{name} contains PHP bindings for %{name}.
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
%patch4 -p1
|
|
||||||
|
|
||||||
mkdir -p daemon/m4
|
mkdir -p daemon/m4
|
||||||
|
|
||||||
@ -530,7 +520,7 @@ export LIBGUESTFS_TRACE=1
|
|||||||
# 504273 ppc, ppc64 "no opcode defined"
|
# 504273 ppc, ppc64 "no opcode defined"
|
||||||
# 505109 ppc, ppc64 "Boot failure! No secondary bootloader specified"
|
# 505109 ppc, ppc64 "Boot failure! No secondary bootloader specified"
|
||||||
# 502058 i386, x86-64 F-11 need to boot with noapic (WORKAROUND ENABLED)
|
# 502058 i386, x86-64 F-11 need to boot with noapic (WORKAROUND ENABLED)
|
||||||
# 502074 i386 all commands segfault randomly
|
# 502074 i386 all commands segfault randomly (fixed itself)
|
||||||
# 503236 i386 F-12 cryptomgr_test at doublefault_fn
|
# 503236 i386 F-12 cryptomgr_test at doublefault_fn
|
||||||
# 507066 all F-12 sequence of chroot calls (FIXED)
|
# 507066 all F-12 sequence of chroot calls (FIXED)
|
||||||
# 513249 all F-12 guestfwd broken in qemu (FIXED)
|
# 513249 all F-12 guestfwd broken in qemu (FIXED)
|
||||||
@ -782,6 +772,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 12 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.11.0-1
|
||||||
|
- New upstream development branch 1.11.0.
|
||||||
|
- New Source URL.
|
||||||
|
- Remove patches which are now upstream.
|
||||||
|
|
||||||
* Sun Apr 10 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.9.18-4
|
* Sun Apr 10 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.9.18-4
|
||||||
- Include further fixes to virt-resize from upstream.
|
- Include further fixes to virt-resize from upstream.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user