Backport patch which adds riscv64 support.
Straightforward addition of an upstream patch. See: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891663 http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgpg-error.git;a=commitdiff;h=596c0d701edeb45e0069bb74b9343e3d5b708ef0
This commit is contained in:
parent
657c64b4f5
commit
d73f522e37
@ -0,0 +1,59 @@
|
|||||||
|
From: NIIBE Yutaka <gniibe@fsij.org>
|
||||||
|
Date: Wed, 28 Feb 2018 01:47:51 +0000 (+0900)
|
||||||
|
Subject: syscfg: Add a riscv64 architecture.
|
||||||
|
X-Git-Url: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgpg-error.git;a=commitdiff_plain;h=596c0d701edeb45e0069bb74b9343e3d5b708ef0
|
||||||
|
|
||||||
|
syscfg: Add a riscv64 architecture.
|
||||||
|
|
||||||
|
* src/syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h: New.
|
||||||
|
* src/Makefile.am (lock_obj_pub): Add it.
|
||||||
|
--
|
||||||
|
|
||||||
|
Debian-bug-id: 891663
|
||||||
|
Co-authored-by: Karsten Merker <merker@debian.org>
|
||||||
|
Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
|
||||||
|
---
|
||||||
|
|
||||||
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
|
index 4446612..268c2ab 100644
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -65,6 +65,7 @@ lock_obj_pub = \
|
||||||
|
syscfg/lock-obj-pub.powerpc64-unknown-linux-gnu.h \
|
||||||
|
syscfg/lock-obj-pub.powerpc64le-unknown-linux-gnu.h \
|
||||||
|
syscfg/lock-obj-pub.powerpc-unknown-linux-gnuspe.h \
|
||||||
|
+ syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h \
|
||||||
|
syscfg/lock-obj-pub.s390x-ibm-linux-gnu.h \
|
||||||
|
syscfg/lock-obj-pub.sh3-unknown-linux-gnu.h \
|
||||||
|
syscfg/lock-obj-pub.sh4-unknown-linux-gnu.h \
|
||||||
|
diff --git a/src/syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h b/src/syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..8aab9d6
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/src/syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h
|
||||||
|
@@ -0,0 +1,25 @@
|
||||||
|
+## lock-obj-pub.riscv64-unknown-linux-gnu.h
|
||||||
|
+## File created by gen-posix-lock-obj - DO NOT EDIT
|
||||||
|
+## To be included by mkheader into gpg-error.h
|
||||||
|
+
|
||||||
|
+typedef struct
|
||||||
|
+{
|
||||||
|
+ long _vers;
|
||||||
|
+ union {
|
||||||
|
+ volatile char _priv[40];
|
||||||
|
+ long _x_align;
|
||||||
|
+ long *_xp_align;
|
||||||
|
+ } u;
|
||||||
|
+} gpgrt_lock_t;
|
||||||
|
+
|
||||||
|
+#define GPGRT_LOCK_INITIALIZER {1,{{0,0,0,0,0,0,0,0, \
|
||||||
|
+ 0,0,0,0,0,0,0,0, \
|
||||||
|
+ 0,0,0,0,0,0,0,0, \
|
||||||
|
+ 0,0,0,0,0,0,0,0, \
|
||||||
|
+ 0,0,0,0,0,0,0,0}}}
|
||||||
|
+##
|
||||||
|
+## Local Variables:
|
||||||
|
+## mode: c
|
||||||
|
+## buffer-read-only: t
|
||||||
|
+## End:
|
||||||
|
+##
|
@ -1,11 +1,13 @@
|
|||||||
Summary: Library for error values used by GnuPG components
|
Summary: Library for error values used by GnuPG components
|
||||||
Name: libgpg-error
|
Name: libgpg-error
|
||||||
Version: 1.27
|
Version: 1.27
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
URL: https://www.gnupg.org/related_software/libgpg-error/
|
URL: https://www.gnupg.org/related_software/libgpg-error/
|
||||||
Source0: ftp://ftp.gnupg.org/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2
|
Source0: ftp://ftp.gnupg.org/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2
|
||||||
Source1: ftp://ftp.gnupg.org/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2.sig
|
Source1: ftp://ftp.gnupg.org/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2.sig
|
||||||
Patch1: libgpg-error-1.25-multilib.patch
|
Patch1: libgpg-error-1.25-multilib.patch
|
||||||
|
# Upstream commit 596c0d701, required by
|
||||||
|
Patch2: libgpg-error.git-596c0d701edeb45e0069bb74b9343e3d5b708ef0.patch
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
|
|
||||||
@ -36,6 +38,7 @@ contains files necessary to develop applications using libgpg-error.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .multilib
|
%patch1 -p1 -b .multilib
|
||||||
|
%patch2 -p1 -b .riscv64
|
||||||
# The config script already suppresses the -L if it's /usr/lib, so cheat and
|
# The config script already suppresses the -L if it's /usr/lib, so cheat and
|
||||||
# set it to a value which we know will be suppressed.
|
# set it to a value which we know will be suppressed.
|
||||||
sed -i -e 's|^libdir=@libdir@$|libdir=@exec_prefix@/lib|g;s|@GPG_ERROR_CONFIG_HOST@|none|g' src/gpg-error-config.in
|
sed -i -e 's|^libdir=@libdir@$|libdir=@exec_prefix@/lib|g;s|@GPG_ERROR_CONFIG_HOST@|none|g' src/gpg-error-config.in
|
||||||
@ -91,6 +94,9 @@ exit 0
|
|||||||
%{_mandir}/man1/gpg-error-config.*
|
%{_mandir}/man1/gpg-error-config.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 28 2018 Richard W.M. Jones <rjones@redhat.com> - 1.27-6
|
||||||
|
- Backport patch which adds riscv64 support.
|
||||||
|
|
||||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.27-5
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.27-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user