d73f522e37
Straightforward addition of an upstream patch. See: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891663 http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgpg-error.git;a=commitdiff;h=596c0d701edeb45e0069bb74b9343e3d5b708ef0
60 lines
2.0 KiB
Diff
60 lines
2.0 KiB
Diff
From: NIIBE Yutaka <gniibe@fsij.org>
|
|
Date: Wed, 28 Feb 2018 01:47:51 +0000 (+0900)
|
|
Subject: syscfg: Add a riscv64 architecture.
|
|
X-Git-Url: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgpg-error.git;a=commitdiff_plain;h=596c0d701edeb45e0069bb74b9343e3d5b708ef0
|
|
|
|
syscfg: Add a riscv64 architecture.
|
|
|
|
* src/syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h: New.
|
|
* src/Makefile.am (lock_obj_pub): Add it.
|
|
--
|
|
|
|
Debian-bug-id: 891663
|
|
Co-authored-by: Karsten Merker <merker@debian.org>
|
|
Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
|
|
---
|
|
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index 4446612..268c2ab 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -65,6 +65,7 @@ lock_obj_pub = \
|
|
syscfg/lock-obj-pub.powerpc64-unknown-linux-gnu.h \
|
|
syscfg/lock-obj-pub.powerpc64le-unknown-linux-gnu.h \
|
|
syscfg/lock-obj-pub.powerpc-unknown-linux-gnuspe.h \
|
|
+ syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h \
|
|
syscfg/lock-obj-pub.s390x-ibm-linux-gnu.h \
|
|
syscfg/lock-obj-pub.sh3-unknown-linux-gnu.h \
|
|
syscfg/lock-obj-pub.sh4-unknown-linux-gnu.h \
|
|
diff --git a/src/syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h b/src/syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h
|
|
new file mode 100644
|
|
index 0000000..8aab9d6
|
|
--- /dev/null
|
|
+++ b/src/syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h
|
|
@@ -0,0 +1,25 @@
|
|
+## lock-obj-pub.riscv64-unknown-linux-gnu.h
|
|
+## File created by gen-posix-lock-obj - DO NOT EDIT
|
|
+## To be included by mkheader into gpg-error.h
|
|
+
|
|
+typedef struct
|
|
+{
|
|
+ long _vers;
|
|
+ union {
|
|
+ volatile char _priv[40];
|
|
+ long _x_align;
|
|
+ long *_xp_align;
|
|
+ } u;
|
|
+} gpgrt_lock_t;
|
|
+
|
|
+#define GPGRT_LOCK_INITIALIZER {1,{{0,0,0,0,0,0,0,0, \
|
|
+ 0,0,0,0,0,0,0,0, \
|
|
+ 0,0,0,0,0,0,0,0, \
|
|
+ 0,0,0,0,0,0,0,0, \
|
|
+ 0,0,0,0,0,0,0,0}}}
|
|
+##
|
|
+## Local Variables:
|
|
+## mode: c
|
|
+## buffer-read-only: t
|
|
+## End:
|
|
+##
|