7a5a7e8ddf
switch to qemu based release. lots of small fixes.
41 lines
1.4 KiB
Diff
41 lines
1.4 KiB
Diff
From d2d3d10a1422a99f55994dc6de3731b984241acb Mon Sep 17 00:00:00 2001
|
|
From: Alon Levy <alevy@redhat.com>
|
|
Date: Tue, 20 Nov 2012 18:04:32 +0200
|
|
Subject: [PATCH] libcacard: build vscclient from root only
|
|
|
|
Signed-off-by: Alon Levy <alevy@redhat.com>
|
|
---
|
|
libcacard/Makefile | 8 ++++++--
|
|
1 file changed, 6 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libcacard/Makefile b/libcacard/Makefile
|
|
index 63990b7..faca3ca 100644
|
|
--- a/libcacard/Makefile
|
|
+++ b/libcacard/Makefile
|
|
@@ -1,3 +1,7 @@
|
|
+ifeq ($(BUILD_DIR),)
|
|
+ BUILD_DIR=$(CURDIR)/../
|
|
+endif
|
|
+
|
|
-include ../config-host.mak
|
|
-include $(SRC_PATH)/Makefile.objs
|
|
-include $(SRC_PATH)/rules.mak
|
|
@@ -46,12 +50,12 @@ libcacard.pc: $(libcacard_srcpath)/libcacard.pc.in
|
|
|
|
.PHONY: install-libcacard
|
|
|
|
-install-libcacard: libcacard.pc libcacard.la vscclient
|
|
+install-libcacard: libcacard.pc libcacard.la ../vscclient
|
|
$(INSTALL_DIR) "$(DESTDIR)$(libdir)"
|
|
$(INSTALL_DIR) "$(DESTDIR)$(libdir)/pkgconfig"
|
|
$(INSTALL_DIR) "$(DESTDIR)$(libcacard_includedir)"
|
|
$(INSTALL_DIR) "$(DESTDIR)$(bindir)"
|
|
- $(LIBTOOL) --mode=install $(INSTALL_PROG) vscclient "$(DESTDIR)$(bindir)"
|
|
+ $(LIBTOOL) --mode=install $(INSTALL_PROG) ../vscclient "$(DESTDIR)$(bindir)"
|
|
$(LIBTOOL) --mode=install $(INSTALL_DATA) libcacard.la "$(DESTDIR)$(libdir)"
|
|
$(LIBTOOL) --mode=install $(INSTALL_DATA) libcacard.pc "$(DESTDIR)$(libdir)/pkgconfig"
|
|
for inc in *.h; do \
|
|
--
|
|
1.8.0
|
|
|