1.2.1-1
switch to qemu based release. lots of small fixes.
This commit is contained in:
parent
a253546e06
commit
7a5a7e8ddf
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/libcacard-0.1.0.tar.bz2
|
||||
/libcacard-0.1.2.tar.bz2
|
||||
/qemu-1.2.1.tar.bz2
|
||||
|
40
0001-libcacard-build-vscclient-from-root-only.patch
Normal file
40
0001-libcacard-build-vscclient-from-root-only.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From d2d3d10a1422a99f55994dc6de3731b984241acb Mon Sep 17 00:00:00 2001
|
||||
From: Alon Levy <alevy@redhat.com>
|
||||
Date: Tue, 20 Nov 2012 18:04:32 +0200
|
||||
Subject: [PATCH] libcacard: build vscclient from root only
|
||||
|
||||
Signed-off-by: Alon Levy <alevy@redhat.com>
|
||||
---
|
||||
libcacard/Makefile | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/libcacard/Makefile b/libcacard/Makefile
|
||||
index 63990b7..faca3ca 100644
|
||||
--- a/libcacard/Makefile
|
||||
+++ b/libcacard/Makefile
|
||||
@@ -1,3 +1,7 @@
|
||||
+ifeq ($(BUILD_DIR),)
|
||||
+ BUILD_DIR=$(CURDIR)/../
|
||||
+endif
|
||||
+
|
||||
-include ../config-host.mak
|
||||
-include $(SRC_PATH)/Makefile.objs
|
||||
-include $(SRC_PATH)/rules.mak
|
||||
@@ -46,12 +50,12 @@ libcacard.pc: $(libcacard_srcpath)/libcacard.pc.in
|
||||
|
||||
.PHONY: install-libcacard
|
||||
|
||||
-install-libcacard: libcacard.pc libcacard.la vscclient
|
||||
+install-libcacard: libcacard.pc libcacard.la ../vscclient
|
||||
$(INSTALL_DIR) "$(DESTDIR)$(libdir)"
|
||||
$(INSTALL_DIR) "$(DESTDIR)$(libdir)/pkgconfig"
|
||||
$(INSTALL_DIR) "$(DESTDIR)$(libcacard_includedir)"
|
||||
$(INSTALL_DIR) "$(DESTDIR)$(bindir)"
|
||||
- $(LIBTOOL) --mode=install $(INSTALL_PROG) vscclient "$(DESTDIR)$(bindir)"
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_PROG) ../vscclient "$(DESTDIR)$(bindir)"
|
||||
$(LIBTOOL) --mode=install $(INSTALL_DATA) libcacard.la "$(DESTDIR)$(libdir)"
|
||||
$(LIBTOOL) --mode=install $(INSTALL_DATA) libcacard.pc "$(DESTDIR)$(libdir)/pkgconfig"
|
||||
for inc in *.h; do \
|
||||
--
|
||||
1.8.0
|
||||
|
@ -1,12 +1,13 @@
|
||||
Name: libcacard
|
||||
Version: 0.1.2
|
||||
Release: 3%{?dist}
|
||||
Version: 1.2.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Common Access Card (CAC) Emulation
|
||||
Group: System Environment/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://www.spice-space.org/download
|
||||
Source0: http://www.spice-space.org/download/libcacard/libcacard-%{version}.tar.bz2
|
||||
BuildRequires: nss-devel >= 3.12.8-2
|
||||
URL: http://www.qemu.org/
|
||||
Source0: http://wiki.qemu.org/download/qemu-%{version}.tar.bz2
|
||||
Patch00: 0001-libcacard-build-vscclient-from-root-only.patch
|
||||
BuildRequires: nss-devel >= 3.12.8-2 libtool
|
||||
|
||||
%description
|
||||
Common Access Card (CAC) emulation library.
|
||||
@ -28,15 +29,17 @@ Requires: %{name} = %{version}-%{release}
|
||||
CAC emulation development files.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -n qemu-%{version} -q
|
||||
%patch00 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
./configure --prefix=%{_prefix} --libdir=%{_libdir} --disable-guest-agent --target-list=
|
||||
make libcacard.la %{?_smp_mflags}
|
||||
make vscclient
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
make install-libcacard DESTDIR=$RPM_BUILD_ROOT
|
||||
find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
@ -59,6 +62,10 @@ find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
|
||||
%{_bindir}/vscclient
|
||||
|
||||
%changelog
|
||||
* Tue Nov 20 2012 Alon Levy <alevy@redhat.com> 1.2.0-1
|
||||
- libcacard independent repository is no longer used, qemu contains it as
|
||||
a subdirectory. Switch and update version number to qemu's.
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user