21 lines
921 B
Diff
21 lines
921 B
Diff
diff -up kexec-tools-2.0.0/purgatory/Makefile.orig kexec-tools-2.0.0/purgatory/Makefile
|
|
--- kexec-tools-2.0.0/purgatory/Makefile.orig 2011-03-10 11:39:22.100799291 -0500
|
|
+++ kexec-tools-2.0.0/purgatory/Makefile 2011-03-10 11:39:36.422736886 -0500
|
|
@@ -55,14 +55,14 @@ $(PURGATORY): CPPFLAGS=$($(ARCH)_PURGATO
|
|
-I$(srcdir)/util_lib/include \
|
|
-I$(shell $(CC) -print-file-name=include)
|
|
$(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)\
|
|
- --no-undefined -nostartfiles -nostdlib -nodefaultlibs \
|
|
+ -nostartfiles -nostdlib -nodefaultlibs \
|
|
-e purgatory_start -r
|
|
|
|
$(PURGATORY): $(PURGATORY_OBJS)
|
|
$(MKDIR) -p $(@D)
|
|
$(CC) $(LDFLAGS) -o $@ $^
|
|
|
|
-# $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
|
|
+# $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
|
|
|
|
echo::
|
|
@echo "PURGATORY_SRCS $(PURGATORY_SRCS)"
|