Fixing build break with purgatory

This commit is contained in:
Neil Horman 2011-03-10 11:42:25 -05:00 committed by Neil Horman
parent 2fb552037c
commit 0961b1bce8
2 changed files with 26 additions and 1 deletions

View File

@ -0,0 +1,20 @@
diff -up kexec-tools-2.0.0/purgatory/Makefile.orig kexec-tools-2.0.0/purgatory/Makefile
--- kexec-tools-2.0.0/purgatory/Makefile.orig 2011-03-10 11:39:22.100799291 -0500
+++ kexec-tools-2.0.0/purgatory/Makefile 2011-03-10 11:39:36.422736886 -0500
@@ -55,14 +55,14 @@ $(PURGATORY): CPPFLAGS=$($(ARCH)_PURGATO
-I$(srcdir)/util_lib/include \
-I$(shell $(CC) -print-file-name=include)
$(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)\
- --no-undefined -nostartfiles -nostdlib -nodefaultlibs \
+ -nostartfiles -nostdlib -nodefaultlibs \
-e purgatory_start -r
$(PURGATORY): $(PURGATORY_OBJS)
$(MKDIR) -p $(@D)
$(CC) $(LDFLAGS) -o $@ $^
-# $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
+# $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
echo::
@echo "PURGATORY_SRCS $(PURGATORY_SRCS)"

View File

@ -1,6 +1,6 @@
Name: kexec-tools
Version: 2.0.0
Release: 43%{?dist}
Release: 44%{?dist}
License: GPLv2
Group: Applications/System
Summary: The kexec/kdump userspace component.
@ -74,6 +74,7 @@ Patch602: kexec-tools-2.0.0-makedumpfile-dynamic-build.patch
Patch603: kexec-tools-2.0.0-makedumpfile-2.6.32-utsname.patch
Patch604: kexec-tools-2.0.0-makedumpfile-boption.patch
Patch605: kexec-tools-2.0.0-makedumpfile-2.6.32-sparsemem.patch
Patch606: kexec-tools-2.0.0-purgatory-makefile.patch
%description
kexec-tools provides /sbin/kexec binary that facilitates a new
@ -96,6 +97,7 @@ tar -z -x -v -f %{SOURCE9}
%patch603 -p1
%patch604 -p1
%patch605 -p1
%patch606 -p1
tar -z -x -v -f %{SOURCE13}
@ -280,6 +282,9 @@ done
%changelog
* Thu Mar 10 2011 Neil Horman <nhorman@redhat.com> - 2.0.0-44
- Fix build break in purgatory makefile
* Thu Mar 10 2011 Neil Horman <nhorman@redhat.com> - 2.0.0-43
- Remove vestigual emitdms code and call from mkdumprd