46 lines
1.4 KiB
Diff
46 lines
1.4 KiB
Diff
#
|
|
# Small compile fixes (For more involved fixes, please use a separate patch).
|
|
#
|
|
# Please add the errors from gcc before the diffs to save others having
|
|
# to do a compile to figure out what your diff is fixing. Thanks.
|
|
#
|
|
# ../../lib/rbtree.c:24:26: fatal error: linux/export.h: No such file or directory
|
|
diff --git a/tools/perf/Makefile b/tools/perf/Makefile
|
|
index b492e3a..2f42886 100644
|
|
--- a/tools/perf/Makefile
|
|
+++ b/tools/perf/Makefile
|
|
@@ -251,7 +251,7 @@ LIB_H += util/include/linux/const.h
|
|
LIB_H += util/include/linux/ctype.h
|
|
LIB_H += util/include/linux/kernel.h
|
|
LIB_H += util/include/linux/list.h
|
|
-LIB_H += util/include/linux/module.h
|
|
+LIB_H += util/include/linux/export.h
|
|
LIB_H += util/include/linux/poison.h
|
|
LIB_H += util/include/linux/prefetch.h
|
|
LIB_H += util/include/linux/rbtree.h
|
|
diff --git a/tools/perf/util/include/linux/export.h b/tools/perf/util/include/linux/export.h
|
|
new file mode 100644
|
|
index 0000000..b43e2dc
|
|
--- /dev/null
|
|
+++ b/tools/perf/util/include/linux/export.h
|
|
@@ -0,0 +1,6 @@
|
|
+#ifndef PERF_LINUX_MODULE_H
|
|
+#define PERF_LINUX_MODULE_H
|
|
+
|
|
+#define EXPORT_SYMBOL(name)
|
|
+
|
|
+#endif
|
|
diff --git a/tools/perf/util/include/linux/module.h b/tools/perf/util/include/linux/module.h
|
|
deleted file mode 100644
|
|
index b43e2dc..0000000
|
|
--- a/tools/perf/util/include/linux/module.h
|
|
+++ /dev/null
|
|
@@ -1,6 +0,0 @@
|
|
-#ifndef PERF_LINUX_MODULE_H
|
|
-#define PERF_LINUX_MODULE_H
|
|
-
|
|
-#define EXPORT_SYMBOL(name)
|
|
-
|
|
-#endif
|
|
--
|