f7a3bf6547
* Thu Aug 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc0.20200813gitdc06fe51d26e.1] - dc06fe51d26e rebase - More mismatches ("Justin M. Forbes") - Fedora config change due to deps ("Justin M. Forbes") - CONFIG_SND_SOC_MAX98390 is now selected by SND_SOC_INTEL_DA7219_MAX98357A_GENERIC ("Justin M. Forbes") - Config change required for build part 2 ("Justin M. Forbes") - Config change required for build ("Justin M. Forbes") - Fedora config update ("Justin M. Forbes") - Revert "Merge branch 'make_configs_fix' into 'os-build'" (Justin Forbes) - redhat/configs/process_configs.sh: Remove *.config.orig files (Prarit Bhargava) - redhat/configs/process_configs.sh: Add process_configs_known_broken flag (Prarit Bhargava) - redhat/Makefile: Fix '*-configs' targets (Prarit Bhargava) - Updated changelog for the release based on v5.8 (Fedora Kernel Team) - Add ability to sync upstream through Makefile (Don Zickus) - Add master merge check (Don Zickus) - Replace hardcoded values 'os-build' and project id with variables (Don Zickus) - gitattributes: Remove unnecesary export restrictions (Prarit Bhargava) - redhat/Makefile.common: Fix MARKER (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
62 lines
1.8 KiB
Diff
62 lines
1.8 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Don Zickus <dzickus@redhat.com>
|
|
Date: Thu, 14 May 2020 10:30:51 -0400
|
|
Subject: [PATCH] x86: Fix compile issues with rh_check_supported()
|
|
|
|
Upstream status: RHEL only
|
|
|
|
The function rh_check_supported is a RHEL function to limit the
|
|
platforms RHEL does not want to support.
|
|
|
|
To avoid imposing this requirement on Fedora, the function was
|
|
wrapped with CONFIG_RHEL_DIFFERENCES so Fedora can disable this.
|
|
|
|
However, this has a few compile warnings that need to be cleaned up
|
|
when disabled.
|
|
|
|
Move CONFIG_RHEL_DIFFERENCES to include the functions themselves
|
|
instead of the call. As the unused functions created warnings.
|
|
|
|
V2: modified stub definition
|
|
|
|
Signed-off-by: Don Zickus <dzickus@redhat.com>
|
|
---
|
|
arch/x86/kernel/setup.c | 6 ++++--
|
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
|
index b57e6dd6d7ef..66441cb9c1af 100644
|
|
--- a/arch/x86/kernel/setup.c
|
|
+++ b/arch/x86/kernel/setup.c
|
|
@@ -757,6 +757,7 @@ static void __init trim_low_memory_range(void)
|
|
memblock_reserve(0, ALIGN(reserve_low, PAGE_SIZE));
|
|
}
|
|
|
|
+#ifdef CONFIG_RHEL_DIFFERENCES
|
|
static bool valid_amd_processor(__u8 family, const char *model_id)
|
|
{
|
|
bool valid;
|
|
@@ -881,6 +882,9 @@ static void rh_check_supported(void)
|
|
if (acpi_disabled && !guest)
|
|
pr_crit("ACPI has been disabled or is not available on this hardware. This may result in a single cpu boot, incorrect PCI IRQ routing, or boot failure.\n");
|
|
}
|
|
+#else
|
|
+#define rh_check_supported()
|
|
+#endif
|
|
|
|
/*
|
|
* Dump out kernel offset information on panic.
|
|
@@ -1371,9 +1375,7 @@ void __init setup_arch(char **cmdline_p)
|
|
efi_apply_memmap_quirks();
|
|
#endif
|
|
|
|
-#ifdef CONFIG_RHEL_DIFFERENCES
|
|
rh_check_supported();
|
|
-#endif
|
|
|
|
unwind_init();
|
|
}
|
|
--
|
|
2.26.2
|
|
|