f7a3bf6547
* Thu Aug 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc0.20200813gitdc06fe51d26e.1] - dc06fe51d26e rebase - More mismatches ("Justin M. Forbes") - Fedora config change due to deps ("Justin M. Forbes") - CONFIG_SND_SOC_MAX98390 is now selected by SND_SOC_INTEL_DA7219_MAX98357A_GENERIC ("Justin M. Forbes") - Config change required for build part 2 ("Justin M. Forbes") - Config change required for build ("Justin M. Forbes") - Fedora config update ("Justin M. Forbes") - Revert "Merge branch 'make_configs_fix' into 'os-build'" (Justin Forbes) - redhat/configs/process_configs.sh: Remove *.config.orig files (Prarit Bhargava) - redhat/configs/process_configs.sh: Add process_configs_known_broken flag (Prarit Bhargava) - redhat/Makefile: Fix '*-configs' targets (Prarit Bhargava) - Updated changelog for the release based on v5.8 (Fedora Kernel Team) - Add ability to sync upstream through Makefile (Don Zickus) - Add master merge check (Don Zickus) - Replace hardcoded values 'os-build' and project id with variables (Don Zickus) - gitattributes: Remove unnecesary export restrictions (Prarit Bhargava) - redhat/Makefile.common: Fix MARKER (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
57 lines
1.6 KiB
Diff
57 lines
1.6 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||
From: Chad Dupuis <cdupuis@redhat.com>
|
||
Date: Thu, 2 Jan 2020 14:24:39 -0500
|
||
Subject: [PATCH] qla4xxx: Remove deprecated PCI IDs from RHEL 8
|
||
|
||
Message-id: <1524063895-23086-1-git-send-email-cdupuis@redhat.com>
|
||
Patchwork-id: 209742
|
||
O-Subject: [RHEL 8 e-stor PATCH] qla4xxx: Remove depricated PCI IDs from RHEL 8.
|
||
Bugzilla: 1518874
|
||
RH-Acked-by: Tomas Henzl <thenzl@redhat.com>
|
||
RH-Acked-by: Jarod Wilson <jarod@redhat.com>
|
||
|
||
Bugzilla: 1518874
|
||
|
||
RHEL 8 specific
|
||
|
||
Brew build: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID822250
|
||
|
||
Three PCI device IDs are marked as deprecated in RHEL 7:
|
||
|
||
PCI_DEVICE_ID_QLOGIC_ISP8022
|
||
PCI_DEVICE_ID_QLOGIC_ISP8324
|
||
PCI_DEVICE_ID_QLOGIC_ISP8042
|
||
|
||
This patch removes them from the PCI table in RHEL 8 so the
|
||
qla4xxx driver will not bind to the hardware.
|
||
|
||
Upstream Status: RHEL only
|
||
Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
||
---
|
||
drivers/scsi/qla4xxx/ql4_os.c | 2 ++
|
||
1 file changed, 2 insertions(+)
|
||
|
||
diff --git a/drivers/scsi/qla4xxx/ql4_os.c b/drivers/scsi/qla4xxx/ql4_os.c
|
||
index bab87e47b238..70545ee26c9c 100644
|
||
--- a/drivers/scsi/qla4xxx/ql4_os.c
|
||
+++ b/drivers/scsi/qla4xxx/ql4_os.c
|
||
@@ -9868,6 +9868,7 @@ static struct pci_device_id qla4xxx_pci_tbl[] = {
|
||
.subvendor = PCI_ANY_ID,
|
||
.subdevice = PCI_ANY_ID,
|
||
},
|
||
+#ifndef CONFIG_RHEL_DIFFERENCES
|
||
{
|
||
.vendor = PCI_VENDOR_ID_QLOGIC,
|
||
.device = PCI_DEVICE_ID_QLOGIC_ISP8022,
|
||
@@ -9886,6 +9887,7 @@ static struct pci_device_id qla4xxx_pci_tbl[] = {
|
||
.subvendor = PCI_ANY_ID,
|
||
.subdevice = PCI_ANY_ID,
|
||
},
|
||
+#endif
|
||
{0, 0},
|
||
};
|
||
MODULE_DEVICE_TABLE(pci, qla4xxx_pci_tbl);
|
||
--
|
||
2.26.2
|
||
|