f7a3bf6547
* Thu Aug 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc0.20200813gitdc06fe51d26e.1] - dc06fe51d26e rebase - More mismatches ("Justin M. Forbes") - Fedora config change due to deps ("Justin M. Forbes") - CONFIG_SND_SOC_MAX98390 is now selected by SND_SOC_INTEL_DA7219_MAX98357A_GENERIC ("Justin M. Forbes") - Config change required for build part 2 ("Justin M. Forbes") - Config change required for build ("Justin M. Forbes") - Fedora config update ("Justin M. Forbes") - Revert "Merge branch 'make_configs_fix' into 'os-build'" (Justin Forbes) - redhat/configs/process_configs.sh: Remove *.config.orig files (Prarit Bhargava) - redhat/configs/process_configs.sh: Add process_configs_known_broken flag (Prarit Bhargava) - redhat/Makefile: Fix '*-configs' targets (Prarit Bhargava) - Updated changelog for the release based on v5.8 (Fedora Kernel Team) - Add ability to sync upstream through Makefile (Don Zickus) - Add master merge check (Don Zickus) - Replace hardcoded values 'os-build' and project id with variables (Don Zickus) - gitattributes: Remove unnecesary export restrictions (Prarit Bhargava) - redhat/Makefile.common: Fix MARKER (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
56 lines
1.9 KiB
Diff
56 lines
1.9 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Joseph Szczypek <jszczype@redhat.com>
|
|
Date: Thu, 2 Jan 2020 14:24:40 -0500
|
|
Subject: [PATCH] hpsa: remove old cciss-based smartarray pci ids
|
|
|
|
Message-id: <1524750809-43700-2-git-send-email-jszczype@redhat.com>
|
|
Patchwork-id: 211573
|
|
O-Subject: [RHEL8 e-stor PATCH 1/2] hpsa: remove old cciss-based smartarray pci ids
|
|
Bugzilla: 1471185
|
|
RH-Acked-by: Maurizio Lombardi <mlombard@redhat.com>
|
|
RH-Acked-by: Tomas Henzl <thenzl@redhat.com>
|
|
|
|
Per discussion with Microsemi, the old PCI IDs for smartarrays
|
|
originally used with the old cciss driver are not being
|
|
supported with RHEL8. They are also not supported with RHEL7.
|
|
Therefore the PCI IDs and the catch-all are being removed.
|
|
|
|
Acked-by: Don Brace <don.brace@microsemi.com>
|
|
Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
|
|
|
Upstream Status: RHEL only
|
|
---
|
|
drivers/scsi/hpsa.c | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/drivers/scsi/hpsa.c b/drivers/scsi/hpsa.c
|
|
index 91794a50b31f..0c3dd00e8664 100644
|
|
--- a/drivers/scsi/hpsa.c
|
|
+++ b/drivers/scsi/hpsa.c
|
|
@@ -82,7 +82,9 @@ MODULE_DESCRIPTION("Driver for HP Smart Array Controller version " \
|
|
MODULE_SUPPORTED_DEVICE("HP Smart Array Controllers");
|
|
MODULE_VERSION(HPSA_DRIVER_VERSION);
|
|
MODULE_LICENSE("GPL");
|
|
+#ifndef CONFIG_RHEL_DIFFERENCES
|
|
MODULE_ALIAS("cciss");
|
|
+#endif
|
|
|
|
static int hpsa_simple_mode;
|
|
module_param(hpsa_simple_mode, int, S_IRUGO|S_IWUSR);
|
|
@@ -144,10 +146,12 @@ static const struct pci_device_id hpsa_pci_device_id[] = {
|
|
{PCI_VENDOR_ID_HP_3PAR, 0x0075, 0x1590, 0x007D},
|
|
{PCI_VENDOR_ID_HP_3PAR, 0x0075, 0x1590, 0x0088},
|
|
{PCI_VENDOR_ID_HP, 0x333f, 0x103c, 0x333f},
|
|
+#ifndef CONFIG_RHEL_DIFFERENCES
|
|
{PCI_VENDOR_ID_HP, PCI_ANY_ID, PCI_ANY_ID, PCI_ANY_ID,
|
|
PCI_CLASS_STORAGE_RAID << 8, 0xffff << 8, 0},
|
|
{PCI_VENDOR_ID_COMPAQ, PCI_ANY_ID, PCI_ANY_ID, PCI_ANY_ID,
|
|
PCI_CLASS_STORAGE_RAID << 8, 0xffff << 8, 0},
|
|
+#endif
|
|
{0,}
|
|
};
|
|
|
|
--
|
|
2.26.2
|
|
|