f7a3bf6547
* Thu Aug 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc0.20200813gitdc06fe51d26e.1] - dc06fe51d26e rebase - More mismatches ("Justin M. Forbes") - Fedora config change due to deps ("Justin M. Forbes") - CONFIG_SND_SOC_MAX98390 is now selected by SND_SOC_INTEL_DA7219_MAX98357A_GENERIC ("Justin M. Forbes") - Config change required for build part 2 ("Justin M. Forbes") - Config change required for build ("Justin M. Forbes") - Fedora config update ("Justin M. Forbes") - Revert "Merge branch 'make_configs_fix' into 'os-build'" (Justin Forbes) - redhat/configs/process_configs.sh: Remove *.config.orig files (Prarit Bhargava) - redhat/configs/process_configs.sh: Add process_configs_known_broken flag (Prarit Bhargava) - redhat/Makefile: Fix '*-configs' targets (Prarit Bhargava) - Updated changelog for the release based on v5.8 (Fedora Kernel Team) - Add ability to sync upstream through Makefile (Don Zickus) - Add master merge check (Don Zickus) - Replace hardcoded values 'os-build' and project id with variables (Don Zickus) - gitattributes: Remove unnecesary export restrictions (Prarit Bhargava) - redhat/Makefile.common: Fix MARKER (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Aaron Ma <aaron.ma@canonical.com>
|
|
Date: Tue, 24 Mar 2020 03:16:39 +0800
|
|
Subject: [PATCH] e1000e: bump up timeout to wait when ME un-configure ULP mode
|
|
|
|
ME takes 2+ seconds to un-configure ULP mode done after resume
|
|
from s2idle on some ThinkPad laptops.
|
|
Without enough wait, reset and re-init will fail with error.
|
|
|
|
Fixes: f15bb6dde738cc8fa0 ("e1000e: Add support for S0ix")
|
|
BugLink: https://bugs.launchpad.net/bugs/1865570
|
|
Signed-off-by: Aaron Ma <aaron.ma@canonical.com>
|
|
---
|
|
drivers/net/ethernet/intel/e1000e/ich8lan.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/drivers/net/ethernet/intel/e1000e/ich8lan.c b/drivers/net/ethernet/intel/e1000e/ich8lan.c
|
|
index b2f2fcfdf732..a9e4c059d402 100644
|
|
--- a/drivers/net/ethernet/intel/e1000e/ich8lan.c
|
|
+++ b/drivers/net/ethernet/intel/e1000e/ich8lan.c
|
|
@@ -1245,9 +1245,9 @@ static s32 e1000_disable_ulp_lpt_lp(struct e1000_hw *hw, bool force)
|
|
ew32(H2ME, mac_reg);
|
|
}
|
|
|
|
- /* Poll up to 300msec for ME to clear ULP_CFG_DONE. */
|
|
+ /* Poll up to 2.5sec for ME to clear ULP_CFG_DONE. */
|
|
while (er32(FWSM) & E1000_FWSM_ULP_CFG_DONE) {
|
|
- if (i++ == 30) {
|
|
+ if (i++ == 250) {
|
|
ret_val = -E1000_ERR_PHY;
|
|
goto out;
|
|
}
|
|
--
|
|
2.26.2
|
|
|