f7a3bf6547
* Thu Aug 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc0.20200813gitdc06fe51d26e.1] - dc06fe51d26e rebase - More mismatches ("Justin M. Forbes") - Fedora config change due to deps ("Justin M. Forbes") - CONFIG_SND_SOC_MAX98390 is now selected by SND_SOC_INTEL_DA7219_MAX98357A_GENERIC ("Justin M. Forbes") - Config change required for build part 2 ("Justin M. Forbes") - Config change required for build ("Justin M. Forbes") - Fedora config update ("Justin M. Forbes") - Revert "Merge branch 'make_configs_fix' into 'os-build'" (Justin Forbes) - redhat/configs/process_configs.sh: Remove *.config.orig files (Prarit Bhargava) - redhat/configs/process_configs.sh: Add process_configs_known_broken flag (Prarit Bhargava) - redhat/Makefile: Fix '*-configs' targets (Prarit Bhargava) - Updated changelog for the release based on v5.8 (Fedora Kernel Team) - Add ability to sync upstream through Makefile (Don Zickus) - Add master merge check (Don Zickus) - Replace hardcoded values 'os-build' and project id with variables (Don Zickus) - gitattributes: Remove unnecesary export restrictions (Prarit Bhargava) - redhat/Makefile.common: Fix MARKER (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
52 lines
2.3 KiB
Diff
52 lines
2.3 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||
From: Raghava Aditya Renukunta <rrenukun@redhat.com>
|
||
Date: Thu, 2 Jan 2020 14:24:38 -0500
|
||
Subject: [PATCH] aacraid: Remove depreciated device and vendor PCI id's
|
||
|
||
Message-id: <20180315040041.9449.8525.stgit@dhcp187-32.khw.lab.eng.bos.redhat.com>
|
||
Patchwork-id: 206793
|
||
O-Subject: [RHEL8 e-stor PATCH] scsi: aacraid: Remove depreciated device and vendor PCI id's
|
||
Bugzilla: 1495307
|
||
RH-Acked-by: Maurizio Lombardi <mlombard@redhat.com>
|
||
RH-Acked-by: Tomas Henzl <thenzl@redhat.com>
|
||
|
||
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id95307
|
||
Brew Info: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID552286
|
||
Upstream Status: N/A (RHEL 8 internal)
|
||
Tested: Code Review
|
||
|
||
Remove Vendor PCI ID and Device PCI ID of depreciated devices from
|
||
aacraid pci table, preventing these device from attaching to the aacraid
|
||
driver.
|
||
|
||
Upstream Status: RHEL only
|
||
Signed-off-by: Raghava Aditya Renukunta <rrenukun@redhat.com>
|
||
Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
||
---
|
||
drivers/scsi/aacraid/linit.c | 2 ++
|
||
1 file changed, 2 insertions(+)
|
||
|
||
diff --git a/drivers/scsi/aacraid/linit.c b/drivers/scsi/aacraid/linit.c
|
||
index 8588da0a0655..2bc9157fb5d3 100644
|
||
--- a/drivers/scsi/aacraid/linit.c
|
||
+++ b/drivers/scsi/aacraid/linit.c
|
||
@@ -78,6 +78,7 @@ char aac_driver_version[] = AAC_DRIVER_FULL_VERSION;
|
||
* Note: The last field is used to index into aac_drivers below.
|
||
*/
|
||
static const struct pci_device_id aac_pci_tbl[] = {
|
||
+#ifndef CONFIG_RHEL_DIFFERENCES
|
||
{ 0x1028, 0x0001, 0x1028, 0x0001, 0, 0, 0 }, /* PERC 2/Si (Iguana/PERC2Si) */
|
||
{ 0x1028, 0x0002, 0x1028, 0x0002, 0, 0, 1 }, /* PERC 3/Di (Opal/PERC3Di) */
|
||
{ 0x1028, 0x0003, 0x1028, 0x0003, 0, 0, 2 }, /* PERC 3/Si (SlimFast/PERC3Si */
|
||
@@ -145,6 +146,7 @@ static const struct pci_device_id aac_pci_tbl[] = {
|
||
{ 0x9005, 0x0285, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 59 }, /* Adaptec Catch All */
|
||
{ 0x9005, 0x0286, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 60 }, /* Adaptec Rocket Catch All */
|
||
{ 0x9005, 0x0288, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 61 }, /* Adaptec NEMER/ARK Catch All */
|
||
+#endif
|
||
{ 0x9005, 0x028b, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 62 }, /* Adaptec PMC Series 6 (Tupelo) */
|
||
{ 0x9005, 0x028c, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 63 }, /* Adaptec PMC Series 7 (Denali) */
|
||
{ 0x9005, 0x028d, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 64 }, /* Adaptec PMC Series 8 */
|
||
--
|
||
2.26.2
|
||
|