98 lines
3.0 KiB
Diff
98 lines
3.0 KiB
Diff
From b9bde1ab2f260d56413511bbb68199ea3c45ec1f Mon Sep 17 00:00:00 2001
|
|
From: Laura Abbott <labbott@redhat.com>
|
|
Date: Tue, 11 Oct 2016 13:10:34 -0700
|
|
Subject: [PATCH 2/2] Revert "tools build: Add support for host programs
|
|
format"
|
|
|
|
This reverts commit 0c3b7e42616f1f6084cfeb0d443cbff0b2c424a9.
|
|
---
|
|
tools/build/Build.include | 5 -----
|
|
tools/build/Makefile | 6 ------
|
|
tools/build/Makefile.build | 19 ++++---------------
|
|
3 files changed, 4 insertions(+), 26 deletions(-)
|
|
|
|
diff --git a/tools/build/Build.include b/tools/build/Build.include
|
|
index 0248938..4d000bc 100644
|
|
--- a/tools/build/Build.include
|
|
+++ b/tools/build/Build.include
|
|
@@ -90,8 +90,3 @@ if_changed = $(if $(strip $(any-prereq) $(arg-check)), \
|
|
# - per object C flags
|
|
# - BUILD_STR macro to allow '-D"$(variable)"' constructs
|
|
c_flags = -Wp,-MD,$(depfile),-MT,$@ $(CFLAGS) -D"BUILD_STR(s)=\#s" $(CFLAGS_$(basetarget).o) $(CFLAGS_$(obj))
|
|
-
|
|
-###
|
|
-## HOSTCC C flags
|
|
-
|
|
-host_c_flags = -Wp,-MD,$(depfile),-MT,$@ $(CHOSTFLAGS) -D"BUILD_STR(s)=\#s" $(CHOSTFLAGS_$(basetarget).o) $(CHOSTFLAGS_$(obj))
|
|
diff --git a/tools/build/Makefile b/tools/build/Makefile
|
|
index 8332959..2659f2f 100644
|
|
--- a/tools/build/Makefile
|
|
+++ b/tools/build/Makefile
|
|
@@ -14,12 +14,6 @@ endef
|
|
$(call allow-override,CC,$(CROSS_COMPILE)gcc)
|
|
$(call allow-override,LD,$(CROSS_COMPILE)ld)
|
|
|
|
-HOSTCC ?= gcc
|
|
-HOSTLD ?= ld
|
|
-HOSTAR ?= ar
|
|
-
|
|
-export HOSTCC HOSTLD HOSTAR
|
|
-
|
|
ifeq ($(V),1)
|
|
Q =
|
|
else
|
|
diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
|
|
index 190519a..27f3583 100644
|
|
--- a/tools/build/Makefile.build
|
|
+++ b/tools/build/Makefile.build
|
|
@@ -58,9 +58,6 @@ quiet_cmd_mkdir = MKDIR $(dir $@)
|
|
quiet_cmd_cc_o_c = CC $@
|
|
cmd_cc_o_c = $(CC) $(c_flags) -c -o $@ $<
|
|
|
|
-quiet_cmd_host_cc_o_c = HOSTCC $@
|
|
- cmd_host_cc_o_c = $(HOSTCC) $(host_c_flags) -c -o $@ $<
|
|
-
|
|
quiet_cmd_cpp_i_c = CPP $@
|
|
cmd_cpp_i_c = $(CC) $(c_flags) -E -o $@ $<
|
|
|
|
@@ -73,24 +70,16 @@ quiet_cmd_gen = GEN $@
|
|
# If there's nothing to link, create empty $@ object.
|
|
quiet_cmd_ld_multi = LD $@
|
|
cmd_ld_multi = $(if $(strip $(obj-y)),\
|
|
- $(LD) -r -o $@ $(filter $(obj-y),$^),rm -f $@; $(AR) rcs $@)
|
|
-
|
|
-quiet_cmd_host_ld_multi = HOSTLD $@
|
|
- cmd_host_ld_multi = $(if $(strip $(obj-y)),\
|
|
- $(HOSTLD) -r -o $@ $(filter $(obj-y),$^),rm -f $@; $(HOSTAR) rcs $@)
|
|
-
|
|
-ifneq ($(filter $(obj),$(hostprogs)),)
|
|
- host = host_
|
|
-endif
|
|
+ $(LD) -r -o $@ $(filter $(obj-y),$^),rm -f $@; $(AR) rcs $@)
|
|
|
|
# Build rules
|
|
$(OUTPUT)%.o: %.c FORCE
|
|
$(call rule_mkdir)
|
|
- $(call if_changed_dep,$(host)cc_o_c)
|
|
+ $(call if_changed_dep,cc_o_c)
|
|
|
|
$(OUTPUT)%.o: %.S FORCE
|
|
$(call rule_mkdir)
|
|
- $(call if_changed_dep,$(host)cc_o_c)
|
|
+ $(call if_changed_dep,cc_o_c)
|
|
|
|
$(OUTPUT)%.i: %.c FORCE
|
|
$(call rule_mkdir)
|
|
@@ -130,7 +119,7 @@ $(sort $(subdir-obj-y)): $(subdir-y) ;
|
|
|
|
$(in-target): $(obj-y) FORCE
|
|
$(call rule_mkdir)
|
|
- $(call if_changed,$(host)ld_multi)
|
|
+ $(call if_changed,ld_multi)
|
|
|
|
__build: $(in-target)
|
|
@:
|
|
--
|
|
2.7.4
|
|
|