d1b6f8c7af
* Thu Apr 23 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc2.20200423git7adc4b399952.1] - 7adc4b399952 rebase - Match template format in kernel.spec.template ("Justin M. Forbes") - Break out the Patches into individual files for dist-git ("Justin M. Forbes") - Break the Red Hat patch into individual commits (Jeremy Cline) - Adjust module filtering so CONFIG_DRM_DP_CEC can be set (Jeremy Cline) - Add a script to generate release tags and branches (Jeremy Cline) - Set CONFIG_VDPA for fedora ("Justin M. Forbes") - Provide defaults in ark-rebase-patches.sh (Jeremy Cline) - Default ark-rebase-patches.sh to not report issues (Jeremy Cline) Resolves: rhbz# Signed-off-by: Jeremy Cline <jcline@redhat.com>
54 lines
1.6 KiB
Diff
54 lines
1.6 KiB
Diff
From 0126c84a2e7cdad9c0f0f74005c4bf1900ceac9c Mon Sep 17 00:00:00 2001
|
|
From: Eugene Syromiatnikov <esyr@redhat.com>
|
|
Date: Thu, 14 Jun 2018 16:36:08 -0400
|
|
Subject: [PATCH] bpf: Add tech preview taint for syscall
|
|
|
|
Message-id: <394af3a9985d1ad9ea6741cb95ff145312d106b9.1528991396.git.esyr@redhat.com>
|
|
Patchwork-id: 8251
|
|
O-Subject: [kernel team] [RHEL8 PATCH v4 3/5] [bpf] bpf: Add tech preview taint for syscall
|
|
Bugzilla: 1559877
|
|
RH-Acked-by: Jiri Benc <jbenc@redhat.com>
|
|
RH-Acked-by: Jesper Dangaard Brouer <brouer@redhat.com>
|
|
|
|
Adding tech preview taint for using the eBPF syscall.
|
|
|
|
Based on a RHEL 7 commit "bpf: Add tech preview taint for syscall" by
|
|
Jiri Olsa.
|
|
|
|
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1559877
|
|
Brew: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=16716594
|
|
|
|
Upstream Status: RHEL only
|
|
Signed-off-by: Jiri Olsa <jolsa@redhat.com>
|
|
Signed-off-by: Eugene Syromiatnikov <esyr@redhat.com>
|
|
Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
|
---
|
|
kernel/bpf/syscall.c | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
|
|
index 39c033265bae..28ed55c3dd18 100644
|
|
--- a/kernel/bpf/syscall.c
|
|
+++ b/kernel/bpf/syscall.c
|
|
@@ -3678,11 +3678,17 @@ static int link_update(union bpf_attr *attr)
|
|
SYSCALL_DEFINE3(bpf, int, cmd, union bpf_attr __user *, uattr, unsigned int, size)
|
|
{
|
|
union bpf_attr attr;
|
|
+ static int marked;
|
|
int err;
|
|
|
|
if (sysctl_unprivileged_bpf_disabled && !capable(CAP_SYS_ADMIN))
|
|
return -EPERM;
|
|
|
|
+ if (!marked) {
|
|
+ mark_tech_preview("eBPF syscall", NULL);
|
|
+ marked = true;
|
|
+ }
|
|
+
|
|
err = bpf_check_uarg_tail_zero(uattr, sizeof(attr), size);
|
|
if (err)
|
|
return err;
|
|
--
|
|
2.26.0
|
|
|