* Thu Apr 23 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc2.20200423git7adc4b399952.1] - 7adc4b399952 rebase - Match template format in kernel.spec.template ("Justin M. Forbes") - Break out the Patches into individual files for dist-git ("Justin M. Forbes") - Break the Red Hat patch into individual commits (Jeremy Cline) - Adjust module filtering so CONFIG_DRM_DP_CEC can be set (Jeremy Cline) - Add a script to generate release tags and branches (Jeremy Cline) - Set CONFIG_VDPA for fedora ("Justin M. Forbes") - Provide defaults in ark-rebase-patches.sh (Jeremy Cline) - Default ark-rebase-patches.sh to not report issues (Jeremy Cline) Resolves: rhbz# Signed-off-by: Jeremy Cline <jcline@redhat.com>
57 lines
2.1 KiB
Diff
57 lines
2.1 KiB
Diff
From 1f5dcf4610aa214af0eb1d34c09bdf85fd10ef2b Mon Sep 17 00:00:00 2001
|
|
From: Mark Salter <msalter@redhat.com>
|
|
Date: Fri, 11 May 2018 21:01:17 -0400
|
|
Subject: [PATCH] acpi: prefer booting with ACPI over DTS
|
|
|
|
Message-id: <20180511210117.10457-1-msalter@redhat.com>
|
|
Patchwork-id: 214708
|
|
O-Subject: [RHEL-8 BZ1576869] [RHEL only] acpi: prefer booting with ACPI over DTS
|
|
Bugzilla: 1576869
|
|
RH-Acked-by: Jonathan Toppins <jtoppins@redhat.com>
|
|
RH-Acked-by: Tony Camuso <tcamuso@redhat.com>
|
|
RH-Acked-by: Bhupesh Sharma <bhsharma@redhat.com>
|
|
RH-Acked-by: Dean Nelson <dnelson@redhat.com>
|
|
|
|
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1576869
|
|
Brew: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=16208479
|
|
Testing: Verified kernel defaults to ACPI on Mustang
|
|
|
|
From: Jonathan Toppins <jtoppins@redhat.com>
|
|
|
|
This patch forces ACPI boot tables to be preferred over DTS.
|
|
|
|
Currently for ACPI to be used a user either has to set acpi=on on the
|
|
kernel command line or make sure any device tree passed to the kernel
|
|
is empty. If the dtb passed to the kernel is non-empty then device-tree
|
|
will be chosen as the boot method of choice.
|
|
|
|
RHEL does not wish to support this boot method so change table boot
|
|
preferences to use ACPI. In the event ACPI table checks fail the kernel
|
|
will fallback to using DTS to boot.
|
|
|
|
Signed-off-by: Jonathan Toppins <jtoppins@redhat.com>
|
|
|
|
Upstream Status: RHEL only
|
|
Signed-off-by: Mark Salter <msalter@redhat.com>
|
|
Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
|
---
|
|
arch/arm64/kernel/acpi.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/arch/arm64/kernel/acpi.c b/arch/arm64/kernel/acpi.c
|
|
index a100483b47c4..29f693734edb 100644
|
|
--- a/arch/arm64/kernel/acpi.c
|
|
+++ b/arch/arm64/kernel/acpi.c
|
|
@@ -39,7 +39,7 @@ int acpi_pci_disabled = 1; /* skip ACPI PCI scan and IRQ initialization */
|
|
EXPORT_SYMBOL(acpi_pci_disabled);
|
|
|
|
static bool param_acpi_off __initdata;
|
|
-static bool param_acpi_on __initdata;
|
|
+static bool param_acpi_on __initdata = true;
|
|
static bool param_acpi_force __initdata;
|
|
|
|
static int __init parse_acpi(char *arg)
|
|
--
|
|
2.26.0
|
|
|