f7a3bf6547
* Thu Aug 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc0.20200813gitdc06fe51d26e.1] - dc06fe51d26e rebase - More mismatches ("Justin M. Forbes") - Fedora config change due to deps ("Justin M. Forbes") - CONFIG_SND_SOC_MAX98390 is now selected by SND_SOC_INTEL_DA7219_MAX98357A_GENERIC ("Justin M. Forbes") - Config change required for build part 2 ("Justin M. Forbes") - Config change required for build ("Justin M. Forbes") - Fedora config update ("Justin M. Forbes") - Revert "Merge branch 'make_configs_fix' into 'os-build'" (Justin Forbes) - redhat/configs/process_configs.sh: Remove *.config.orig files (Prarit Bhargava) - redhat/configs/process_configs.sh: Add process_configs_known_broken flag (Prarit Bhargava) - redhat/Makefile: Fix '*-configs' targets (Prarit Bhargava) - Updated changelog for the release based on v5.8 (Fedora Kernel Team) - Add ability to sync upstream through Makefile (Don Zickus) - Add master merge check (Don Zickus) - Replace hardcoded values 'os-build' and project id with variables (Don Zickus) - gitattributes: Remove unnecesary export restrictions (Prarit Bhargava) - redhat/Makefile.common: Fix MARKER (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
54 lines
1.8 KiB
Diff
54 lines
1.8 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Tomas Henzl <thenzl@redhat.com>
|
|
Date: Thu, 9 Aug 2018 13:44:15 -0400
|
|
Subject: [PATCH] kernel: add SUPPORT_REMOVED kernel taint
|
|
|
|
Message-id: <e9a9812a-6a4c-a205-e66a-1d47de58306a@redhat.com>
|
|
Patchwork-id: 226423
|
|
O-Subject: [RHEL-8.0 V4 01/10] kernel: add SUPPORT_REMOVED kernel taint
|
|
Bugzilla: 1602033
|
|
RH-Acked-by: Maurizio Lombardi <mlombard@redhat.com>
|
|
RH-Acked-by: Jiri Benc <jbenc@redhat.com>
|
|
RH-Acked-by: Rob Evers <revers@redhat.com>
|
|
|
|
Upstream Status: RHEL only
|
|
|
|
rh_taint, pci : add information about removed hardware
|
|
|
|
Upstream Status: RHEL only
|
|
Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
|
---
|
|
include/linux/kernel.h | 2 +-
|
|
kernel/panic.c | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
|
index 2803ec062a16..6753f8e17dfe 100644
|
|
--- a/include/linux/kernel.h
|
|
+++ b/include/linux/kernel.h
|
|
@@ -612,7 +612,7 @@ extern enum system_states {
|
|
#define TAINT_24 24
|
|
#define TAINT_25 25
|
|
#define TAINT_26 26
|
|
-#define TAINT_27 27
|
|
+#define TAINT_SUPPORT_REMOVED 27
|
|
/* Bits 28 - 31 are reserved for Red Hat use only */
|
|
#define TAINT_RESERVED28 28
|
|
#define TAINT_RESERVED29 29
|
|
diff --git a/kernel/panic.c b/kernel/panic.c
|
|
index 2c483bec82d6..e1f2bf843901 100644
|
|
--- a/kernel/panic.c
|
|
+++ b/kernel/panic.c
|
|
@@ -395,7 +395,7 @@ const struct taint_flag taint_flags[TAINT_FLAGS_COUNT] = {
|
|
[ TAINT_24 ] = { '?', '-', false },
|
|
[ TAINT_25 ] = { '?', '-', false },
|
|
[ TAINT_26 ] = { '?', '-', false },
|
|
- [ TAINT_27 ] = { '?', '-', false },
|
|
+ [ TAINT_SUPPORT_REMOVED ] = { 'h', ' ', false },
|
|
[ TAINT_RESERVED28 ] = { '?', '-', false },
|
|
[ TAINT_RESERVED29 ] = { '?', '-', false },
|
|
[ TAINT_RESERVED30 ] = { '?', '-', false },
|
|
--
|
|
2.26.2
|
|
|