f7a3bf6547
* Thu Aug 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc0.20200813gitdc06fe51d26e.1] - dc06fe51d26e rebase - More mismatches ("Justin M. Forbes") - Fedora config change due to deps ("Justin M. Forbes") - CONFIG_SND_SOC_MAX98390 is now selected by SND_SOC_INTEL_DA7219_MAX98357A_GENERIC ("Justin M. Forbes") - Config change required for build part 2 ("Justin M. Forbes") - Config change required for build ("Justin M. Forbes") - Fedora config update ("Justin M. Forbes") - Revert "Merge branch 'make_configs_fix' into 'os-build'" (Justin Forbes) - redhat/configs/process_configs.sh: Remove *.config.orig files (Prarit Bhargava) - redhat/configs/process_configs.sh: Add process_configs_known_broken flag (Prarit Bhargava) - redhat/Makefile: Fix '*-configs' targets (Prarit Bhargava) - Updated changelog for the release based on v5.8 (Fedora Kernel Team) - Add ability to sync upstream through Makefile (Don Zickus) - Add master merge check (Don Zickus) - Replace hardcoded values 'os-build' and project id with variables (Don Zickus) - gitattributes: Remove unnecesary export restrictions (Prarit Bhargava) - redhat/Makefile.common: Fix MARKER (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Peter Robinson <pbrobinson@gmail.com>
|
|
Date: Fri, 10 Jul 2020 16:18:59 +0100
|
|
Subject: [PATCH] Fixes "acpi: prefer booting with ACPI over DTS" to be RHEL
|
|
only
|
|
|
|
The ACPI prefernce is RHEL specific, in Fedora we use upstream defaults so
|
|
it doesn't randomly change the expectations as to how certain hardware works
|
|
that generally isn't classed as "enterprise". So wrap it in the special RHEL
|
|
check as it should be for the ARK kernels.
|
|
|
|
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
|
CC: Mark Salter <msalter@redhat.com>
|
|
---
|
|
arch/arm64/kernel/acpi.c | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/arch/arm64/kernel/acpi.c b/arch/arm64/kernel/acpi.c
|
|
index 5cb0d548ec25..999f0a232e57 100644
|
|
--- a/arch/arm64/kernel/acpi.c
|
|
+++ b/arch/arm64/kernel/acpi.c
|
|
@@ -40,7 +40,11 @@ int acpi_pci_disabled = 1; /* skip ACPI PCI scan and IRQ initialization */
|
|
EXPORT_SYMBOL(acpi_pci_disabled);
|
|
|
|
static bool param_acpi_off __initdata;
|
|
+#ifdef CONFIG_RHEL_DIFFERENCES
|
|
static bool param_acpi_on __initdata = true;
|
|
+#else
|
|
+static bool param_acpi_on __initdata;
|
|
+#endif
|
|
static bool param_acpi_force __initdata;
|
|
|
|
static int __init parse_acpi(char *arg)
|
|
--
|
|
2.26.2
|
|
|