Linux v3.17-8307-gf1d0d14120a8
This commit is contained in:
parent
74b4793119
commit
ff180079f1
@ -29,10 +29,10 @@ index 72665eb80692..2c7b80d31366 100644
|
|||||||
+
|
+
|
||||||
#endif /* _KEYS_SYSTEM_KEYRING_H */
|
#endif /* _KEYS_SYSTEM_KEYRING_H */
|
||||||
diff --git a/init/Kconfig b/init/Kconfig
|
diff --git a/init/Kconfig b/init/Kconfig
|
||||||
index d2355812ba48..4fcd7dd882c2 100644
|
index 1c505e090422..4fb572ae7423 100644
|
||||||
--- a/init/Kconfig
|
--- a/init/Kconfig
|
||||||
+++ b/init/Kconfig
|
+++ b/init/Kconfig
|
||||||
@@ -1722,6 +1722,15 @@ config SYSTEM_TRUSTED_KEYRING
|
@@ -1732,6 +1732,15 @@ config SYSTEM_TRUSTED_KEYRING
|
||||||
|
|
||||||
Keys in this keyring are used by module signature checking.
|
Keys in this keyring are used by module signature checking.
|
||||||
|
|
||||||
|
@ -42,10 +42,10 @@ index 41359e548bcb..db9e6118575e 100644
|
|||||||
efi_guid_t guid;
|
efi_guid_t guid;
|
||||||
u64 table;
|
u64 table;
|
||||||
diff --git a/init/Kconfig b/init/Kconfig
|
diff --git a/init/Kconfig b/init/Kconfig
|
||||||
index 4fcd7dd882c2..65ea201f38af 100644
|
index 4fb572ae7423..b0138f178c7c 100644
|
||||||
--- a/init/Kconfig
|
--- a/init/Kconfig
|
||||||
+++ b/init/Kconfig
|
+++ b/init/Kconfig
|
||||||
@@ -1876,6 +1876,15 @@ config MODULE_SIG_ALL
|
@@ -1886,6 +1886,15 @@ config MODULE_SIG_ALL
|
||||||
comment "Do not forget to sign required modules with scripts/sign-file"
|
comment "Do not forget to sign required modules with scripts/sign-file"
|
||||||
depends on MODULE_SIG_FORCE && !MODULE_SIG_ALL
|
depends on MODULE_SIG_FORCE && !MODULE_SIG_ALL
|
||||||
|
|
||||||
|
@ -15,10 +15,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
|
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
|
||||||
index f8a07128a6e8..41eff584e169 100644
|
index 04e9f5505faa..14563a76c8c8 100644
|
||||||
--- a/Documentation/kernel-parameters.txt
|
--- a/Documentation/kernel-parameters.txt
|
||||||
+++ b/Documentation/kernel-parameters.txt
|
+++ b/Documentation/kernel-parameters.txt
|
||||||
@@ -3625,7 +3625,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
|
@@ -3691,7 +3691,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
|
||||||
the allocated input device; If set to 0, video driver
|
the allocated input device; If set to 0, video driver
|
||||||
will only send out the event without touching backlight
|
will only send out the event without touching backlight
|
||||||
brightness level.
|
brightness level.
|
||||||
|
@ -4838,6 +4838,7 @@ CONFIG_OPTPROBES=y
|
|||||||
CONFIG_HZ_1000=y
|
CONFIG_HZ_1000=y
|
||||||
CONFIG_NO_HZ=y
|
CONFIG_NO_HZ=y
|
||||||
|
|
||||||
|
# CONFIG_SCHED_STACK_END_CHECK is not set
|
||||||
CONFIG_TIMER_STATS=y
|
CONFIG_TIMER_STATS=y
|
||||||
CONFIG_HIGH_RES_TIMERS=y
|
CONFIG_HIGH_RES_TIMERS=y
|
||||||
CONFIG_PERF_EVENTS=y
|
CONFIG_PERF_EVENTS=y
|
||||||
@ -5088,6 +5089,7 @@ CONFIG_RCU_CPU_STALL_TIMEOUT=60
|
|||||||
# CONFIG_RCU_TORTURE_TEST is not set
|
# CONFIG_RCU_TORTURE_TEST is not set
|
||||||
# CONFIG_RCU_TRACE is not set
|
# CONFIG_RCU_TRACE is not set
|
||||||
# CONFIG_RCU_CPU_STALL_INFO is not set
|
# CONFIG_RCU_CPU_STALL_INFO is not set
|
||||||
|
# CONFIG_TASKS_RCU is not set
|
||||||
# CONFIG_RCU_USER_QS is not set
|
# CONFIG_RCU_USER_QS is not set
|
||||||
CONFIG_SPARSE_RCU_POINTER=y
|
CONFIG_SPARSE_RCU_POINTER=y
|
||||||
|
|
||||||
|
@ -9,10 +9,10 @@ Upstream-status: Fedora mustard
|
|||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/init/Kconfig b/init/Kconfig
|
diff --git a/init/Kconfig b/init/Kconfig
|
||||||
index 65ea201f38af..adfc3ba98571 100644
|
index b0138f178c7c..faf5ff3b26ae 100644
|
||||||
--- a/init/Kconfig
|
--- a/init/Kconfig
|
||||||
+++ b/init/Kconfig
|
+++ b/init/Kconfig
|
||||||
@@ -1138,7 +1138,7 @@ config DEBUG_BLK_CGROUP
|
@@ -1148,7 +1148,7 @@ config DEBUG_BLK_CGROUP
|
||||||
endif # CGROUPS
|
endif # CGROUPS
|
||||||
|
|
||||||
config CHECKPOINT_RESTORE
|
config CHECKPOINT_RESTORE
|
||||||
@ -21,7 +21,7 @@ index 65ea201f38af..adfc3ba98571 100644
|
|||||||
default n
|
default n
|
||||||
help
|
help
|
||||||
Enables additional kernel features in a sake of checkpoint/restore.
|
Enables additional kernel features in a sake of checkpoint/restore.
|
||||||
@@ -1149,7 +1149,7 @@ config CHECKPOINT_RESTORE
|
@@ -1159,7 +1159,7 @@ config CHECKPOINT_RESTORE
|
||||||
If unsure, say N here.
|
If unsure, say N here.
|
||||||
|
|
||||||
menuconfig NAMESPACES
|
menuconfig NAMESPACES
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
From: "kernel-team@fedoraproject.org" <kernel-team@fedoraproject.org>
|
|
||||||
Date: Fri, 18 Apr 2014 06:58:29 -0400
|
|
||||||
Subject: [PATCH] disable libdw unwind on non-x86
|
|
||||||
|
|
||||||
Bugzilla: 1025603
|
|
||||||
Upstream-status: ??
|
|
||||||
---
|
|
||||||
tools/perf/config/Makefile | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/tools/perf/config/Makefile b/tools/perf/config/Makefile
|
|
||||||
index 1f67aa02d240..86c21a24da46 100644
|
|
||||||
--- a/tools/perf/config/Makefile
|
|
||||||
+++ b/tools/perf/config/Makefile
|
|
||||||
@@ -52,6 +52,10 @@ ifeq ($(ARCH),powerpc)
|
|
||||||
CFLAGS += -DHAVE_SKIP_CALLCHAIN_IDX
|
|
||||||
endif
|
|
||||||
|
|
||||||
+ifneq ($(ARCH),x86)
|
|
||||||
+ NO_LIBDW_DWARF_UNWIND := 1
|
|
||||||
+endif
|
|
||||||
+
|
|
||||||
ifeq ($(LIBUNWIND_LIBS),)
|
|
||||||
NO_LIBUNWIND := 1
|
|
||||||
else
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
21
kernel.spec
21
kernel.spec
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 6
|
%define gitrev 7
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -568,7 +568,7 @@ Patch14010: lis3-improve-handling-of-null-rate.patch
|
|||||||
Patch15000: watchdog-Disable-watchdog-on-virtual-machines.patch
|
Patch15000: watchdog-Disable-watchdog-on-virtual-machines.patch
|
||||||
|
|
||||||
# PPC
|
# PPC
|
||||||
Patch18000: ppc64-fixtools.patch
|
|
||||||
# ARM64
|
# ARM64
|
||||||
|
|
||||||
# ARMv7
|
# ARMv7
|
||||||
@ -596,11 +596,6 @@ Patch21247: ath9k-rx-dma-stop-check.patch
|
|||||||
|
|
||||||
Patch22000: weird-root-dentry-name-debug.patch
|
Patch22000: weird-root-dentry-name-debug.patch
|
||||||
|
|
||||||
#rhbz 1025603
|
|
||||||
Patch25063: disable-libdw-unwind-on-non-x86.patch
|
|
||||||
|
|
||||||
Patch26000: perf-install-trace-event-plugins.patch
|
|
||||||
|
|
||||||
# Patch series from Hans for various backlight and platform driver fixes
|
# Patch series from Hans for various backlight and platform driver fixes
|
||||||
Patch26002: samsung-laptop-Add-broken-acpi-video-quirk-for-NC210.patch
|
Patch26002: samsung-laptop-Add-broken-acpi-video-quirk-for-NC210.patch
|
||||||
|
|
||||||
@ -1190,7 +1185,7 @@ ApplyOptionalPatch upstream-reverts.patch -R
|
|||||||
ApplyPatch lib-cpumask-Make-CPUMASK_OFFSTACK-usable-without-deb.patch
|
ApplyPatch lib-cpumask-Make-CPUMASK_OFFSTACK-usable-without-deb.patch
|
||||||
|
|
||||||
# PPC
|
# PPC
|
||||||
ApplyPatch ppc64-fixtools.patch
|
|
||||||
# ARM64
|
# ARM64
|
||||||
|
|
||||||
#
|
#
|
||||||
@ -1325,11 +1320,6 @@ ApplyPatch criu-no-expert.patch
|
|||||||
#rhbz 892811
|
#rhbz 892811
|
||||||
ApplyPatch ath9k-rx-dma-stop-check.patch
|
ApplyPatch ath9k-rx-dma-stop-check.patch
|
||||||
|
|
||||||
#rhbz 1025603
|
|
||||||
ApplyPatch disable-libdw-unwind-on-non-x86.patch
|
|
||||||
|
|
||||||
ApplyPatch perf-install-trace-event-plugins.patch
|
|
||||||
|
|
||||||
# Patch series from Hans for various backlight and platform driver fixes
|
# Patch series from Hans for various backlight and platform driver fixes
|
||||||
ApplyPatch samsung-laptop-Add-broken-acpi-video-quirk-for-NC210.patch
|
ApplyPatch samsung-laptop-Add-broken-acpi-video-quirk-for-NC210.patch
|
||||||
|
|
||||||
@ -1883,7 +1873,7 @@ find $RPM_BUILD_ROOT/usr/include \
|
|||||||
|
|
||||||
%if %{with_perf}
|
%if %{with_perf}
|
||||||
# perf tool binary and supporting scripts/binaries
|
# perf tool binary and supporting scripts/binaries
|
||||||
%{perf_make} DESTDIR=$RPM_BUILD_ROOT MULTILIBDIR=%{_lib} install-bin install-traceevent-plugins
|
%{perf_make} DESTDIR=$RPM_BUILD_ROOT lib=%{_lib} install-bin install-traceevent-plugins
|
||||||
# remove the 'trace' symlink.
|
# remove the 'trace' symlink.
|
||||||
rm -f %{buildroot}%{_bindir}/trace
|
rm -f %{buildroot}%{_bindir}/trace
|
||||||
|
|
||||||
@ -2214,6 +2204,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 14 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.18.0-0.rc0.git7.1
|
||||||
|
- Linux v3.17-8307-gf1d0d14120a8
|
||||||
|
|
||||||
* Mon Oct 13 2014 Peter Robinson <pbrobinson@fedoraproject.org>
|
* Mon Oct 13 2014 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||||
- Update armv7/aarch64 config options
|
- Update armv7/aarch64 config options
|
||||||
|
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From: Kyle McMartin <kmcmarti@redhat.com>
|
|
||||||
Date: Mon, 2 Jun 2014 15:11:01 -0400
|
|
||||||
Subject: [PATCH] perf: install trace-event plugins
|
|
||||||
|
|
||||||
perf hardcodes $libdir to be lib for all but x86_64, so kludge around it
|
|
||||||
until upstream gets their act together.
|
|
||||||
---
|
|
||||||
tools/perf/config/Makefile | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/tools/perf/config/Makefile b/tools/perf/config/Makefile
|
|
||||||
index 86c21a24da46..bf0fe97bd358 100644
|
|
||||||
--- a/tools/perf/config/Makefile
|
|
||||||
+++ b/tools/perf/config/Makefile
|
|
||||||
@@ -642,8 +642,12 @@ endif
|
|
||||||
ifeq ($(IS_X86_64),1)
|
|
||||||
lib = lib64
|
|
||||||
else
|
|
||||||
+ifdef MULTILIBDIR
|
|
||||||
+lib = $(MULTILIBDIR)
|
|
||||||
+else
|
|
||||||
lib = lib
|
|
||||||
endif
|
|
||||||
+endif
|
|
||||||
libdir = $(prefix)/$(lib)
|
|
||||||
|
|
||||||
# Shell quote (do not use $(call) to accommodate ancient setups);
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
@ -1,24 +0,0 @@
|
|||||||
From: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
Date: Mon, 6 Oct 2014 15:15:15 +0100
|
|
||||||
Subject: [PATCH] ppc64-fixtools
|
|
||||||
|
|
||||||
Build tools on ppc64le (rhbz 1138884), Some minor ppc64 cleanups
|
|
||||||
---
|
|
||||||
tools/perf/arch/powerpc/util/skip-callchain-idx.c | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/tools/perf/arch/powerpc/util/skip-callchain-idx.c b/tools/perf/arch/powerpc/util/skip-callchain-idx.c
|
|
||||||
index a7c23a4b3778..d73ef8bb08c7 100644
|
|
||||||
--- a/tools/perf/arch/powerpc/util/skip-callchain-idx.c
|
|
||||||
+++ b/tools/perf/arch/powerpc/util/skip-callchain-idx.c
|
|
||||||
@@ -15,6 +15,7 @@
|
|
||||||
|
|
||||||
#include "util/thread.h"
|
|
||||||
#include "util/callchain.h"
|
|
||||||
+#include "util/debug.h"
|
|
||||||
|
|
||||||
/*
|
|
||||||
* When saving the callchain on Power, the kernel conservatively saves
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
fb30d0f29214d75cddd2faa94f73d5cf linux-3.17.tar.xz
|
fb30d0f29214d75cddd2faa94f73d5cf linux-3.17.tar.xz
|
||||||
159e969cbc27201d8e2fa0f609dc722f perf-man-3.17.tar.gz
|
159e969cbc27201d8e2fa0f609dc722f perf-man-3.17.tar.gz
|
||||||
5740b0a6b49144f85e75da8acb275576 patch-3.17-git6.xz
|
992c678dad773514a9c3ae553fe50d1c patch-3.17-git7.xz
|
||||||
|
@ -20,10 +20,10 @@ Signed-off-by: Dave Jones <davej@redhat.com>
|
|||||||
1 file changed, 29 insertions(+)
|
1 file changed, 29 insertions(+)
|
||||||
|
|
||||||
diff --git a/kernel/watchdog.c b/kernel/watchdog.c
|
diff --git a/kernel/watchdog.c b/kernel/watchdog.c
|
||||||
index 7b223b212683..4757d7410087 100644
|
index ff7fd80bef99..88aebd38b92f 100644
|
||||||
--- a/kernel/watchdog.c
|
--- a/kernel/watchdog.c
|
||||||
+++ b/kernel/watchdog.c
|
+++ b/kernel/watchdog.c
|
||||||
@@ -24,6 +24,7 @@
|
@@ -19,6 +19,7 @@
|
||||||
#include <linux/sysctl.h>
|
#include <linux/sysctl.h>
|
||||||
#include <linux/smpboot.h>
|
#include <linux/smpboot.h>
|
||||||
#include <linux/sched/rt.h>
|
#include <linux/sched/rt.h>
|
||||||
@ -31,7 +31,7 @@ index 7b223b212683..4757d7410087 100644
|
|||||||
|
|
||||||
#include <asm/irq_regs.h>
|
#include <asm/irq_regs.h>
|
||||||
#include <linux/kvm_para.h>
|
#include <linux/kvm_para.h>
|
||||||
@@ -113,6 +114,32 @@ static int __init softlockup_all_cpu_backtrace_setup(char *str)
|
@@ -108,6 +109,32 @@ static int __init softlockup_all_cpu_backtrace_setup(char *str)
|
||||||
__setup("softlockup_all_cpu_backtrace=", softlockup_all_cpu_backtrace_setup);
|
__setup("softlockup_all_cpu_backtrace=", softlockup_all_cpu_backtrace_setup);
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -64,7 +64,7 @@ index 7b223b212683..4757d7410087 100644
|
|||||||
/*
|
/*
|
||||||
* Hard-lockup warnings should be triggered after just a few seconds. Soft-
|
* Hard-lockup warnings should be triggered after just a few seconds. Soft-
|
||||||
* lockups can have false positives under extreme conditions. So we generally
|
* lockups can have false positives under extreme conditions. So we generally
|
||||||
@@ -660,6 +687,8 @@ out:
|
@@ -658,6 +685,8 @@ out:
|
||||||
|
|
||||||
void __init lockup_detector_init(void)
|
void __init lockup_detector_init(void)
|
||||||
{
|
{
|
||||||
|
Loading…
Reference in New Issue
Block a user