Linux v3.9-rc3-148-g2ffdd7e
- Fixes CVE-2013-1796, CVE-2013-1797, CVE-2013-1798 in kvm.
This commit is contained in:
parent
eeb8b24898
commit
f09cfb8300
@ -1,61 +0,0 @@
|
|||||||
From fe7963cbe464048cfae4523975aa208a6c7dc420 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Boyer <jwboyer@redhat.com>
|
|
||||||
Date: Mon, 18 Feb 2013 10:32:13 -0500
|
|
||||||
Subject: [PATCH] bluetooth: Add support for atheros 04ca:3004 device to ath3k
|
|
||||||
|
|
||||||
Yet another version of the atheros bluetooth chipset
|
|
||||||
|
|
||||||
T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
|
|
||||||
D: Ver= 1.10 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
|
|
||||||
P: Vendor=04ca ProdID=3004 Rev=00.01
|
|
||||||
S: Manufacturer=Atheros Communications
|
|
||||||
S: Product=Bluetooth USB Host Controller
|
|
||||||
S: SerialNumber=Alaska Day 2006
|
|
||||||
C: #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
|
|
||||||
I: If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
|
|
||||||
I: If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
|
|
||||||
|
|
||||||
This resolves https://bugzilla.redhat.com/show_bug.cgi?id=844750
|
|
||||||
|
|
||||||
Reported-by: niktr@mail.ru
|
|
||||||
Signed-off-by: Josh Boyer <jwboyer@redhat.com>
|
|
||||||
---
|
|
||||||
drivers/bluetooth/ath3k.c | 2 ++
|
|
||||||
drivers/bluetooth/btusb.c | 1 +
|
|
||||||
2 files changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/bluetooth/ath3k.c b/drivers/bluetooth/ath3k.c
|
|
||||||
index 33c9a44..b9908dd 100644
|
|
||||||
--- a/drivers/bluetooth/ath3k.c
|
|
||||||
+++ b/drivers/bluetooth/ath3k.c
|
|
||||||
@@ -76,6 +76,7 @@ static struct usb_device_id ath3k_table[] = {
|
|
||||||
{ USB_DEVICE(0x0CF3, 0x3004) },
|
|
||||||
{ USB_DEVICE(0x0CF3, 0x311D) },
|
|
||||||
{ USB_DEVICE(0x13d3, 0x3375) },
|
|
||||||
+ { USB_DEVICE(0x04CA, 0x3004) },
|
|
||||||
{ USB_DEVICE(0x04CA, 0x3005) },
|
|
||||||
{ USB_DEVICE(0x04CA, 0x3006) },
|
|
||||||
{ USB_DEVICE(0x04CA, 0x3008) },
|
|
||||||
@@ -108,6 +109,7 @@ static struct usb_device_id ath3k_blist_tbl[] = {
|
|
||||||
{ USB_DEVICE(0x0cf3, 0x3004), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x0cf3, 0x311D), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x13d3, 0x3375), .driver_info = BTUSB_ATH3012 },
|
|
||||||
+ { USB_DEVICE(0x04ca, 0x3004), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x04ca, 0x3005), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x04ca, 0x3006), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x04ca, 0x3008), .driver_info = BTUSB_ATH3012 },
|
|
||||||
diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
|
|
||||||
index 7e351e3..59cde8e 100644
|
|
||||||
--- a/drivers/bluetooth/btusb.c
|
|
||||||
+++ b/drivers/bluetooth/btusb.c
|
|
||||||
@@ -134,6 +134,7 @@ static struct usb_device_id blacklist_table[] = {
|
|
||||||
{ USB_DEVICE(0x0cf3, 0x3004), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x0cf3, 0x311d), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x13d3, 0x3375), .driver_info = BTUSB_ATH3012 },
|
|
||||||
+ { USB_DEVICE(0x04ca, 0x3004), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x04ca, 0x3005), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x04ca, 0x3006), .driver_info = BTUSB_ATH3012 },
|
|
||||||
{ USB_DEVICE(0x04ca, 0x3008), .driver_info = BTUSB_ATH3012 },
|
|
||||||
--
|
|
||||||
1.8.1.2
|
|
||||||
|
|
14
kernel.spec
14
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 5
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 3
|
%define rcrev 3
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 1
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -727,9 +727,6 @@ Patch21242: criu-no-expert.patch
|
|||||||
#rhbz 892811
|
#rhbz 892811
|
||||||
Patch21247: ath9k_rx_dma_stop_check.patch
|
Patch21247: ath9k_rx_dma_stop_check.patch
|
||||||
|
|
||||||
#rhbz 844750
|
|
||||||
Patch21250: 0001-bluetooth-Add-support-for-atheros-04ca-3004-device-t.patch
|
|
||||||
|
|
||||||
#rhbz 903192
|
#rhbz 903192
|
||||||
Patch21261: 0001-kmsg-Honor-dmesg_restrict-sysctl-on-dev-kmsg.patch
|
Patch21261: 0001-kmsg-Honor-dmesg_restrict-sysctl-on-dev-kmsg.patch
|
||||||
|
|
||||||
@ -1430,9 +1427,6 @@ ApplyPatch criu-no-expert.patch
|
|||||||
#rhbz 892811
|
#rhbz 892811
|
||||||
ApplyPatch ath9k_rx_dma_stop_check.patch
|
ApplyPatch ath9k_rx_dma_stop_check.patch
|
||||||
|
|
||||||
#rhbz 844750
|
|
||||||
ApplyPatch 0001-bluetooth-Add-support-for-atheros-04ca-3004-device-t.patch
|
|
||||||
|
|
||||||
#rhbz 903192
|
#rhbz 903192
|
||||||
ApplyPatch 0001-kmsg-Honor-dmesg_restrict-sysctl-on-dev-kmsg.patch
|
ApplyPatch 0001-kmsg-Honor-dmesg_restrict-sysctl-on-dev-kmsg.patch
|
||||||
|
|
||||||
@ -2290,6 +2284,10 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 21 2013 Josh Boyer <jwboyer@redhat.com> - 3.9.0-0.rc3.git1.1
|
||||||
|
- Linux v3.9-rc3-148-g2ffdd7e
|
||||||
|
- Fixes CVE-2013-1796, CVE-2013-1797, CVE-2013-1798 in kvm.
|
||||||
|
|
||||||
* Wed Mar 20 2013 Dave Jones <davej@redhat.com>
|
* Wed Mar 20 2013 Dave Jones <davej@redhat.com>
|
||||||
- Enable CONFIG_DM_DELAY (rhbz 923721)
|
- Enable CONFIG_DM_DELAY (rhbz 923721)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user