Fix build fail on s390x
This commit is contained in:
parent
f19b8f46b4
commit
f055781cf8
10
kernel.spec
10
kernel.spec
@ -40,7 +40,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 8
|
%global baserelease 9
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -641,6 +641,9 @@ Patch25069: 0001-acpi-video-Add-4-new-models-to-the-use_native_backli.patch
|
|||||||
#rhbz 1089545
|
#rhbz 1089545
|
||||||
Patch25070: 0001-acpi-video-Add-use_native_backlight-quirks-for-Think.patch
|
Patch25070: 0001-acpi-video-Add-use_native_backlight-quirks-for-Think.patch
|
||||||
|
|
||||||
|
Patch25071: s390-appldata-add-slab.h-for-kzalloc-kfree.patch
|
||||||
|
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1361,6 +1364,8 @@ ApplyPatch 0001-acpi-video-Add-4-new-models-to-the-use_native_backli.patch
|
|||||||
#rhbz 1089545
|
#rhbz 1089545
|
||||||
ApplyPatch 0001-acpi-video-Add-use_native_backlight-quirks-for-Think.patch
|
ApplyPatch 0001-acpi-video-Add-use_native_backlight-quirks-for-Think.patch
|
||||||
|
|
||||||
|
ApplyPatch s390-appldata-add-slab.h-for-kzalloc-kfree.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2231,6 +2236,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 15 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc5.git2.9
|
||||||
|
- Fix build fail on s390x
|
||||||
|
|
||||||
* Wed May 14 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc5.git2.8
|
* Wed May 14 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc5.git2.8
|
||||||
- Enable autoprov for kernel module Provides (rhbz 1058331)
|
- Enable autoprov for kernel module Provides (rhbz 1058331)
|
||||||
- Enable xz compressed modules (from Kyle McMartin)
|
- Enable xz compressed modules (from Kyle McMartin)
|
||||||
|
28
s390-appldata-add-slab.h-for-kzalloc-kfree.patch
Normal file
28
s390-appldata-add-slab.h-for-kzalloc-kfree.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 1eb5e8b7449ff017c2f358d97bd2fcd4eb87cc53 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jeff Mahoney <jeffm@suse.com>
|
||||||
|
Date: Sun, 27 Apr 2014 17:35:43 -0400
|
||||||
|
Subject: s390/appldata: add slab.h for kzalloc/kfree
|
||||||
|
|
||||||
|
This fixes:
|
||||||
|
arch/s390/appldata/appldata_mem.c:135:2: error: implicit declaration of function 'kzalloc' [-Werror=implicit-function-declaration]
|
||||||
|
arch/s390/appldata/appldata_mem.c:141:3: error: implicit declaration of function 'kfree' [-Werror=implicit-function-declaration]
|
||||||
|
|
||||||
|
Signed-off-by: Jeff Mahoney <jeffm@suse.com>
|
||||||
|
Signed-off-by: Heiko Carstens <heiko.carstens@de.ibm.com>
|
||||||
|
Signed-off-by: Martin Schwidefsky <schwidefsky@de.ibm.com>
|
||||||
|
|
||||||
|
diff --git a/arch/s390/appldata/appldata_mem.c b/arch/s390/appldata/appldata_mem.c
|
||||||
|
index 42be537..edcf2a7 100644
|
||||||
|
--- a/arch/s390/appldata/appldata_mem.c
|
||||||
|
+++ b/arch/s390/appldata/appldata_mem.c
|
||||||
|
@@ -13,6 +13,7 @@
|
||||||
|
#include <linux/kernel_stat.h>
|
||||||
|
#include <linux/pagemap.h>
|
||||||
|
#include <linux/swap.h>
|
||||||
|
+#include <linux/slab.h>
|
||||||
|
#include <asm/io.h>
|
||||||
|
|
||||||
|
#include "appldata.h"
|
||||||
|
--
|
||||||
|
cgit v0.10.1
|
||||||
|
|
Loading…
Reference in New Issue
Block a user