Linux v3.13-rc1-252-gdda9cc3
This commit is contained in:
parent
78c2e3a21d
commit
eff40fb8eb
@ -1,54 +0,0 @@
|
|||||||
Bugzilla: N/A
|
|
||||||
Upstream-status: https://lkml.org/lkml/2013/11/12/413 (hopefully 3.13)
|
|
||||||
|
|
||||||
From ce4a59012b5f2a9b521cad4610f055a792841951 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Boyer <jwboyer@fedoraproject.org>
|
|
||||||
Date: Tue, 12 Nov 2013 11:03:57 -0500
|
|
||||||
Subject: [PATCH] staging: imx-drm: Fix modular build of DRM_IMX_IPUV3
|
|
||||||
|
|
||||||
commit b8d181e408af (staging: drm/imx: add drm plane support) added a file
|
|
||||||
to the make target for DRM_IMX_IPUV3 but didn't adjust the objs required
|
|
||||||
to actually build that as a module. Kbuild got confused and this lead to
|
|
||||||
link errors like:
|
|
||||||
|
|
||||||
ERROR: "ipu_plane_disable" [drivers/staging/imx-drm/ipuv3-crtc.ko] undefined!
|
|
||||||
ERROR: "ipu_plane_enable" [drivers/staging/imx-drm/ipuv3-crtc.ko] undefined!
|
|
||||||
|
|
||||||
Additionally, it added a call to imx_drm_crtc_id which also fails with a
|
|
||||||
link error as above. To fix this, we adjust the make target with the proper
|
|
||||||
objs, which will change the name of the resulting .ko. We also add an
|
|
||||||
EXPORT_SYMBOL_GPL for imx_drm_crtc_id.
|
|
||||||
|
|
||||||
Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|
||||||
---
|
|
||||||
drivers/staging/imx-drm/Makefile | 4 +++-
|
|
||||||
drivers/staging/imx-drm/imx-drm-core.c | 1 +
|
|
||||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/staging/imx-drm/Makefile b/drivers/staging/imx-drm/Makefile
|
|
||||||
index 2c3a9e1..8742432 100644
|
|
||||||
--- a/drivers/staging/imx-drm/Makefile
|
|
||||||
+++ b/drivers/staging/imx-drm/Makefile
|
|
||||||
@@ -8,4 +8,6 @@ obj-$(CONFIG_DRM_IMX_TVE) += imx-tve.o
|
|
||||||
obj-$(CONFIG_DRM_IMX_LDB) += imx-ldb.o
|
|
||||||
obj-$(CONFIG_DRM_IMX_FB_HELPER) += imx-fbdev.o
|
|
||||||
obj-$(CONFIG_DRM_IMX_IPUV3_CORE) += ipu-v3/
|
|
||||||
-obj-$(CONFIG_DRM_IMX_IPUV3) += ipuv3-crtc.o ipuv3-plane.o
|
|
||||||
+
|
|
||||||
+imx-ipuv3-crtc-objs := ipuv3-crtc.o ipuv3-plane.o
|
|
||||||
+obj-$(CONFIG_DRM_IMX_IPUV3) += imx-ipuv3-crtc.o
|
|
||||||
diff --git a/drivers/staging/imx-drm/imx-drm-core.c b/drivers/staging/imx-drm/imx-drm-core.c
|
|
||||||
index 4483d47..2b366d8 100644
|
|
||||||
--- a/drivers/staging/imx-drm/imx-drm-core.c
|
|
||||||
+++ b/drivers/staging/imx-drm/imx-drm-core.c
|
|
||||||
@@ -72,6 +72,7 @@ int imx_drm_crtc_id(struct imx_drm_crtc *crtc)
|
|
||||||
{
|
|
||||||
return crtc->pipe;
|
|
||||||
}
|
|
||||||
+EXPORT_SYMBOL_GPL(imx_drm_crtc_id);
|
|
||||||
|
|
||||||
static void imx_drm_driver_lastclose(struct drm_device *drm)
|
|
||||||
{
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 1
|
%define rcrev 1
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 3
|
%define gitrev 4
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -705,8 +705,6 @@ Patch25128: dm-cache-policy-mq_fix-large-scale-table-allocation-bug.patch
|
|||||||
#rhbz 1000439
|
#rhbz 1000439
|
||||||
Patch25129: cpupower-Fix-segfault-due-to-incorrect-getopt_long-a.patch
|
Patch25129: cpupower-Fix-segfault-due-to-incorrect-getopt_long-a.patch
|
||||||
|
|
||||||
Patch25142: 0001-staging-imx-drm-Fix-modular-build-of-DRM_IMX_IPUV3.patch
|
|
||||||
|
|
||||||
#CVE-2013-6382 rhbz 1033603 1034670
|
#CVE-2013-6382 rhbz 1033603 1034670
|
||||||
Patch25157: xfs-underflow-bug-in-xfs_attrlist_by_handle.patch
|
Patch25157: xfs-underflow-bug-in-xfs_attrlist_by_handle.patch
|
||||||
|
|
||||||
@ -1381,8 +1379,6 @@ ApplyPatch dm-cache-policy-mq_fix-large-scale-table-allocation-bug.patch
|
|||||||
#rhbz 1000439
|
#rhbz 1000439
|
||||||
ApplyPatch cpupower-Fix-segfault-due-to-incorrect-getopt_long-a.patch
|
ApplyPatch cpupower-Fix-segfault-due-to-incorrect-getopt_long-a.patch
|
||||||
|
|
||||||
ApplyPatch 0001-staging-imx-drm-Fix-modular-build-of-DRM_IMX_IPUV3.patch
|
|
||||||
|
|
||||||
#CVE-2013-6382 rhbz 1033603 1034670
|
#CVE-2013-6382 rhbz 1033603 1034670
|
||||||
ApplyPatch xfs-underflow-bug-in-xfs_attrlist_by_handle.patch
|
ApplyPatch xfs-underflow-bug-in-xfs_attrlist_by_handle.patch
|
||||||
|
|
||||||
@ -2198,6 +2194,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 29 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.13.0-0.rc1.git4.1
|
||||||
|
- Linux v3.13-rc1-252-gdda9cc3
|
||||||
|
|
||||||
* Tue Nov 26 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.13.0-0.rc1.git3.1
|
* Tue Nov 26 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.13.0-0.rc1.git3.1
|
||||||
- Linux v3.13-rc1-128-g0e4b074
|
- Linux v3.13-rc1-128-g0e4b074
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
cc6ee608854e0da4b64f6c1ff8b6398c linux-3.12.tar.xz
|
cc6ee608854e0da4b64f6c1ff8b6398c linux-3.12.tar.xz
|
||||||
7697217bcae1c083c8253e50db6172ee patch-3.13-rc1.xz
|
7697217bcae1c083c8253e50db6172ee patch-3.13-rc1.xz
|
||||||
4c545b46b0f662f0c0f1ad3c7d7816ad patch-3.13-rc1-git3.xz
|
bf83dad35cb26e9e17dc61bef8801f73 patch-3.13-rc1-git4.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user