Revert possible commits causing perf build failures
This commit is contained in:
parent
e8a4d25680
commit
ee8b7cf7ab
@ -0,0 +1,51 @@
|
||||
From 13304cca47c956c308ce8f3fc7b37b61895fa1ea Mon Sep 17 00:00:00 2001
|
||||
From: Laura Abbott <labbott@redhat.com>
|
||||
Date: Tue, 11 Oct 2016 13:10:26 -0700
|
||||
Subject: [PATCH 1/2] Revert "tools build: Support compiling C++ source file"
|
||||
|
||||
This reverts commit f61bdc3304281e9ff9eec4f1ed9fb15bcf4d8a5e.
|
||||
---
|
||||
tools/build/Build.include | 1 -
|
||||
tools/build/Makefile.build | 7 -------
|
||||
2 files changed, 8 deletions(-)
|
||||
|
||||
diff --git a/tools/build/Build.include b/tools/build/Build.include
|
||||
index 1dcb95e..0248938 100644
|
||||
--- a/tools/build/Build.include
|
||||
+++ b/tools/build/Build.include
|
||||
@@ -90,7 +90,6 @@ if_changed = $(if $(strip $(any-prereq) $(arg-check)), \
|
||||
# - per object C flags
|
||||
# - BUILD_STR macro to allow '-D"$(variable)"' constructs
|
||||
c_flags = -Wp,-MD,$(depfile),-MT,$@ $(CFLAGS) -D"BUILD_STR(s)=\#s" $(CFLAGS_$(basetarget).o) $(CFLAGS_$(obj))
|
||||
-cxx_flags = -Wp,-MD,$(depfile),-MT,$@ $(CXXFLAGS) -D"BUILD_STR(s)=\#s" $(CXXFLAGS_$(basetarget).o) $(CXXFLAGS_$(obj))
|
||||
|
||||
###
|
||||
## HOSTCC C flags
|
||||
diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
|
||||
index 99c0ccd..190519a 100644
|
||||
--- a/tools/build/Makefile.build
|
||||
+++ b/tools/build/Makefile.build
|
||||
@@ -61,9 +61,6 @@ quiet_cmd_cc_o_c = CC $@
|
||||
quiet_cmd_host_cc_o_c = HOSTCC $@
|
||||
cmd_host_cc_o_c = $(HOSTCC) $(host_c_flags) -c -o $@ $<
|
||||
|
||||
-quiet_cmd_cxx_o_c = CXX $@
|
||||
- cmd_cxx_o_c = $(CXX) $(cxx_flags) -c -o $@ $<
|
||||
-
|
||||
quiet_cmd_cpp_i_c = CPP $@
|
||||
cmd_cpp_i_c = $(CC) $(c_flags) -E -o $@ $<
|
||||
|
||||
@@ -91,10 +88,6 @@ $(OUTPUT)%.o: %.c FORCE
|
||||
$(call rule_mkdir)
|
||||
$(call if_changed_dep,$(host)cc_o_c)
|
||||
|
||||
-$(OUTPUT)%.o: %.cpp FORCE
|
||||
- $(call rule_mkdir)
|
||||
- $(call if_changed_dep,cxx_o_c)
|
||||
-
|
||||
$(OUTPUT)%.o: %.S FORCE
|
||||
$(call rule_mkdir)
|
||||
$(call if_changed_dep,$(host)cc_o_c)
|
||||
--
|
||||
2.7.4
|
||||
|
@ -0,0 +1,97 @@
|
||||
From b9bde1ab2f260d56413511bbb68199ea3c45ec1f Mon Sep 17 00:00:00 2001
|
||||
From: Laura Abbott <labbott@redhat.com>
|
||||
Date: Tue, 11 Oct 2016 13:10:34 -0700
|
||||
Subject: [PATCH 2/2] Revert "tools build: Add support for host programs
|
||||
format"
|
||||
|
||||
This reverts commit 0c3b7e42616f1f6084cfeb0d443cbff0b2c424a9.
|
||||
---
|
||||
tools/build/Build.include | 5 -----
|
||||
tools/build/Makefile | 6 ------
|
||||
tools/build/Makefile.build | 19 ++++---------------
|
||||
3 files changed, 4 insertions(+), 26 deletions(-)
|
||||
|
||||
diff --git a/tools/build/Build.include b/tools/build/Build.include
|
||||
index 0248938..4d000bc 100644
|
||||
--- a/tools/build/Build.include
|
||||
+++ b/tools/build/Build.include
|
||||
@@ -90,8 +90,3 @@ if_changed = $(if $(strip $(any-prereq) $(arg-check)), \
|
||||
# - per object C flags
|
||||
# - BUILD_STR macro to allow '-D"$(variable)"' constructs
|
||||
c_flags = -Wp,-MD,$(depfile),-MT,$@ $(CFLAGS) -D"BUILD_STR(s)=\#s" $(CFLAGS_$(basetarget).o) $(CFLAGS_$(obj))
|
||||
-
|
||||
-###
|
||||
-## HOSTCC C flags
|
||||
-
|
||||
-host_c_flags = -Wp,-MD,$(depfile),-MT,$@ $(CHOSTFLAGS) -D"BUILD_STR(s)=\#s" $(CHOSTFLAGS_$(basetarget).o) $(CHOSTFLAGS_$(obj))
|
||||
diff --git a/tools/build/Makefile b/tools/build/Makefile
|
||||
index 8332959..2659f2f 100644
|
||||
--- a/tools/build/Makefile
|
||||
+++ b/tools/build/Makefile
|
||||
@@ -14,12 +14,6 @@ endef
|
||||
$(call allow-override,CC,$(CROSS_COMPILE)gcc)
|
||||
$(call allow-override,LD,$(CROSS_COMPILE)ld)
|
||||
|
||||
-HOSTCC ?= gcc
|
||||
-HOSTLD ?= ld
|
||||
-HOSTAR ?= ar
|
||||
-
|
||||
-export HOSTCC HOSTLD HOSTAR
|
||||
-
|
||||
ifeq ($(V),1)
|
||||
Q =
|
||||
else
|
||||
diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
|
||||
index 190519a..27f3583 100644
|
||||
--- a/tools/build/Makefile.build
|
||||
+++ b/tools/build/Makefile.build
|
||||
@@ -58,9 +58,6 @@ quiet_cmd_mkdir = MKDIR $(dir $@)
|
||||
quiet_cmd_cc_o_c = CC $@
|
||||
cmd_cc_o_c = $(CC) $(c_flags) -c -o $@ $<
|
||||
|
||||
-quiet_cmd_host_cc_o_c = HOSTCC $@
|
||||
- cmd_host_cc_o_c = $(HOSTCC) $(host_c_flags) -c -o $@ $<
|
||||
-
|
||||
quiet_cmd_cpp_i_c = CPP $@
|
||||
cmd_cpp_i_c = $(CC) $(c_flags) -E -o $@ $<
|
||||
|
||||
@@ -73,24 +70,16 @@ quiet_cmd_gen = GEN $@
|
||||
# If there's nothing to link, create empty $@ object.
|
||||
quiet_cmd_ld_multi = LD $@
|
||||
cmd_ld_multi = $(if $(strip $(obj-y)),\
|
||||
- $(LD) -r -o $@ $(filter $(obj-y),$^),rm -f $@; $(AR) rcs $@)
|
||||
-
|
||||
-quiet_cmd_host_ld_multi = HOSTLD $@
|
||||
- cmd_host_ld_multi = $(if $(strip $(obj-y)),\
|
||||
- $(HOSTLD) -r -o $@ $(filter $(obj-y),$^),rm -f $@; $(HOSTAR) rcs $@)
|
||||
-
|
||||
-ifneq ($(filter $(obj),$(hostprogs)),)
|
||||
- host = host_
|
||||
-endif
|
||||
+ $(LD) -r -o $@ $(filter $(obj-y),$^),rm -f $@; $(AR) rcs $@)
|
||||
|
||||
# Build rules
|
||||
$(OUTPUT)%.o: %.c FORCE
|
||||
$(call rule_mkdir)
|
||||
- $(call if_changed_dep,$(host)cc_o_c)
|
||||
+ $(call if_changed_dep,cc_o_c)
|
||||
|
||||
$(OUTPUT)%.o: %.S FORCE
|
||||
$(call rule_mkdir)
|
||||
- $(call if_changed_dep,$(host)cc_o_c)
|
||||
+ $(call if_changed_dep,cc_o_c)
|
||||
|
||||
$(OUTPUT)%.i: %.c FORCE
|
||||
$(call rule_mkdir)
|
||||
@@ -130,7 +119,7 @@ $(sort $(subdir-obj-y)): $(subdir-y) ;
|
||||
|
||||
$(in-target): $(obj-y) FORCE
|
||||
$(call rule_mkdir)
|
||||
- $(call if_changed,$(host)ld_multi)
|
||||
+ $(call if_changed,ld_multi)
|
||||
|
||||
__build: $(in-target)
|
||||
@:
|
||||
--
|
||||
2.7.4
|
||||
|
@ -42,7 +42,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -615,6 +615,10 @@ Patch849: 0001-iio-Use-event-header-from-kernel-tree.patch
|
||||
# Fix came in locally
|
||||
Patch851: 0001-drivers-net-phy-Correct-duplicate-MDIO_XGENE-entry.patch
|
||||
|
||||
# Maybe related to perf build failures?
|
||||
Patch852: 0001-Revert-tools-build-Support-compiling-C-source-file.patch
|
||||
Patch853: 0002-Revert-tools-build-Add-support-for-host-programs-for.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -2151,6 +2155,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Tue Oct 11 2016 Laura Abbott <labbott@redhat.com> - 4.9.0-0.rc0.git6.2
|
||||
- Revert possible commits causing perf build failures
|
||||
|
||||
* Tue Oct 11 2016 Laura Abbott <labbott@redhat.com> - 4.9.0-0.rc0.git6.1
|
||||
- Linux v4.8-11825-g101105b
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user