Linux v4.0-8158-g09d51602cf84
This commit is contained in:
parent
814e7c84f7
commit
ed8080d353
@ -33,10 +33,10 @@ index 82fbdbc1e0b0..a811210ad486 100644
|
|||||||
290/040 ALL edd_mbr_sig_buffer EDD MBR signatures
|
290/040 ALL edd_mbr_sig_buffer EDD MBR signatures
|
||||||
2D0/A00 ALL e820_map E820 memory map table
|
2D0/A00 ALL e820_map E820 memory map table
|
||||||
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
||||||
index d43e7e1c784b..3e9129a79646 100644
|
index 6049d587599e..cfd53b6b95f6 100644
|
||||||
--- a/arch/x86/Kconfig
|
--- a/arch/x86/Kconfig
|
||||||
+++ b/arch/x86/Kconfig
|
+++ b/arch/x86/Kconfig
|
||||||
@@ -1686,6 +1686,16 @@ config EFI_MIXED
|
@@ -1696,6 +1696,16 @@ config EFI_MIXED
|
||||||
|
|
||||||
If unsure, say N.
|
If unsure, say N.
|
||||||
|
|
||||||
|
@ -29,10 +29,10 @@ index 72665eb80692..2c7b80d31366 100644
|
|||||||
+
|
+
|
||||||
#endif /* _KEYS_SYSTEM_KEYRING_H */
|
#endif /* _KEYS_SYSTEM_KEYRING_H */
|
||||||
diff --git a/init/Kconfig b/init/Kconfig
|
diff --git a/init/Kconfig b/init/Kconfig
|
||||||
index 3b9df1aa35db..0eaa8278c87b 100644
|
index dc24dec60232..3b703d077513 100644
|
||||||
--- a/init/Kconfig
|
--- a/init/Kconfig
|
||||||
+++ b/init/Kconfig
|
+++ b/init/Kconfig
|
||||||
@@ -1764,6 +1764,15 @@ config SYSTEM_TRUSTED_KEYRING
|
@@ -1758,6 +1758,15 @@ config SYSTEM_TRUSTED_KEYRING
|
||||||
|
|
||||||
Keys in this keyring are used by module signature checking.
|
Keys in this keyring are used by module signature checking.
|
||||||
|
|
||||||
|
@ -42,10 +42,10 @@ index 3dd6f4a51b9b..9cc069579351 100644
|
|||||||
efi_guid_t guid;
|
efi_guid_t guid;
|
||||||
u64 table;
|
u64 table;
|
||||||
diff --git a/init/Kconfig b/init/Kconfig
|
diff --git a/init/Kconfig b/init/Kconfig
|
||||||
index 0eaa8278c87b..60ec329b1959 100644
|
index 3b703d077513..1c9c8e500a48 100644
|
||||||
--- a/init/Kconfig
|
--- a/init/Kconfig
|
||||||
+++ b/init/Kconfig
|
+++ b/init/Kconfig
|
||||||
@@ -1918,6 +1918,15 @@ config MODULE_SIG_ALL
|
@@ -1912,6 +1912,15 @@ config MODULE_SIG_ALL
|
||||||
comment "Do not forget to sign required modules with scripts/sign-file"
|
comment "Do not forget to sign required modules with scripts/sign-file"
|
||||||
depends on MODULE_SIG_FORCE && !MODULE_SIG_ALL
|
depends on MODULE_SIG_FORCE && !MODULE_SIG_ALL
|
||||||
|
|
||||||
|
@ -15,10 +15,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
|
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
|
||||||
index 11a76df2e1f1..43b733f98a7e 100644
|
index 274252f205b7..d7805f0fd528 100644
|
||||||
--- a/Documentation/kernel-parameters.txt
|
--- a/Documentation/kernel-parameters.txt
|
||||||
+++ b/Documentation/kernel-parameters.txt
|
+++ b/Documentation/kernel-parameters.txt
|
||||||
@@ -3844,7 +3844,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
|
@@ -3850,7 +3850,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
|
||||||
the allocated input device; If set to 0, video driver
|
the allocated input device; If set to 0, video driver
|
||||||
will only send out the event without touching backlight
|
will only send out the event without touching backlight
|
||||||
brightness level.
|
brightness level.
|
||||||
|
@ -365,6 +365,7 @@ CONFIG_BLK_DEV_OSD=m
|
|||||||
CONFIG_BLK_DEV_RAM=m
|
CONFIG_BLK_DEV_RAM=m
|
||||||
CONFIG_BLK_DEV_RAM_COUNT=16
|
CONFIG_BLK_DEV_RAM_COUNT=16
|
||||||
CONFIG_BLK_DEV_RAM_SIZE=16384
|
CONFIG_BLK_DEV_RAM_SIZE=16384
|
||||||
|
CONFIG_BLK_DEV_PMEM=m
|
||||||
CONFIG_BLK_DEV_INITRD=y
|
CONFIG_BLK_DEV_INITRD=y
|
||||||
CONFIG_BLK_DEV_IO_TRACE=y
|
CONFIG_BLK_DEV_IO_TRACE=y
|
||||||
|
|
||||||
@ -4167,6 +4168,7 @@ CONFIG_EXT4_FS=y
|
|||||||
CONFIG_EXT4_USE_FOR_EXT23=y
|
CONFIG_EXT4_USE_FOR_EXT23=y
|
||||||
CONFIG_EXT4_FS_POSIX_ACL=y
|
CONFIG_EXT4_FS_POSIX_ACL=y
|
||||||
CONFIG_EXT4_FS_SECURITY=y
|
CONFIG_EXT4_FS_SECURITY=y
|
||||||
|
# CONFIG_EXT4_FS_ENCRYPTION is not set
|
||||||
CONFIG_JBD2=y
|
CONFIG_JBD2=y
|
||||||
CONFIG_FS_MBCACHE=y
|
CONFIG_FS_MBCACHE=y
|
||||||
CONFIG_REISERFS_FS=m
|
CONFIG_REISERFS_FS=m
|
||||||
|
@ -353,6 +353,7 @@ CONFIG_HP_ILO=m
|
|||||||
|
|
||||||
CONFIG_BACKLIGHT_APPLE=m
|
CONFIG_BACKLIGHT_APPLE=m
|
||||||
|
|
||||||
|
CONFIG_X86_PMEM_LEGACY=y
|
||||||
|
|
||||||
CONFIG_X86_CHECK_BIOS_CORRUPTION=y
|
CONFIG_X86_CHECK_BIOS_CORRUPTION=y
|
||||||
|
|
||||||
|
@ -9,10 +9,10 @@ Upstream-status: Fedora mustard
|
|||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/init/Kconfig b/init/Kconfig
|
diff --git a/init/Kconfig b/init/Kconfig
|
||||||
index 60ec329b1959..6a3a2f63399b 100644
|
index 1c9c8e500a48..6d00970e220e 100644
|
||||||
--- a/init/Kconfig
|
--- a/init/Kconfig
|
||||||
+++ b/init/Kconfig
|
+++ b/init/Kconfig
|
||||||
@@ -1150,7 +1150,7 @@ config DEBUG_BLK_CGROUP
|
@@ -1144,7 +1144,7 @@ config DEBUG_BLK_CGROUP
|
||||||
endif # CGROUPS
|
endif # CGROUPS
|
||||||
|
|
||||||
config CHECKPOINT_RESTORE
|
config CHECKPOINT_RESTORE
|
||||||
@ -21,7 +21,7 @@ index 60ec329b1959..6a3a2f63399b 100644
|
|||||||
default n
|
default n
|
||||||
help
|
help
|
||||||
Enables additional kernel features in a sake of checkpoint/restore.
|
Enables additional kernel features in a sake of checkpoint/restore.
|
||||||
@@ -1161,7 +1161,7 @@ config CHECKPOINT_RESTORE
|
@@ -1155,7 +1155,7 @@ config CHECKPOINT_RESTORE
|
||||||
If unsure, say N here.
|
If unsure, say N here.
|
||||||
|
|
||||||
menuconfig NAMESPACES
|
menuconfig NAMESPACES
|
||||||
|
@ -11,10 +11,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
||||||
index 3e9129a79646..acdde2b3be4c 100644
|
index cfd53b6b95f6..3cd149818005 100644
|
||||||
--- a/arch/x86/Kconfig
|
--- a/arch/x86/Kconfig
|
||||||
+++ b/arch/x86/Kconfig
|
+++ b/arch/x86/Kconfig
|
||||||
@@ -1687,7 +1687,8 @@ config EFI_MIXED
|
@@ -1697,7 +1697,8 @@ config EFI_MIXED
|
||||||
If unsure, say N.
|
If unsure, say N.
|
||||||
|
|
||||||
config EFI_SECURE_BOOT_SIG_ENFORCE
|
config EFI_SECURE_BOOT_SIG_ENFORCE
|
||||||
|
@ -1,78 +0,0 @@
|
|||||||
From: Lukas Czerner <lczerner@redhat.com>
|
|
||||||
Date: Wed, 18 Feb 2015 17:49:28 +0100
|
|
||||||
Subject: [PATCH] ext4: Allocate entire range in zero range
|
|
||||||
|
|
||||||
Currently there is a bug in zero range code which causes zero range
|
|
||||||
calls to only allocate block aligned portion of the range, while
|
|
||||||
ignoring the rest in some cases.
|
|
||||||
|
|
||||||
In some cases, namely if the end of the range is past isize, we do
|
|
||||||
attempt to preallocate the last nonaligned block. However this might
|
|
||||||
cause kernel to BUG() in some carefully designed zero range requests on
|
|
||||||
setups where page size > block size.
|
|
||||||
|
|
||||||
Fix this problem by first preallocating the entire range, including the
|
|
||||||
nonaligned edges and converting the written extents to unwritten in the
|
|
||||||
next step. This approach will also give us the advantage of having the
|
|
||||||
range to be as linearly contiguous as possible.
|
|
||||||
|
|
||||||
Signed-off-by: Lukas Czerner <lczerner@redhat.com>
|
|
||||||
---
|
|
||||||
fs/ext4/extents.c | 31 +++++++++++++++++++------------
|
|
||||||
1 file changed, 19 insertions(+), 12 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/fs/ext4/extents.c b/fs/ext4/extents.c
|
|
||||||
index bed43081720f..aa522429b751 100644
|
|
||||||
--- a/fs/ext4/extents.c
|
|
||||||
+++ b/fs/ext4/extents.c
|
|
||||||
@@ -4803,12 +4803,6 @@ static long ext4_zero_range(struct file *file, loff_t offset,
|
|
||||||
else
|
|
||||||
max_blocks -= lblk;
|
|
||||||
|
|
||||||
- flags = EXT4_GET_BLOCKS_CREATE_UNWRIT_EXT |
|
|
||||||
- EXT4_GET_BLOCKS_CONVERT_UNWRITTEN |
|
|
||||||
- EXT4_EX_NOCACHE;
|
|
||||||
- if (mode & FALLOC_FL_KEEP_SIZE)
|
|
||||||
- flags |= EXT4_GET_BLOCKS_KEEP_SIZE;
|
|
||||||
-
|
|
||||||
mutex_lock(&inode->i_mutex);
|
|
||||||
|
|
||||||
/*
|
|
||||||
@@ -4825,15 +4819,28 @@ static long ext4_zero_range(struct file *file, loff_t offset,
|
|
||||||
ret = inode_newsize_ok(inode, new_size);
|
|
||||||
if (ret)
|
|
||||||
goto out_mutex;
|
|
||||||
- /*
|
|
||||||
- * If we have a partial block after EOF we have to allocate
|
|
||||||
- * the entire block.
|
|
||||||
- */
|
|
||||||
- if (partial_end)
|
|
||||||
- max_blocks += 1;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ flags = EXT4_GET_BLOCKS_CREATE_UNWRIT_EXT;
|
|
||||||
+ if (mode & FALLOC_FL_KEEP_SIZE)
|
|
||||||
+ flags |= EXT4_GET_BLOCKS_KEEP_SIZE;
|
|
||||||
+
|
|
||||||
+ /* Preallocate the range including the unaligned edges */
|
|
||||||
+ if (partial_begin || partial_end) {
|
|
||||||
+ ret = ext4_alloc_file_blocks(file,
|
|
||||||
+ round_down(offset, 1 << blkbits) >> blkbits,
|
|
||||||
+ (round_up((offset + len), 1 << blkbits) -
|
|
||||||
+ round_down(offset, 1 << blkbits)) >> blkbits,
|
|
||||||
+ new_size, flags, mode);
|
|
||||||
+ if (ret)
|
|
||||||
+ goto out_mutex;
|
|
||||||
+
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ /* Zero range excluding the unaligned edges */
|
|
||||||
if (max_blocks > 0) {
|
|
||||||
+ flags |= (EXT4_GET_BLOCKS_CONVERT_UNWRITTEN |
|
|
||||||
+ EXT4_EX_NOCACHE);
|
|
||||||
|
|
||||||
/* Now release the pages and zero block aligned part of pages*/
|
|
||||||
truncate_pagecache_range(inode, start, end - 1);
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
11
kernel.spec
11
kernel.spec
@ -67,7 +67,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 8
|
%define gitrev 9
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -605,9 +605,6 @@ Patch22000: weird-root-dentry-name-debug.patch
|
|||||||
#rhbz 1094948
|
#rhbz 1094948
|
||||||
Patch26131: acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
Patch26131: acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
||||||
|
|
||||||
#CVE-2015-0275 rhbz 1193907 1195178
|
|
||||||
Patch26138: ext4-Allocate-entire-range-in-zero-range.patch
|
|
||||||
|
|
||||||
#CVE-2015-2150 rhbz 1196266 1200397
|
#CVE-2015-2150 rhbz 1196266 1200397
|
||||||
Patch26175: xen-pciback-Don-t-disable-PCI_COMMAND-on-PCI-device-.patch
|
Patch26175: xen-pciback-Don-t-disable-PCI_COMMAND-on-PCI-device-.patch
|
||||||
|
|
||||||
@ -1337,9 +1334,6 @@ ApplyPatch ath9k-rx-dma-stop-check.patch
|
|||||||
#rhbz 1094948
|
#rhbz 1094948
|
||||||
ApplyPatch acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
ApplyPatch acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
||||||
|
|
||||||
#CVE-2015-0275 rhbz 1193907 1195178
|
|
||||||
ApplyPatch ext4-Allocate-entire-range-in-zero-range.patch
|
|
||||||
|
|
||||||
#CVE-2015-2150 rhbz 1196266 1200397
|
#CVE-2015-2150 rhbz 1196266 1200397
|
||||||
ApplyPatch xen-pciback-Don-t-disable-PCI_COMMAND-on-PCI-device-.patch
|
ApplyPatch xen-pciback-Don-t-disable-PCI_COMMAND-on-PCI-device-.patch
|
||||||
|
|
||||||
@ -2199,6 +2193,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 20 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc0.git9.1
|
||||||
|
- Linux v4.0-8158-g09d51602cf84
|
||||||
|
|
||||||
* Sat Apr 18 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc0.git8.1
|
* Sat Apr 18 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc0.git8.1
|
||||||
- Linux v4.0-7945-g7505256626b0
|
- Linux v4.0-7945-g7505256626b0
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
|
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
|
||||||
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
|
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
|
||||||
6ccf04f87802cec28452b62687fb3b2b patch-4.0-git8.xz
|
65de65a37cdcaf4d21aaec6383b8bfcd patch-4.0-git9.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user