Revert EuroLinux modifications
This commit is contained in:
parent
f9b607962c
commit
ecd26ad835
@ -1,12 +0,0 @@
|
||||
--- a/arch/x86/boot/main.c 2019-03-13 04:04:53.000000000 -0700
|
||||
+++ b/arch/x86/boot/main.c 2019-05-25 14:31:21.043272496 -0700
|
||||
@@ -147,7 +147,7 @@ void main(void)
|
||||
|
||||
/* Make sure we have all the proper CPU support */
|
||||
if (validate_cpu()) {
|
||||
- puts("This processor is not supported in this version of RHEL.\n");
|
||||
+ puts("This processor is not supported in this version of EuroLinux.\n");
|
||||
die();
|
||||
}
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/arch/x86/kernel/setup.c 2019-03-13 04:04:53.000000000 -0700
|
||||
+++ b/arch/x86/kernel/setup.c 2019-05-27 08:35:54.580595314 -0700
|
||||
@@ -900,7 +900,7 @@ static void rh_check_supported(void)
|
||||
if (((boot_cpu_data.x86_max_cores * smp_num_siblings) == 1) &&
|
||||
!guest && is_kdump_kernel()) {
|
||||
pr_crit("Detected single cpu native boot.\n");
|
||||
- pr_crit("Important: In Red Hat Enterprise Linux 8, single threaded, single CPU 64-bit physical systems are unsupported by Red Hat. Please contact your Red Hat support representative for a list of certified and supported systems.");
|
||||
+ pr_crit("Important: In EuroLinux 8, single threaded, single CPU 64-bit physical systems are unsupported.");
|
||||
}
|
||||
|
||||
/*
|
@ -1,12 +0,0 @@
|
||||
diff -urN linux-4.18.0-477.27.1.el8_8/init/main.c linux-4.18.0-477.27.1.el8_8p/init/main.c
|
||||
--- linux-4.18.0-477.27.1.el8_8/init/main.c 2023-08-31 16:01:50.000000000 +0200
|
||||
+++ linux-4.18.0-477.27.1.el8_8p/init/main.c 2023-09-20 14:02:16.439638219 +0200
|
||||
@@ -576,7 +576,7 @@
|
||||
page_alloc_init();
|
||||
|
||||
pr_notice("Kernel command line: %s\n", boot_command_line);
|
||||
- pr_notice("Specific versions of hardware are certified with Red Hat Enterprise Linux 8. Please see the list of hardware certified with Red Hat Enterprise Linux 8 at https://catalog.redhat.com.\n");
|
||||
+ pr_notice("Specific versions of hardware are certified with EuroLinux 8. Since EuroLinux is binary compatible with RHEL, please see the list of certified hardware at https://catalog.redhat.com.\n");
|
||||
/* parameters may set static keys */
|
||||
jump_label_init();
|
||||
parse_early_param();
|
@ -323,19 +323,6 @@
|
||||
%define kernel_prereq coreutils, systemd >= 203-2, /usr/bin/kernel-install
|
||||
%define initrd_prereq dracut >= 027
|
||||
|
||||
# EuroLinux override
|
||||
# Normaly this should be done in rpmmacros, but because the packages must be rebuildable with beast
|
||||
# we have to change this here
|
||||
|
||||
%define with_doc 1
|
||||
%define with_kabichk 1
|
||||
%define with_kernel_abi_whitelists 1
|
||||
%global signkernel 0
|
||||
%global signmodules 0
|
||||
|
||||
# End of EuroLinux override
|
||||
|
||||
|
||||
|
||||
Name: kernel%{?variant}
|
||||
Group: System Environment/Kernel
|
||||
@ -557,17 +544,14 @@ Source4001: rpminspect.yaml
|
||||
|
||||
# empty final patch to facilitate testing of kernel patches
|
||||
Patch999999: linux-kernel-test.patch
|
||||
Patch1000: debrand-rh-i686-cpu.patch
|
||||
Patch1002: debrand-single-cpu.patch
|
||||
Patch1003: debrand-specific-versions-of-hardware.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{KVERREL}-root
|
||||
|
||||
%description
|
||||
This is the package which provides the Linux %{name} for EuroLinux.
|
||||
It is based on upstream Linux at version %{version} and maintains kABI
|
||||
This is the package which provides the Linux %{name} for Red Hat Enterprise
|
||||
Linux. It is based on upstream Linux at version %{version} and maintains kABI
|
||||
compatibility of a set of approved symbols, however it is heavily modified with
|
||||
backports and fixes pulled from newer upstream Linux %{name} releases. This means
|
||||
this is not a %{version} kernel anymore: it includes several components which come
|
||||
@ -575,7 +559,7 @@ from newer upstream linux versions, while maintaining a well tested and stable
|
||||
core. Some of the components/backports that may be pulled in are: changes like
|
||||
updates to the core kernel (eg.: scheduler, cgroups, memory management, security
|
||||
fixes and features), updates to block layer, supported filesystems, major driver
|
||||
updates for supported hardware in EuroLinux, enhancements for
|
||||
updates for supported hardware in Red Hat Enterprise Linux, enhancements for
|
||||
enterprise customers, etc.
|
||||
|
||||
#
|
||||
@ -823,14 +807,14 @@ kernel-gcov includes the gcov graph and source files for gcov coverage collectio
|
||||
%endif
|
||||
|
||||
%package -n %{name}-abi-stablelists
|
||||
Summary: The EuroLinux kernel ABI symbol stablelists
|
||||
Summary: The Red Hat Enterprise Linux kernel ABI symbol stablelists
|
||||
Group: System Environment/Kernel
|
||||
AutoReqProv: no
|
||||
Obsoletes: %{name}-abi-whitelists < %{rpmversion}-%{pkg_release}
|
||||
Provides: %{name}-abi-whitelists
|
||||
%description -n %{name}-abi-stablelists
|
||||
The kABI package contains information pertaining to the EuroLinux
|
||||
kernel ABI, including lists of kernel symbols that are needed by
|
||||
The kABI package contains information pertaining to the Red Hat Enterprise
|
||||
Linux kernel ABI, including lists of kernel symbols that are needed by
|
||||
external Linux kernel modules, and a yum plugin to aid enforcement.
|
||||
|
||||
%if %{with_kabidw_base}
|
||||
@ -839,8 +823,8 @@ Summary: The baseline dataset for kABI verification using DWARF data
|
||||
Group: System Environment/Kernel
|
||||
AutoReqProv: no
|
||||
%description kernel-kabidw-base-internal
|
||||
The package contains data describing the current ABI of the EuroLinux
|
||||
kernel, suitable for the kabi-dw tool.
|
||||
The package contains data describing the current ABI of the Red Hat Enterprise
|
||||
Linux kernel, suitable for the kabi-dw tool.
|
||||
%endif
|
||||
|
||||
#
|
||||
@ -1084,9 +1068,9 @@ ApplyPatch()
|
||||
exit 1
|
||||
fi
|
||||
if ! grep -E "^Patch[0-9]+: $patch\$" %{_specdir}/${RPM_PACKAGE_NAME%%%%%{?variant}}.spec ; then
|
||||
if [ "${patch:0:9}" != "patch-4." ] ; then
|
||||
if [ "${patch:0:8}" != "patch-4." ] ; then
|
||||
echo "ERROR: Patch $patch not listed as a source patch in specfile"
|
||||
#exit 1
|
||||
exit 1
|
||||
fi
|
||||
fi 2>/dev/null
|
||||
case "$patch" in
|
||||
@ -1116,9 +1100,6 @@ mv linux-%{rpmversion}-%{pkgrelease} linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
|
||||
ApplyOptionalPatch debrand-single-cpu.patch
|
||||
#ApplyOptionalPatch debrand-rh_taint.patch
|
||||
ApplyOptionalPatch debrand-rh-i686-cpu.patch
|
||||
ApplyOptionalPatch linux-kernel-test.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
@ -1771,18 +1752,18 @@ BuildKernel() {
|
||||
|
||||
# Red Hat UEFI Secure Boot CA cert, which can be used to authenticate the kernel
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer
|
||||
# install -m 0644 %{secureboot_ca_0} $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/kernel-signing-ca.cer
|
||||
# %ifarch s390x ppc64le
|
||||
# if [ $DoModules -eq 1 ]; then
|
||||
# if [ -x /usr/bin/rpm-sign ]; then
|
||||
# install -m 0644 %{secureboot_key_0} $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/%{signing_key_filename}
|
||||
# else
|
||||
# install -m 0644 certs/signing_key.x509.sign${Flav} $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/kernel-signing-ca.cer
|
||||
# openssl x509 -in certs/signing_key.pem.sign${Flav} -outform der -out $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/%{signing_key_filename}
|
||||
# chmod 0644 $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/%{signing_key_filename}
|
||||
# fi
|
||||
# fi
|
||||
# %endif
|
||||
install -m 0644 %{secureboot_ca_0} $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/kernel-signing-ca.cer
|
||||
%ifarch s390x ppc64le
|
||||
if [ $DoModules -eq 1 ]; then
|
||||
if [ -x /usr/bin/rpm-sign ]; then
|
||||
install -m 0644 %{secureboot_key_0} $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/%{signing_key_filename}
|
||||
else
|
||||
install -m 0644 certs/signing_key.x509.sign${Flav} $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/kernel-signing-ca.cer
|
||||
openssl x509 -in certs/signing_key.pem.sign${Flav} -outform der -out $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/%{signing_key_filename}
|
||||
chmod 0644 $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/%{signing_key_filename}
|
||||
fi
|
||||
fi
|
||||
%endif
|
||||
|
||||
%if %{with_ipaclones}
|
||||
MAXPROCS=$(echo %{?_smp_mflags} | sed -n 's/-j\s*\([0-9]\+\)/\1/p')
|
||||
@ -2715,14 +2696,6 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Thu Nov 30 2023 EuroLinux Autopatch <devel@euro-linux.com>
|
||||
- Added Patch: debrand-rh-i686-cpu.patch
|
||||
--> i686 info debrand
|
||||
- Added Patch: debrand-single-cpu.patch
|
||||
--> Single cpu debrand
|
||||
- Added Patch: debrand-specific-versions-of-hardware.patch
|
||||
--> Specific versions of hardware debrand
|
||||
|
||||
* Thu Nov 16 2023 Patrick Talbert <ptalbert@redhat.com> [4.18.0-513.9.1.el8_9]
|
||||
- ice: reset first in crash dump kernels (Petr Oros) [2244625 2139761]
|
||||
- nvmet-tcp: Fix a possible UAF in queue intialization setup (John Meneghini) [RHEL-11507 RHEL-11509] {CVE-2023-5178}
|
||||
|
Loading…
Reference in New Issue
Block a user