Linunx v3.5-4773-gbdc0077
This commit is contained in:
parent
306dfccc03
commit
ebdfef5fb4
@ -1,43 +0,0 @@
|
|||||||
From 81a06eed2491273b7d6d274ae4be1d333c100ab0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mark Langsdorf <mark.langsdorf@calxeda.com>
|
|
||||||
Date: Mon, 12 Mar 2012 06:28:19 -0400
|
|
||||||
Subject: [PATCH] highbank: export clock functions
|
|
||||||
|
|
||||||
Signed-off-by: Mark Langsdorf <mark.langsdorf@calxeda.com>
|
|
||||||
---
|
|
||||||
arch/arm/mach-highbank/clock.c | 4 ++++
|
|
||||||
1 files changed, 4 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git diff -up linux-3.2-rc4.orig/arch/arm/mach-highbank/clock.c diff -up linux-3.2-rc4/arch/arm/mach-highbank/clock.c
|
|
||||||
index c25a2ae..cdbc575 100644
|
|
||||||
--- a/arch/arm/mach-highbank/clock.c
|
|
||||||
+++ b/arch/arm/mach-highbank/clock.c
|
|
||||||
@@ -27,14 +27,17 @@ int clk_enable(struct clk *clk)
|
|
||||||
{
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
+EXPORT_SYMBOL_GPL(clk_enable);
|
|
||||||
|
|
||||||
void clk_disable(struct clk *clk)
|
|
||||||
{}
|
|
||||||
+EXPORT_SYMBOL_GPL(clk_disable);
|
|
||||||
|
|
||||||
unsigned long clk_get_rate(struct clk *clk)
|
|
||||||
{
|
|
||||||
return clk->rate;
|
|
||||||
}
|
|
||||||
+EXPORT_SYMBOL_GPL(clk_get_rate);
|
|
||||||
|
|
||||||
long clk_round_rate(struct clk *clk, unsigned long rate)
|
|
||||||
{
|
|
||||||
@@ -45,6 +48,7 @@ int clk_set_rate(struct clk *clk, unsigned long rate)
|
|
||||||
{
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
+EXPORT_SYMBOL_GPL(clk_set_rate);
|
|
||||||
|
|
||||||
static struct clk eclk = { .rate = 200000000 };
|
|
||||||
static struct clk pclk = { .rate = 150000000 };
|
|
||||||
--
|
|
||||||
1.7.9.1
|
|
||||||
|
|
16
kernel.spec
16
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 2
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -715,8 +715,6 @@ Patch14000: hibernate-freeze-filesystems.patch
|
|||||||
|
|
||||||
Patch14010: lis3-improve-handling-of-null-rate.patch
|
Patch14010: lis3-improve-handling-of-null-rate.patch
|
||||||
|
|
||||||
Patch14015: team-update-from-net-next.patch
|
|
||||||
|
|
||||||
|
|
||||||
# ARM
|
# ARM
|
||||||
# OMAP
|
# OMAP
|
||||||
@ -727,8 +725,6 @@ Patch21005: arm-tegra-usb-no-reset-linux33.patch
|
|||||||
Patch21006: arm-tegra-sdhci-module-fix.patch
|
Patch21006: arm-tegra-sdhci-module-fix.patch
|
||||||
|
|
||||||
# ARM highbank patches
|
# ARM highbank patches
|
||||||
# Highbank clock functions need to be EXPORT for module builds
|
|
||||||
Patch21010: highbank-export-clock-functions.patch
|
|
||||||
|
|
||||||
Patch21094: power-x86-destdir.patch
|
Patch21094: power-x86-destdir.patch
|
||||||
|
|
||||||
@ -1420,8 +1416,6 @@ ApplyPatch efi-dont-map-boot-services-on-32bit.patch
|
|||||||
|
|
||||||
ApplyPatch lis3-improve-handling-of-null-rate.patch
|
ApplyPatch lis3-improve-handling-of-null-rate.patch
|
||||||
|
|
||||||
ApplyPatch team-update-from-net-next.patch
|
|
||||||
|
|
||||||
ApplyPatch power-x86-destdir.patch
|
ApplyPatch power-x86-destdir.patch
|
||||||
|
|
||||||
#rhbz 754518
|
#rhbz 754518
|
||||||
@ -1434,9 +1428,6 @@ ApplyPatch weird-root-dentry-name-debug.patch
|
|||||||
#selinux ptrace child permissions
|
#selinux ptrace child permissions
|
||||||
ApplyPatch selinux-apply-different-permission-to-ptrace-child.patch
|
ApplyPatch selinux-apply-different-permission-to-ptrace-child.patch
|
||||||
|
|
||||||
#Highbank clock functions
|
|
||||||
ApplyPatch highbank-export-clock-functions.patch
|
|
||||||
|
|
||||||
#Fix FIPS for aesni hardare
|
#Fix FIPS for aesni hardare
|
||||||
ApplyPatch crypto-testmgr-allow-aesni-intel-and-ghash_clmulni-intel.patch
|
ApplyPatch crypto-testmgr-allow-aesni-intel-and-ghash_clmulni-intel.patch
|
||||||
ApplyPatch crypto-aesni-intel-fix-wrong-kfree-pointer.patch
|
ApplyPatch crypto-aesni-intel-fix-wrong-kfree-pointer.patch
|
||||||
@ -2301,6 +2292,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 25 2012 Justin M. Forbes <jforbes@redhat.com> - 3.6.0-0.rc0.git2.1
|
||||||
|
- Linux v3.5-4773-gbdc0077
|
||||||
|
|
||||||
* Tue Jul 24 2012 Josh Boyer <jwboyer@redhat.com>
|
* Tue Jul 24 2012 Josh Boyer <jwboyer@redhat.com>
|
||||||
- Update modsign patch to latest upstream
|
- Update modsign patch to latest upstream
|
||||||
- Add initial UEFI Secure Boot patchset. Work in progress.
|
- Add initial UEFI Secure Boot patchset. Work in progress.
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
24153eaaa81dedc9481ada8cd9c3b83d linux-3.5.tar.xz
|
24153eaaa81dedc9481ada8cd9c3b83d linux-3.5.tar.xz
|
||||||
095f6e8dbf38a89d9b2de458f8f91ae8 patch-3.5-git1.xz
|
4dd697d2fcc6a4bf6fea466c56c88571 patch-3.5-git2.xz
|
||||||
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user