Linux 2.6.36.1
This commit is contained in:
parent
ae441b0e31
commit
ebb38001c4
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ patch-*.bz2
|
|||||||
clog
|
clog
|
||||||
*.rpm
|
*.rpm
|
||||||
kernel-2.6.*/
|
kernel-2.6.*/
|
||||||
|
/patch-2.6.36.1.bz2
|
||||||
|
15
kernel.spec
15
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||||
# for example a 3 here will become 0.3
|
# for example a 3 here will become 0.3
|
||||||
#
|
#
|
||||||
%global baserelease 8
|
%global baserelease 9
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -65,7 +65,7 @@ Summary: The Linux kernel
|
|||||||
# Do we have a -stable update to apply?
|
# Do we have a -stable update to apply?
|
||||||
%define stable_update 1
|
%define stable_update 1
|
||||||
# Is it a -stable RC?
|
# Is it a -stable RC?
|
||||||
%define stable_rc 1
|
%define stable_rc 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%if 0%{?stable_update}
|
%if 0%{?stable_update}
|
||||||
%define stablerev .%{stable_update}
|
%define stablerev .%{stable_update}
|
||||||
@ -82,9 +82,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 8
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 5
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -724,8 +724,6 @@ Patch12303: dmar-disable-when-ricoh-multifunction.patch
|
|||||||
|
|
||||||
Patch12305: xhci_hcd-suspend-resume.patch
|
Patch12305: xhci_hcd-suspend-resume.patch
|
||||||
|
|
||||||
Patch12306: secmark-do-not-return-early-if-there-was-no-error.patch
|
|
||||||
|
|
||||||
Patch12307: tty-restore-tty_ldisc_wait_idle.patch
|
Patch12307: tty-restore-tty_ldisc_wait_idle.patch
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1346,8 +1344,6 @@ ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
|||||||
|
|
||||||
ApplyPatch xhci_hcd-suspend-resume.patch
|
ApplyPatch xhci_hcd-suspend-resume.patch
|
||||||
|
|
||||||
#ApplyPatch secmark-do-not-return-early-if-there-was-no-error.patch
|
|
||||||
|
|
||||||
ApplyPatch tty-restore-tty_ldisc_wait_idle.patch
|
ApplyPatch tty-restore-tty_ldisc_wait_idle.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
@ -1963,6 +1959,9 @@ fi
|
|||||||
# || ||
|
# || ||
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 22 2010 Kyle McMartin <kyle@redhat.com> 2.6.36.1-9
|
||||||
|
- Linux stable 2.6.36.1
|
||||||
|
|
||||||
* Mon Nov 22 2010 Kyle McMartin <kyle@redhat.com> 2.6.36.1-8.rc1
|
* Mon Nov 22 2010 Kyle McMartin <kyle@redhat.com> 2.6.36.1-8.rc1
|
||||||
- Merge 100eeae2 (TTY: restore tty_ldisc_wait_idle) which should fix the WARN
|
- Merge 100eeae2 (TTY: restore tty_ldisc_wait_idle) which should fix the WARN
|
||||||
in tty_open in rawhide.
|
in tty_open in rawhide.
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 15714f7b58011cf3948cab2988abea560240c74f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Eric Paris <eparis@redhat.com>
|
|
||||||
Date: Tue, 12 Oct 2010 11:40:08 -0400
|
|
||||||
Subject: [PATCH] secmark: do not return early if there was no error
|
|
||||||
|
|
||||||
Commit 4a5a5c73 attempted to pass decent error messages back to userspace for
|
|
||||||
netfilter errors. In xt_SECMARK.c however the patch screwed up and returned
|
|
||||||
on 0 (aka no error) early and didn't finish setting up secmark. This results
|
|
||||||
in a kernel BUG if you use SECMARK.
|
|
||||||
|
|
||||||
Signed-off-by: Eric Paris <eparis@redhat.com>
|
|
||||||
Acked-by: Paul Moore <paul.moore@hp.com>
|
|
||||||
Signed-off-by: James Morris <jmorris@namei.org>
|
|
||||||
---
|
|
||||||
net/netfilter/xt_SECMARK.c | 2 +-
|
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/net/netfilter/xt_SECMARK.c b/net/netfilter/xt_SECMARK.c
|
|
||||||
index 23b2d6c..364ad16 100644
|
|
||||||
--- a/net/netfilter/xt_SECMARK.c
|
|
||||||
+++ b/net/netfilter/xt_SECMARK.c
|
|
||||||
@@ -101,7 +101,7 @@ static int secmark_tg_check(const struct xt_tgchk_param *par)
|
|
||||||
switch (info->mode) {
|
|
||||||
case SECMARK_MODE_SEL:
|
|
||||||
err = checkentry_selinux(info);
|
|
||||||
- if (err <= 0)
|
|
||||||
+ if (err)
|
|
||||||
return err;
|
|
||||||
break;
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.3.2
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user