Linux v4.18-rc5
This commit is contained in:
parent
d49e6674ca
commit
ea971d099e
@ -1,54 +0,0 @@
|
|||||||
From 4cf95d8ea33f6b4704229e64f8a215bc44bf2403 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Laura Abbott <labbott@redhat.com>
|
|
||||||
Date: Mon, 9 Jul 2018 12:55:30 -0700
|
|
||||||
Subject: [PATCH] Revert "arm64: Use aarch64elf and aarch64elfb emulation mode
|
|
||||||
variants"
|
|
||||||
To: Will Deacon <will.deacon@arm.com>
|
|
||||||
To: Paul Kocialkowski <contact@paulk.fr>
|
|
||||||
To: Catalin Marinas <catalin.marinas@arm.com>
|
|
||||||
Cc: linux-arm-kernel@lists.infradead.org
|
|
||||||
Cc: linux-kernel@vger.kernel.org
|
|
||||||
|
|
||||||
This reverts commit 38fc4248677552ce35efc09902fdcb06b61d7ef9.
|
|
||||||
|
|
||||||
This breaks compilation with Fedora gcc-8 tool chains:
|
|
||||||
|
|
||||||
CHK include/generated/compile.h
|
|
||||||
LD [M] arch/arm64/crypto/sha512-ce.o
|
|
||||||
aarch64-linux-gnu-ld: cannot open linker script file ldscripts/aarch64elf.xr: No such file or directory
|
|
||||||
make[1]: *** [scripts/Makefile.build:530: arch/arm64/crypto/sha512-ce.o] Error 1
|
|
||||||
make: *** [Makefile:1029: arch/arm64/crypto] Error 2
|
|
||||||
|
|
||||||
Fixes: 38fc42486775 ("arm64: Use aarch64elf and aarch64elfb emulation mode variants")
|
|
||||||
Signed-off-by: Laura Abbott <labbott@redhat.com>
|
|
||||||
---
|
|
||||||
A bit rushed and I'm still debugging but I wanted to send this out
|
|
||||||
before anyone else gets hit since it is -rc4. Seeing this on both native
|
|
||||||
and cross compiles.
|
|
||||||
---
|
|
||||||
arch/arm64/Makefile | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/arch/arm64/Makefile b/arch/arm64/Makefile
|
|
||||||
index 7976d2d242fa..f476d52ad8d6 100644
|
|
||||||
--- a/arch/arm64/Makefile
|
|
||||||
+++ b/arch/arm64/Makefile
|
|
||||||
@@ -60,13 +60,13 @@ ifeq ($(CONFIG_CPU_BIG_ENDIAN), y)
|
|
||||||
KBUILD_CPPFLAGS += -mbig-endian
|
|
||||||
CHECKFLAGS += -D__AARCH64EB__
|
|
||||||
AS += -EB
|
|
||||||
-LDFLAGS += -EB -maarch64elfb
|
|
||||||
+LDFLAGS += -EB -maarch64linuxb
|
|
||||||
UTS_MACHINE := aarch64_be
|
|
||||||
else
|
|
||||||
KBUILD_CPPFLAGS += -mlittle-endian
|
|
||||||
CHECKFLAGS += -D__AARCH64EL__
|
|
||||||
AS += -EL
|
|
||||||
-LDFLAGS += -EL -maarch64elf
|
|
||||||
+LDFLAGS += -EL -maarch64linux
|
|
||||||
UTS_MACHINE := aarch64
|
|
||||||
endif
|
|
||||||
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
@ -1,50 +0,0 @@
|
|||||||
From b8c8dc142ff2f7f46060ed77b2de05c813233029 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Laura Abbott <labbott@redhat.com>
|
|
||||||
Date: Fri, 6 Jul 2018 17:11:31 -0700
|
|
||||||
Subject: [PATCHv2 1/7] tools: build: Fixup host c flags
|
|
||||||
To: Masahiro Yamada <yamada.masahiro@socionext.com>
|
|
||||||
To: Josh Poimboeuf <jpoimboe@redhat.com>
|
|
||||||
To: Jiri Olsa <jolsa@kernel.org>
|
|
||||||
Cc: linux-kbuild@vger.kernel.org
|
|
||||||
Cc: linux-kernel@vger.kernel.org
|
|
||||||
Cc: Robin Jarry <robin.jarry@6wind.com>
|
|
||||||
|
|
||||||
Commit 0c3b7e42616f ("tools build: Add support for host programs format")
|
|
||||||
introduced host_c_flags which referenced CHOSTFLAGS. The actual name of the
|
|
||||||
variable is HOSTCFLAGS. Fix this up.
|
|
||||||
|
|
||||||
Fixes: 0c3b7e42616f ("tools build: Add support for host programs format")
|
|
||||||
Signed-off-by: Laura Abbott <labbott@redhat.com>
|
|
||||||
---
|
|
||||||
v2: Also fixed another instance in perf pmu-events.
|
|
||||||
---
|
|
||||||
tools/build/Build.include | 2 +-
|
|
||||||
tools/perf/pmu-events/Build | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tools/build/Build.include b/tools/build/Build.include
|
|
||||||
index a4bbb984941d..b5c679cd441c 100644
|
|
||||||
--- a/tools/build/Build.include
|
|
||||||
+++ b/tools/build/Build.include
|
|
||||||
@@ -98,4 +98,4 @@ cxx_flags = -Wp,-MD,$(depfile) -Wp,-MT,$@ $(CXXFLAGS) -D"BUILD_STR(s)=\#s" $(CXX
|
|
||||||
###
|
|
||||||
## HOSTCC C flags
|
|
||||||
|
|
||||||
-host_c_flags = -Wp,-MD,$(depfile) -Wp,-MT,$@ $(CHOSTFLAGS) -D"BUILD_STR(s)=\#s" $(CHOSTFLAGS_$(basetarget).o) $(CHOSTFLAGS_$(obj))
|
|
||||||
+host_c_flags = -Wp,-MD,$(depfile) -Wp,-MT,$@ $(HOSTCFLAGS) -D"BUILD_STR(s)=\#s" $(HOSTCFLAGS_$(basetarget).o) $(HOSTCFLAGS_$(obj))
|
|
||||||
diff --git a/tools/perf/pmu-events/Build b/tools/perf/pmu-events/Build
|
|
||||||
index 17783913d330..215ba30b8534 100644
|
|
||||||
--- a/tools/perf/pmu-events/Build
|
|
||||||
+++ b/tools/perf/pmu-events/Build
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
hostprogs := jevents
|
|
||||||
|
|
||||||
jevents-y += json.o jsmn.o jevents.o
|
|
||||||
-CHOSTFLAGS_jevents.o = -I$(srctree)/tools/include
|
|
||||||
+HOSTCFLAGS_jevents.o = -I$(srctree)/tools/include
|
|
||||||
pmu-events-y += pmu-events.o
|
|
||||||
JDIR = pmu-events/arch/$(SRCARCH)
|
|
||||||
JSON = $(shell [ -d $(JDIR) ] && \
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
@ -1,38 +0,0 @@
|
|||||||
From b89f16785c9b5176c0af9b15eee74048daf95357 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Laura Abbott <labbott@redhat.com>
|
|
||||||
Date: Fri, 6 Jul 2018 17:42:05 -0700
|
|
||||||
Subject: [PATCHv2 2/7] tools: build: Use HOSTLDFLAGS with fixdep
|
|
||||||
To: Masahiro Yamada <yamada.masahiro@socionext.com>
|
|
||||||
To: Josh Poimboeuf <jpoimboe@redhat.com>
|
|
||||||
To: Jiri Olsa <jolsa@kernel.org>
|
|
||||||
Cc: linux-kbuild@vger.kernel.org
|
|
||||||
Cc: linux-kernel@vger.kernel.org
|
|
||||||
Cc: Robin Jarry <robin.jarry@6wind.com>
|
|
||||||
|
|
||||||
The final link of fixdep uses LDFLAGS but not the existing HOSTLDFLAGS.
|
|
||||||
Fix this.
|
|
||||||
|
|
||||||
Signed-off-by: Laura Abbott <labbott@redhat.com>
|
|
||||||
---
|
|
||||||
v2: Switch to just using HOSTLDFLAGS instead of both LDFLAGS and
|
|
||||||
HOSTLDFLAGS.
|
|
||||||
---
|
|
||||||
tools/build/Makefile | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/tools/build/Makefile b/tools/build/Makefile
|
|
||||||
index 5eb4b5ad79cb..5edf65e684ab 100644
|
|
||||||
--- a/tools/build/Makefile
|
|
||||||
+++ b/tools/build/Makefile
|
|
||||||
@@ -43,7 +43,7 @@ $(OUTPUT)fixdep-in.o: FORCE
|
|
||||||
$(Q)$(MAKE) $(build)=fixdep
|
|
||||||
|
|
||||||
$(OUTPUT)fixdep: $(OUTPUT)fixdep-in.o
|
|
||||||
- $(QUIET_LINK)$(HOSTCC) $(LDFLAGS) -o $@ $<
|
|
||||||
+ $(QUIET_LINK)$(HOSTCC) $(HOSTLDFLAGS) -o $@ $<
|
|
||||||
|
|
||||||
FORCE:
|
|
||||||
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
12
kernel.spec
12
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%global rcrev 4
|
%global rcrev 5
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 4
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -607,17 +607,12 @@ Patch502: input-rmi4-remove-the-need-for-artifical-IRQ.patch
|
|||||||
# rhbz 1470995
|
# rhbz 1470995
|
||||||
Patch504: kexec-bzimage-verify-pe-signature-fix.patch
|
Patch504: kexec-bzimage-verify-pe-signature-fix.patch
|
||||||
|
|
||||||
# arm64 compile fix
|
|
||||||
Patch505: 0001-Revert-arm64-Use-aarch64elf-and-aarch64elfb-emulatio.patch
|
|
||||||
|
|
||||||
# Support for unique build ids
|
# Support for unique build ids
|
||||||
# All queued in the kbuild tree
|
# All queued in the kbuild tree
|
||||||
Patch506: 0001-kbuild-Add-build-salt-to-the-kernel-and-modules.patch
|
Patch506: 0001-kbuild-Add-build-salt-to-the-kernel-and-modules.patch
|
||||||
Patch507: 0002-x86-Add-build-salt-to-the-vDSO.patch
|
Patch507: 0002-x86-Add-build-salt-to-the-vDSO.patch
|
||||||
Patch508: 0003-powerpc-Add-build-salt-to-the-vDSO.patch
|
Patch508: 0003-powerpc-Add-build-salt-to-the-vDSO.patch
|
||||||
Patch509: 0004-arm64-Add-build-salt-to-the-vDSO.patch
|
Patch509: 0004-arm64-Add-build-salt-to-the-vDSO.patch
|
||||||
Patch510: 0001-tools-build-Fixup-host-c-flags.patch
|
|
||||||
Patch511: 0002-tools-build-Use-HOSTLDFLAGS-with-fixdep.patch
|
|
||||||
Patch512: 0003-treewide-Rename-HOSTCFLAGS-KBUILD_HOSTCFLAGS.patch
|
Patch512: 0003-treewide-Rename-HOSTCFLAGS-KBUILD_HOSTCFLAGS.patch
|
||||||
Patch513: 0004-treewide-Rename-HOSTCXXFLAGS-to-KBUILD_HOSTCXXFLAGS.patch
|
Patch513: 0004-treewide-Rename-HOSTCXXFLAGS-to-KBUILD_HOSTCXXFLAGS.patch
|
||||||
Patch514: 0005-treewide-Rename-HOSTLDFLAGS-to-KBUILD_HOSTLDFLAGS.patch
|
Patch514: 0005-treewide-Rename-HOSTLDFLAGS-to-KBUILD_HOSTLDFLAGS.patch
|
||||||
@ -1878,6 +1873,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 16 2018 Laura Abbott <labbott@redhat.com> - 4.18.0-0.rc5.git0.1
|
||||||
|
- Linux v4.18-rc5
|
||||||
|
|
||||||
* Mon Jul 16 2018 Laura Abbott <labbott@redhat.com>
|
* Mon Jul 16 2018 Laura Abbott <labbott@redhat.com>
|
||||||
- Disable debugging options.
|
- Disable debugging options.
|
||||||
|
|
||||||
|
3
sources
3
sources
@ -1,3 +1,2 @@
|
|||||||
SHA512 (linux-4.17.tar.xz) = 4d9de340a26155a89ea8773131c76220cc2057f2b5d031b467b60e8b14c1842518e2d60a863d8c695f0f7640f3f18d43826201984a238dade857b6cef79837db
|
SHA512 (linux-4.17.tar.xz) = 4d9de340a26155a89ea8773131c76220cc2057f2b5d031b467b60e8b14c1842518e2d60a863d8c695f0f7640f3f18d43826201984a238dade857b6cef79837db
|
||||||
SHA512 (patch-4.18-rc4.xz) = 6d2b502a0a183b3612d3fe64d7836d12087db18cb7446842b777b4e936c60da58faa22830668b1af2acb903ccbf5577bb7b337127c6d6b7778f51c4aa3296c08
|
SHA512 (patch-4.18-rc5.xz) = 238685483f0eb95d95678dd4ddd83c044d3888bd4ccc6966c6f9e8209a21aea86c18ba4a8e10c9e0d78037bc4809a93196f44ee23e8f9463641a16ca1ea97574
|
||||||
SHA512 (patch-4.18-rc4-git4.xz) = 55ff71cb2235da5cd5b85045e90776343a1e717b1ba6090d49d5399bb1643476a536bd5a737c1c54e42a2d21eb24f4aa6d8acc6a47c6671fdf4334aa3216d492
|
|
||||||
|
Loading…
Reference in New Issue
Block a user