kernel-5.14.0-0.rc5.20210813gitf8e6dfc64f61.45
* Fri Aug 13 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.20210813gitf8e6dfc64f61.45] - update filters for Fedora (Justin M. Forbes) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
82d295ba1d
commit
ea072671a1
@ -1,6 +1,3 @@
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/8d1041fe3e9bbffe2e339a032af8dc98780b1319
|
||||
8d1041fe3e9bbffe2e339a032af8dc98780b1319 pinctrl: tigerlake: Fix GPIO mapping for newer version of software
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/a34f0f1fdb553a2d11a5220c9e417e3d9d96ee43
|
||||
a34f0f1fdb553a2d11a5220c9e417e3d9d96ee43 Revert "ice: mark driver as tech-preview"
|
||||
|
||||
|
19
kernel.spec
19
kernel.spec
@ -78,9 +78,9 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||
# to build the base kernel using the debug configuration. (Specifying
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 0
|
||||
%define debugbuildsenabled 1
|
||||
|
||||
%global distro_build 0.rc5.20210813gitf8e6dfc64f61.46
|
||||
%global distro_build 0.rc6.46
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -124,13 +124,13 @@ Summary: The Linux kernel
|
||||
%define kversion 5.14
|
||||
|
||||
%define rpmversion 5.14.0
|
||||
%define pkgrelease 0.rc5.20210813gitf8e6dfc64f61.46
|
||||
%define pkgrelease 0.rc6.46
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 14
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc5.20210813gitf8e6dfc64f61.46%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc6.46%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -671,7 +671,7 @@ BuildRequires: lld
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.14-rc5-184-gf8e6dfc64f61.tar.xz
|
||||
Source0: linux-5.14-rc6.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1357,8 +1357,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.14-rc5-184-gf8e6dfc64f61 -c
|
||||
mv linux-5.14-rc5-184-gf8e6dfc64f61 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.14-rc6 -c
|
||||
mv linux-5.14-rc6 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -2647,7 +2647,7 @@ then\
|
||||
%{_sbindir}/weak-modules --add-kernel %{KVERREL}%{?1:+%{1}} || exit $?\
|
||||
fi\
|
||||
%endif\
|
||||
/bin/kernel-install -v add %{KVERREL}%{?1:+%{1}} /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz || exit $?\
|
||||
/bin/kernel-install add %{KVERREL}%{?1:+%{1}} /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz || exit $?\
|
||||
%{nil}
|
||||
|
||||
#
|
||||
@ -2952,9 +2952,6 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Fri Aug 13 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.20210813gitf8e6dfc64f61.46]
|
||||
- pinctrl: tigerlake: Fix GPIO mapping for newer version of software (Andy Shevchenko)
|
||||
|
||||
* Fri Aug 13 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.20210813gitf8e6dfc64f61.45]
|
||||
- update filters for Fedora (Justin M. Forbes)
|
||||
|
||||
|
@ -33,7 +33,6 @@
|
||||
drivers/nvme/host/nvme.h | 4 +
|
||||
drivers/pci/pci-driver.c | 29 ++
|
||||
drivers/pci/quirks.c | 24 +
|
||||
drivers/pinctrl/intel/pinctrl-tigerlake.c | 26 +-
|
||||
drivers/scsi/aacraid/linit.c | 2 +
|
||||
drivers/scsi/be2iscsi/be_main.c | 2 +
|
||||
drivers/scsi/hpsa.c | 4 +
|
||||
@ -81,7 +80,7 @@
|
||||
tools/testing/selftests/bpf/progs/linked_maps2.c | 76 ---
|
||||
tools/testing/selftests/bpf/progs/linked_vars1.c | 54 --
|
||||
tools/testing/selftests/bpf/progs/linked_vars2.c | 55 ---
|
||||
83 files changed, 1167 insertions(+), 1505 deletions(-)
|
||||
82 files changed, 1154 insertions(+), 1492 deletions(-)
|
||||
|
||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||
index bdb22006f713..61a3a4a4730b 100644
|
||||
@ -137,7 +136,7 @@ index 000000000000..effb81d04bfd
|
||||
+
|
||||
+endmenu
|
||||
diff --git a/Makefile b/Makefile
|
||||
index eae1314a5b86..a8dcae6b5b85 100644
|
||||
index c19d1638da25..5392d14f9646 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -1495,56 +1494,6 @@ index 6d74386eadc2..2333c1e4ae05 100644
|
||||
/*
|
||||
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
|
||||
* class code. Fix it.
|
||||
diff --git a/drivers/pinctrl/intel/pinctrl-tigerlake.c b/drivers/pinctrl/intel/pinctrl-tigerlake.c
|
||||
index 3e4ef2b87526..0bcd19597e4a 100644
|
||||
--- a/drivers/pinctrl/intel/pinctrl-tigerlake.c
|
||||
+++ b/drivers/pinctrl/intel/pinctrl-tigerlake.c
|
||||
@@ -701,32 +701,32 @@ static const struct pinctrl_pin_desc tglh_pins[] = {
|
||||
|
||||
static const struct intel_padgroup tglh_community0_gpps[] = {
|
||||
TGL_GPP(0, 0, 24, 0), /* GPP_A */
|
||||
- TGL_GPP(1, 25, 44, 128), /* GPP_R */
|
||||
- TGL_GPP(2, 45, 70, 32), /* GPP_B */
|
||||
- TGL_GPP(3, 71, 78, INTEL_GPIO_BASE_NOMAP), /* vGPIO_0 */
|
||||
+ TGL_GPP(1, 25, 44, 32), /* GPP_R */
|
||||
+ TGL_GPP(2, 45, 70, 64), /* GPP_B */
|
||||
+ TGL_GPP(3, 71, 78, 96), /* vGPIO_0 */
|
||||
};
|
||||
|
||||
static const struct intel_padgroup tglh_community1_gpps[] = {
|
||||
- TGL_GPP(0, 79, 104, 96), /* GPP_D */
|
||||
- TGL_GPP(1, 105, 128, 64), /* GPP_C */
|
||||
- TGL_GPP(2, 129, 136, 160), /* GPP_S */
|
||||
- TGL_GPP(3, 137, 153, 192), /* GPP_G */
|
||||
- TGL_GPP(4, 154, 180, 224), /* vGPIO */
|
||||
+ TGL_GPP(0, 79, 104, 128), /* GPP_D */
|
||||
+ TGL_GPP(1, 105, 128, 160), /* GPP_C */
|
||||
+ TGL_GPP(2, 129, 136, 192), /* GPP_S */
|
||||
+ TGL_GPP(3, 137, 153, 224), /* GPP_G */
|
||||
+ TGL_GPP(4, 154, 180, 256), /* vGPIO */
|
||||
};
|
||||
|
||||
static const struct intel_padgroup tglh_community3_gpps[] = {
|
||||
- TGL_GPP(0, 181, 193, 256), /* GPP_E */
|
||||
- TGL_GPP(1, 194, 217, 288), /* GPP_F */
|
||||
+ TGL_GPP(0, 181, 193, 288), /* GPP_E */
|
||||
+ TGL_GPP(1, 194, 217, 320), /* GPP_F */
|
||||
};
|
||||
|
||||
static const struct intel_padgroup tglh_community4_gpps[] = {
|
||||
- TGL_GPP(0, 218, 241, 320), /* GPP_H */
|
||||
+ TGL_GPP(0, 218, 241, 352), /* GPP_H */
|
||||
TGL_GPP(1, 242, 251, 384), /* GPP_J */
|
||||
- TGL_GPP(2, 252, 266, 352), /* GPP_K */
|
||||
+ TGL_GPP(2, 252, 266, 416), /* GPP_K */
|
||||
};
|
||||
|
||||
static const struct intel_padgroup tglh_community5_gpps[] = {
|
||||
- TGL_GPP(0, 267, 281, 416), /* GPP_I */
|
||||
+ TGL_GPP(0, 267, 281, 448), /* GPP_I */
|
||||
TGL_GPP(1, 282, 290, INTEL_GPIO_BASE_NOMAP), /* JTAG */
|
||||
};
|
||||
|
||||
diff --git a/drivers/scsi/aacraid/linit.c b/drivers/scsi/aacraid/linit.c
|
||||
index 3168915adaa7..71b48e29b708 100644
|
||||
--- a/drivers/scsi/aacraid/linit.c
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.14-rc5-184-gf8e6dfc64f61.tar.xz) = 89c8951e84ec528f8c473cd0785d1202273f0d32b1837ec887fd2127319c45a38b6a9f929c09053b0aaa6767421609cda63e455dde313ce3cc725dde9bef9fa0
|
||||
SHA512 (kernel-abi-stablelists-5.14.0-0.rc5.20210813gitf8e6dfc64f61.46.tar.bz2) = f3fd4ae6d022a1be167ab37f17033a0abd1b453dfd441e5b6597f6b09a85c1c802a99d7580f3172a4494cf34b7a7cfc7f83f3b7e9399c0c192510211bf74b5a5
|
||||
SHA512 (kernel-kabi-dw-5.14.0-0.rc5.20210813gitf8e6dfc64f61.46.tar.bz2) = 297dd8820a62e7eb9754a647d06d9aaff79aed97e842ae2817a9f1f1df51032c88d759d4f45f0788043ecdb22e403b1e4c4c5cd846db7ef4939a395a41a1c48f
|
||||
SHA512 (linux-5.14-rc6.tar.xz) = b9bed03d9b2bc71f8109ce6b604433276d63d129e02105e69c14b7f5d42fb490b09b7d6bad4ed4c80ab71d9bbc874265087c3783d421f9ace32e319578638560
|
||||
SHA512 (kernel-abi-stablelists-5.14.0-0.rc6.46.tar.bz2) = 90e8f166a6580061a3ef74e952810d029b3d89352ce882bb992110569f72870daa0c2260eb08ac309a21f5f048f898c8bc9fd13b27e409d752553ae545f93869
|
||||
SHA512 (kernel-kabi-dw-5.14.0-0.rc6.46.tar.bz2) = 3a1cf4a8f076b081ecea3b697d0db15306afe4407d8ec5a61207ea65ffab304d3493a0653cc97fff2912603e7b716436be4486effcb049b626ebed40bc8a11bf
|
||||
|
Loading…
Reference in New Issue
Block a user