kernel-5.17-0.rc0.20220121gitc2c94b3b187d.73
* Fri Jan 21 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc0.20220121gitc2c94b3b187d.73] - objtool: check: give big enough buffer for pv_ops (Sergei Trofimovich) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
51ecd72040
commit
e6421c472b
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 71
|
||||
RHEL_RELEASE = 73
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
@ -1,3 +1,6 @@
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/8783212c76137450007cd397847b20f9ae2634c4
|
||||
8783212c76137450007cd397847b20f9ae2634c4 objtool: check: give big enough buffer for pv_ops
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/c1ee15318f4a2688057fd1aeee6272603d0871f0
|
||||
c1ee15318f4a2688057fd1aeee6272603d0871f0 Fixup merge in random.c
|
||||
|
||||
|
15
kernel.spec
15
kernel.spec
@ -87,7 +87,7 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 0
|
||||
|
||||
%global distro_build 0.rc0.20220120gitfa2e1ba3e9e3.71
|
||||
%global distro_build 0.rc0.20220121gitc2c94b3b187d.73
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -132,13 +132,13 @@ Summary: The Linux kernel
|
||||
|
||||
%define rpmversion 5.17.0
|
||||
%define patchversion 5.17
|
||||
%define pkgrelease 0.rc0.20220120gitfa2e1ba3e9e3.71
|
||||
%define pkgrelease 0.rc0.20220121gitc2c94b3b187d.73
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 17
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc0.20220120gitfa2e1ba3e9e3.71%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc0.20220121gitc2c94b3b187d.73%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -692,7 +692,7 @@ BuildRequires: lld
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.16-11358-gfa2e1ba3e9e3.tar.xz
|
||||
Source0: linux-5.16-11444-gc2c94b3b187d.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1386,8 +1386,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.16-11358-gfa2e1ba3e9e3 -c
|
||||
mv linux-5.16-11358-gfa2e1ba3e9e3 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.16-11444-gc2c94b3b187d -c
|
||||
mv linux-5.16-11444-gc2c94b3b187d linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -2986,6 +2986,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Fri Jan 21 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc0.20220121gitc2c94b3b187d.73]
|
||||
- objtool: check: give big enough buffer for pv_ops (Sergei Trofimovich)
|
||||
|
||||
* Thu Jan 20 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc0.20220120gitfa2e1ba3e9e3.71]
|
||||
- Fixup merge in random.c (Justin M. Forbes)
|
||||
|
||||
|
@ -1,51 +0,0 @@
|
||||
From nobody Wed Jan 19 11:56:00 2022
|
||||
From: Sergei Trofimovich <slyich@gmail.com>
|
||||
To: Peter Zijlstra <peterz@infradead.org>
|
||||
Cc: linux-kernel@vger.kernel.org, Sergei Trofimovich <slyich@gmail.com>, Josh Poimboeuf <jpoimboe@redhat.com>
|
||||
Subject: [PATCH] objtool: check: give big enough buffer for pv_ops
|
||||
Date: Fri, 14 Jan 2022 07:57:56 +0000
|
||||
Message-Id: <20220114075756.838243-1-slyich@gmail.com>
|
||||
List-ID: <linux-kernel.vger.kernel.org>
|
||||
X-Mailing-List: linux-kernel@vger.kernel.org
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
Content-Transfer-Encoding: 7bit
|
||||
|
||||
On gcc-12 build fails flagging possible buffer overflow:
|
||||
|
||||
check.c: In function 'validate_call':
|
||||
check.c:2865:58: error: '%d' directive output may be truncated writing between 1 and 10 bytes into a region of size 9 [-Werror=format-truncation=]
|
||||
2865 | snprintf(pvname, sizeof(pvname), "pv_ops[%d]", idx);
|
||||
| ^~
|
||||
|
||||
I think it's a valid warning:
|
||||
|
||||
static char pvname[16];
|
||||
int idx;
|
||||
...
|
||||
idx = (rel->addend / sizeof(void *));
|
||||
snprintf(pvname, sizeof(pvname), "pv_ops[%d]", idx);
|
||||
|
||||
we have only 7 chars for %d while it could take up to 9.
|
||||
|
||||
CC: Josh Poimboeuf <jpoimboe@redhat.com>
|
||||
CC: Peter Zijlstra <peterz@infradead.org>
|
||||
---
|
||||
tools/objtool/check.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/objtool/check.c b/tools/objtool/check.c
|
||||
index 8c1931eab5f1..0fae132ea59f 100644
|
||||
--- a/tools/objtool/check.c
|
||||
+++ b/tools/objtool/check.c
|
||||
@@ -2852,7 +2852,7 @@ static inline bool func_uaccess_safe(struct symbol *func)
|
||||
|
||||
static inline const char *call_dest_name(struct instruction *insn)
|
||||
{
|
||||
- static char pvname[16];
|
||||
+ static char pvname[32];
|
||||
struct reloc *rel;
|
||||
int idx;
|
||||
|
||||
--
|
||||
2.34.1
|
@ -72,7 +72,8 @@
|
||||
security/lockdown/Kconfig | 13 +
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 6 +
|
||||
74 files changed, 1512 insertions(+), 188 deletions(-)
|
||||
tools/objtool/check.c | 2 +-
|
||||
75 files changed, 1513 insertions(+), 189 deletions(-)
|
||||
|
||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||
index f5a27f067db9..f4dc42f2f82a 100644
|
||||
@ -3173,3 +3174,16 @@ index 3d4eb474f35b..c02f1aa3ff64 100644
|
||||
#ifdef CONFIG_PERF_EVENTS
|
||||
int security_perf_event_open(struct perf_event_attr *attr, int type)
|
||||
{
|
||||
diff --git a/tools/objtool/check.c b/tools/objtool/check.c
|
||||
index c2d2ab9a2861..f5bed94e4558 100644
|
||||
--- a/tools/objtool/check.c
|
||||
+++ b/tools/objtool/check.c
|
||||
@@ -2854,7 +2854,7 @@ static inline bool func_uaccess_safe(struct symbol *func)
|
||||
|
||||
static inline const char *call_dest_name(struct instruction *insn)
|
||||
{
|
||||
- static char pvname[16];
|
||||
+ static char pvname[32];
|
||||
struct reloc *rel;
|
||||
int idx;
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.16-11358-gfa2e1ba3e9e3.tar.xz) = fcfa8b889916b1e009a195447f36cdb51ac75df0a5ed42b15863a5694241c6b28de01be67a404f3fc7c46fe5d63b1fc671bde0ea6dd9f57123d3f579bcaad1c4
|
||||
SHA512 (kernel-abi-stablelists-5.17.0-0.rc0.20220120gitfa2e1ba3e9e3.71.tar.bz2) = a8ded5de4c5f94e38fb46edc0f7e16d62cb5cfc459916cc80f0a22efc5e365c549cdafd8ceb717170b48cbd644dac4b93c85c3ae84ca5c8cf9419e6a894bbd9a
|
||||
SHA512 (kernel-kabi-dw-5.17.0-0.rc0.20220120gitfa2e1ba3e9e3.71.tar.bz2) = 053742e0a4246c097474679f4689c04cb0cfaf8eecfcfd8c6a77f39b42e785193b132d365c4bd4d26f7b5d73c453f6aceba15332df97b183b592ce810d3ba03e
|
||||
SHA512 (linux-5.16-11444-gc2c94b3b187d.tar.xz) = 783132284701cd1114fb15f9ef2b379fcf1bae874a5c1b8b6e6f4b3ac250fd4bf621372c97513eb8174ebee5067dc294e0e031eee95aeac7dcb78cf6462aa323
|
||||
SHA512 (kernel-abi-stablelists-5.17.0-0.rc0.20220121gitc2c94b3b187d.73.tar.bz2) = d23e8b2705394193d8a93fe94866e570a515e638fbd78e72aeaebb66333f17d442cb1c75e419c8d9187d560e70b8683302a248e42f7c20ad80d6ef6f39e9a0f0
|
||||
SHA512 (kernel-kabi-dw-5.17.0-0.rc0.20220121gitc2c94b3b187d.73.tar.bz2) = a570f47acd8d0af11b8684536269cfdb6f64051c7a8c419ee1a42297b4cdabc770877eee97e37596f35e8a46e0e81a2bd67461abd4380df988c08fcadbf84cb6
|
||||
|
Loading…
Reference in New Issue
Block a user