Linux 3.2-rc1
From kernel.org this time, not git generated locally: http://www.kernel.org/pub/linux/kernel/v3.x/patch-3.2-rc1.bz2
This commit is contained in:
parent
44ef27d0d0
commit
e3e38acf4d
@ -60,6 +60,7 @@ CONFIG_LEDS_CPU=y
|
|||||||
CONFIG_MTD_AFS_PARTS=y
|
CONFIG_MTD_AFS_PARTS=y
|
||||||
CONFIG_MTD_ARM_INTEGRATOR=y
|
CONFIG_MTD_ARM_INTEGRATOR=y
|
||||||
CONFIG_MTD_IMPA7=y
|
CONFIG_MTD_IMPA7=y
|
||||||
|
CONFIG_MTD_OF_PARTS=y
|
||||||
|
|
||||||
CONFIG_AX88796=m
|
CONFIG_AX88796=m
|
||||||
CONFIG_AX88796_93CX6=y
|
CONFIG_AX88796_93CX6=y
|
||||||
|
@ -207,6 +207,7 @@ CONFIG_MTD_BLOCK2MTD=m
|
|||||||
CONFIG_MTD_OOPS=m
|
CONFIG_MTD_OOPS=m
|
||||||
# CONFIG_MTD_INTEL_VR_NOR is not set
|
# CONFIG_MTD_INTEL_VR_NOR is not set
|
||||||
CONFIG_MTD_ALAUDA=m
|
CONFIG_MTD_ALAUDA=m
|
||||||
|
CONFIG_MTD_DOCG3=m
|
||||||
|
|
||||||
CONFIG_FTL=m
|
CONFIG_FTL=m
|
||||||
CONFIG_NFTL=m
|
CONFIG_NFTL=m
|
||||||
|
21
kernel.spec
21
kernel.spec
@ -54,7 +54,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 3
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -85,9 +85,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 1
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 7
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -700,14 +700,8 @@ Patch21001: arm-smsc-support-reading-mac-address-from-device-tree.patch
|
|||||||
#rhbz 749166
|
#rhbz 749166
|
||||||
Patch21050: xfs-Fix-possible-memory-corruption-in-xfs_readlink.patch
|
Patch21050: xfs-Fix-possible-memory-corruption-in-xfs_readlink.patch
|
||||||
|
|
||||||
#rhbz 731365
|
|
||||||
Patch21062: mac80211-fix-remain_off_channel-regression.patch
|
|
||||||
Patch21063: mac80211-config-hw-when-going-back-on-channel.patch
|
|
||||||
|
|
||||||
Patch21070: oom-fix-integer-overflow-of-points.patch
|
Patch21070: oom-fix-integer-overflow-of-points.patch
|
||||||
|
|
||||||
Patch21071: modsplit-post-merge.patch
|
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||||
@ -1329,12 +1323,6 @@ ApplyPatch utrace.patch
|
|||||||
#rhbz 750402
|
#rhbz 750402
|
||||||
ApplyPatch oom-fix-integer-overflow-of-points.patch
|
ApplyPatch oom-fix-integer-overflow-of-points.patch
|
||||||
|
|
||||||
ApplyPatch modsplit-post-merge.patch
|
|
||||||
|
|
||||||
#rhbz 731365
|
|
||||||
ApplyPatch mac80211-fix-remain_off_channel-regression.patch
|
|
||||||
ApplyPatch mac80211-config-hw-when-going-back-on-channel.patch
|
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2038,6 +2026,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 08 2011 Josh Boyer <jwboyer@redhat.com>
|
||||||
|
- Linux 3.2-rc1
|
||||||
|
|
||||||
* Mon Nov 07 2011 Josh Boyer <jwboyer@redhat.com>
|
* Mon Nov 07 2011 Josh Boyer <jwboyer@redhat.com>
|
||||||
- Linux 3.1-git7
|
- Linux 3.1-git7
|
||||||
- Drop override for XEN_MAX_DOMAIN_MEMORY (rhbz 751789)
|
- Drop override for XEN_MAX_DOMAIN_MEMORY (rhbz 751789)
|
||||||
|
@ -1,40 +0,0 @@
|
|||||||
From 776308dd5fa8a41e8bbb79818a66bd68a7db757e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Eliad Peller <eliad@wizery.com>
|
|
||||||
Date: Thu, 20 Oct 2011 19:05:50 +0200
|
|
||||||
Subject: [PATCH] mac80211: config hw when going back on-channel
|
|
||||||
|
|
||||||
When going back on-channel, we should reconfigure
|
|
||||||
the hw iff the hardware is not already configured
|
|
||||||
to the operational channel.
|
|
||||||
|
|
||||||
Signed-off-by: Eliad Peller <eliad@wizery.com>
|
|
||||||
Cc: stable@kernel.org # 2.6.39+
|
|
||||||
Signed-off-by: John W. Linville <linville@tuxdriver.com>
|
|
||||||
---
|
|
||||||
net/mac80211/work.c | 3 +--
|
|
||||||
1 files changed, 1 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/net/mac80211/work.c b/net/mac80211/work.c
|
|
||||||
index bf5be22..6c53b6d 100644
|
|
||||||
--- a/net/mac80211/work.c
|
|
||||||
+++ b/net/mac80211/work.c
|
|
||||||
@@ -1091,7 +1091,6 @@ static void ieee80211_work_work(struct work_struct *work)
|
|
||||||
}
|
|
||||||
|
|
||||||
if (!remain_off_channel && local->tmp_channel) {
|
|
||||||
- bool on_oper_chan = ieee80211_cfg_on_oper_channel(local);
|
|
||||||
local->tmp_channel = NULL;
|
|
||||||
/* If tmp_channel wasn't operating channel, then
|
|
||||||
* we need to go back on-channel.
|
|
||||||
@@ -1101,7 +1100,7 @@ static void ieee80211_work_work(struct work_struct *work)
|
|
||||||
* we still need to do a hardware config. Currently,
|
|
||||||
* we cannot be here while scanning, however.
|
|
||||||
*/
|
|
||||||
- if (ieee80211_cfg_on_oper_channel(local) && !on_oper_chan)
|
|
||||||
+ if (!ieee80211_cfg_on_oper_channel(local))
|
|
||||||
ieee80211_hw_config(local, 0);
|
|
||||||
|
|
||||||
/* At the least, we need to disable offchannel_ps,
|
|
||||||
--
|
|
||||||
1.7.6.2
|
|
||||||
|
|
@ -1,44 +0,0 @@
|
|||||||
From 682ba5a44516529b29fc780c055e06104d36e31e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Eliad Peller <eliad@wizery.com>
|
|
||||||
Date: Thu, 20 Oct 2011 19:05:49 +0200
|
|
||||||
Subject: [PATCH] mac80211: fix remain_off_channel regression
|
|
||||||
|
|
||||||
The offchannel code is currently broken - we should
|
|
||||||
remain_off_channel if the work was started, and
|
|
||||||
the work's channel and channel_type are the same
|
|
||||||
as local->tmp_channel and local->tmp_channel_type.
|
|
||||||
|
|
||||||
However, if wk->chan_type and local->tmp_channel_type
|
|
||||||
coexist (e.g. have the same channel type), we won't
|
|
||||||
remain_off_channel.
|
|
||||||
|
|
||||||
This behavior was introduced by commit da2fd1f
|
|
||||||
("mac80211: Allow work items to use existing
|
|
||||||
channel type.")
|
|
||||||
|
|
||||||
Tested-by: Ben Greear <greearb@candelatech.com>
|
|
||||||
Signed-off-by: Eliad Peller <eliad@wizery.com>
|
|
||||||
Cc: stable@kernel.org # 2.6.39+
|
|
||||||
Signed-off-by: John W. Linville <linville@tuxdriver.com>
|
|
||||||
---
|
|
||||||
net/mac80211/work.c | 4 ++--
|
|
||||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/net/mac80211/work.c b/net/mac80211/work.c
|
|
||||||
index 94472eb..bf5be22 100644
|
|
||||||
--- a/net/mac80211/work.c
|
|
||||||
+++ b/net/mac80211/work.c
|
|
||||||
@@ -1084,8 +1084,8 @@ static void ieee80211_work_work(struct work_struct *work)
|
|
||||||
continue;
|
|
||||||
if (wk->chan != local->tmp_channel)
|
|
||||||
continue;
|
|
||||||
- if (ieee80211_work_ct_coexists(wk->chan_type,
|
|
||||||
- local->tmp_channel_type))
|
|
||||||
+ if (!ieee80211_work_ct_coexists(wk->chan_type,
|
|
||||||
+ local->tmp_channel_type))
|
|
||||||
continue;
|
|
||||||
remain_off_channel = true;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.7.6.2
|
|
||||||
|
|
@ -1,156 +0,0 @@
|
|||||||
From 15a91ab0dc89e3f6eaeb76d9fcf0d151c6b171c6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Paul Gortmaker <paul.gortmaker@windriver.com>
|
|
||||||
Date: Sat, 8 Oct 2011 23:24:48 -0400
|
|
||||||
Subject: [PATCH] arm: Add export.h to recently added files for EXPORT_SYMBOL
|
|
||||||
|
|
||||||
These files didn't exist at the time of the module.h split, and
|
|
||||||
so were not fixed by the commits on that baseline. Since they use
|
|
||||||
the EXPORT_SYMBOL and/or THIS_MODULE macros, they will need the
|
|
||||||
new export.h file included that provides them.
|
|
||||||
|
|
||||||
Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
|
|
||||||
|
|
||||||
diff --git a/arch/arm/plat-samsung/dma-ops.c b/arch/arm/plat-samsung/dma-ops.c
|
|
||||||
index 6e3d9ab..93a994a 100644
|
|
||||||
--- a/arch/arm/plat-samsung/dma-ops.c
|
|
||||||
+++ b/arch/arm/plat-samsung/dma-ops.c
|
|
||||||
@@ -14,6 +14,7 @@
|
|
||||||
#include <linux/errno.h>
|
|
||||||
#include <linux/amba/pl330.h>
|
|
||||||
#include <linux/scatterlist.h>
|
|
||||||
+#include <linux/export.h>
|
|
||||||
|
|
||||||
#include <mach/dma.h>
|
|
||||||
|
|
||||||
diff --git a/arch/arm/plat-samsung/s3c-dma-ops.c b/arch/arm/plat-samsung/s3c-dma-ops.c
|
|
||||||
index 582333c..7814949 100644
|
|
||||||
--- a/arch/arm/plat-samsung/s3c-dma-ops.c
|
|
||||||
+++ b/arch/arm/plat-samsung/s3c-dma-ops.c
|
|
||||||
@@ -14,6 +14,7 @@
|
|
||||||
#include <linux/errno.h>
|
|
||||||
#include <linux/slab.h>
|
|
||||||
#include <linux/types.h>
|
|
||||||
+#include <linux/export.h>
|
|
||||||
|
|
||||||
#include <mach/dma.h>
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.6
|
|
||||||
|
|
||||||
From 284e50580e13aa492677a987d1e4e3d72dd63c63 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Paul Gortmaker <paul.gortmaker@windriver.com>
|
|
||||||
Date: Wed, 28 Sep 2011 18:29:32 -0400
|
|
||||||
Subject: [PATCH] drivers/md: change module.h -> export.h in
|
|
||||||
persistent-data/dm-*
|
|
||||||
|
|
||||||
For the files which are not themselves modular, we can change
|
|
||||||
them to include only the smaller export.h since all they are
|
|
||||||
doing is looking for EXPORT_SYMBOL.
|
|
||||||
|
|
||||||
Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
|
|
||||||
Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
|
|
||||||
|
|
||||||
diff --git a/drivers/md/persistent-data/dm-btree-remove.c b/drivers/md/persistent-data/dm-btree-remove.c
|
|
||||||
index cdd71d6..e7071f6 100644
|
|
||||||
--- a/drivers/md/persistent-data/dm-btree-remove.c
|
|
||||||
+++ b/drivers/md/persistent-data/dm-btree-remove.c
|
|
||||||
@@ -8,7 +8,7 @@
|
|
||||||
#include "dm-btree-internal.h"
|
|
||||||
#include "dm-transaction-manager.h"
|
|
||||||
|
|
||||||
-#include <linux/module.h>
|
|
||||||
+#include <linux/export.h>
|
|
||||||
|
|
||||||
/*
|
|
||||||
* Removing an entry from a btree
|
|
||||||
diff --git a/drivers/md/persistent-data/dm-btree.c b/drivers/md/persistent-data/dm-btree.c
|
|
||||||
index ca16d5b..408b762 100644
|
|
||||||
--- a/drivers/md/persistent-data/dm-btree.c
|
|
||||||
+++ b/drivers/md/persistent-data/dm-btree.c
|
|
||||||
@@ -8,7 +8,7 @@
|
|
||||||
#include "dm-space-map.h"
|
|
||||||
#include "dm-transaction-manager.h"
|
|
||||||
|
|
||||||
-#include <linux/module.h>
|
|
||||||
+#include <linux/export.h>
|
|
||||||
#include <linux/device-mapper.h>
|
|
||||||
|
|
||||||
#define DM_MSG_PREFIX "btree"
|
|
||||||
diff --git a/drivers/md/persistent-data/dm-space-map-disk.c b/drivers/md/persistent-data/dm-space-map-disk.c
|
|
||||||
index 6229a4e..e6b9d67 100644
|
|
||||||
--- a/drivers/md/persistent-data/dm-space-map-disk.c
|
|
||||||
+++ b/drivers/md/persistent-data/dm-space-map-disk.c
|
|
||||||
@@ -12,7 +12,7 @@
|
|
||||||
|
|
||||||
#include <linux/list.h>
|
|
||||||
#include <linux/slab.h>
|
|
||||||
-#include <linux/module.h>
|
|
||||||
+#include <linux/export.h>
|
|
||||||
#include <linux/device-mapper.h>
|
|
||||||
|
|
||||||
#define DM_MSG_PREFIX "space map disk"
|
|
||||||
diff --git a/drivers/md/persistent-data/dm-transaction-manager.c b/drivers/md/persistent-data/dm-transaction-manager.c
|
|
||||||
index be594dd..e58e89e 100644
|
|
||||||
--- a/drivers/md/persistent-data/dm-transaction-manager.c
|
|
||||||
+++ b/drivers/md/persistent-data/dm-transaction-manager.c
|
|
||||||
@@ -9,7 +9,7 @@
|
|
||||||
#include "dm-space-map-metadata.h"
|
|
||||||
#include "dm-persistent-data-internal.h"
|
|
||||||
|
|
||||||
-#include <linux/module.h>
|
|
||||||
+#include <linux/export.h>
|
|
||||||
#include <linux/slab.h>
|
|
||||||
#include <linux/device-mapper.h>
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.6
|
|
||||||
|
|
||||||
From 1193701b97f5dc4ca6a62a704dd55b058bfcf497 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephen Rothwell <sfr@canb.auug.org.au>
|
|
||||||
Date: Tue, 1 Nov 2011 18:30:49 +1100
|
|
||||||
Subject: [PATCH] device-mapper: dm-bufio.c needs to include module.h
|
|
||||||
|
|
||||||
since it uses the module facilities.
|
|
||||||
|
|
||||||
Signed-off-by: Stephen Rothwell <sfr@canb.auug.org.au>
|
|
||||||
Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
|
|
||||||
|
|
||||||
diff --git a/drivers/md/dm-bufio.c b/drivers/md/dm-bufio.c
|
|
||||||
index cb24666..0a6806f 100644
|
|
||||||
--- a/drivers/md/dm-bufio.c
|
|
||||||
+++ b/drivers/md/dm-bufio.c
|
|
||||||
@@ -14,6 +14,7 @@
|
|
||||||
#include <linux/vmalloc.h>
|
|
||||||
#include <linux/version.h>
|
|
||||||
#include <linux/shrinker.h>
|
|
||||||
+#include <linux/module.h>
|
|
||||||
|
|
||||||
#define DM_MSG_PREFIX "bufio"
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.4.4
|
|
||||||
|
|
||||||
From 8f3a8c73998ac2f9294bba483002ac906f18b92a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephen Rothwell <sfr@canb.auug.org.au>
|
|
||||||
Date: Tue, 1 Nov 2011 20:27:43 +1100
|
|
||||||
Subject: [PATCH] device-mapper: using EXPORT_SYBOL in dm-space-map-checker.c
|
|
||||||
needs export.h
|
|
||||||
|
|
||||||
Signed-off-by: Stephen Rothwell <sfr@canb.auug.org.au>
|
|
||||||
Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
|
|
||||||
|
|
||||||
diff --git a/drivers/md/persistent-data/dm-space-map-checker.c b/drivers/md/persistent-data/dm-space-map-checker.c
|
|
||||||
index bb44a93..50ed53b 100644
|
|
||||||
--- a/drivers/md/persistent-data/dm-space-map-checker.c
|
|
||||||
+++ b/drivers/md/persistent-data/dm-space-map-checker.c
|
|
||||||
@@ -7,6 +7,7 @@
|
|
||||||
#include "dm-space-map-checker.h"
|
|
||||||
|
|
||||||
#include <linux/device-mapper.h>
|
|
||||||
+#include <linux/export.h>
|
|
||||||
|
|
||||||
#ifdef CONFIG_DM_DEBUG_SPACE_MAPS
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.4.4
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user