Linux 3.1-git2 snapshot (upstream f362f98e7c)
This commit is contained in:
parent
c813c0daae
commit
dff0854796
@ -1965,6 +1965,7 @@ CONFIG_INPUT_CM109=m
|
||||
CONFIG_INPUT_POLLDEV=m
|
||||
CONFIG_INPUT_SPARSEKMAP=m
|
||||
# CONFIG_INPUT_ADXL34X is not set
|
||||
# CONFIG_INPUT_BMA150 is not set
|
||||
CONFIG_INPUT_CMA3000=m
|
||||
CONFIG_INPUT_CMA3000_I2C=m
|
||||
|
||||
@ -2067,6 +2068,7 @@ CONFIG_TOUCHSCREEN_MCS5000=m
|
||||
CONFIG_TOUCHSCREEN_MK712=m
|
||||
CONFIG_TOUCHSCREEN_PENMOUNT=m
|
||||
# CONFIG_TOUCHSCREEN_TPS6507X is not set
|
||||
CONFIG_TOUCHSCREEN_TSC_SERIO=m
|
||||
CONFIG_TOUCHSCREEN_TSC2007=m
|
||||
CONFIG_TOUCHSCREEN_TOUCHIT213=m
|
||||
CONFIG_TOUCHSCREEN_TOUCHRIGHT=m
|
||||
|
@ -153,6 +153,7 @@ CONFIG_OLPC_XO1_PM=y
|
||||
CONFIG_OLPC_XO15_SCI=y
|
||||
CONFIG_OLPC_XO1_RTC=y
|
||||
CONFIG_OLPC_XO1_SCI=y
|
||||
# CONFIG_ALIX is not set
|
||||
# staging
|
||||
# CONFIG_FB_OLPC_DCON is not set
|
||||
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/drivers/gpu/drm/radeon/radeon_fence.c b/drivers/gpu/drm/radeon/radeon_fence.c
|
||||
index 7fd4e3e..a488b50 100644
|
||||
--- a/drivers/gpu/drm/radeon/radeon_fence.c
|
||||
+++ b/drivers/gpu/drm/radeon/radeon_fence.c
|
||||
@@ -263,7 +263,7 @@ retry:
|
||||
*/
|
||||
if (seq == rdev->fence_drv.last_seq && radeon_gpu_is_lockup(rdev)) {
|
||||
/* good news we believe it's a lockup */
|
||||
- WARN(1, "GPU lockup (waiting for 0x%08X last fence id 0x%08X)\n",
|
||||
+ printk(KERN_WARNING "GPU lockup (waiting for 0x%08X last fence id 0x%08X)\n",
|
||||
fence->seq, seq);
|
||||
/* FIXME: what should we do ? marking everyone
|
||||
* as signaled for now
|
File diff suppressed because it is too large
Load Diff
107
floppy-Remove-_hlt-related-functions.patch
Normal file
107
floppy-Remove-_hlt-related-functions.patch
Normal file
@ -0,0 +1,107 @@
|
||||
From 5c21b39ab123ada8ce248efc733420bd8c9ea255 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Boyer <jwboyer@redhat.com>
|
||||
Date: Fri, 28 Oct 2011 15:38:06 -0400
|
||||
Subject: [PATCH] floppy: Remove _hlt related functions
|
||||
|
||||
It's close enough to 2012 and the WARN_ONCE is causing things like abrt to
|
||||
auto-file bugs that aren't really bugs.
|
||||
|
||||
Signed-off-by: Josh Boyer <jwboyer@redhat.com>
|
||||
|
||||
diff --git a/Documentation/feature-removal-schedule.txt b/Documentation/feature-removal-schedule.txt
|
||||
index d5ac362..df1e87c 100644
|
||||
--- a/Documentation/feature-removal-schedule.txt
|
||||
+++ b/Documentation/feature-removal-schedule.txt
|
||||
@@ -6,14 +6,6 @@ be removed from this file.
|
||||
|
||||
---------------------------
|
||||
|
||||
-What: x86 floppy disable_hlt
|
||||
-When: 2012
|
||||
-Why: ancient workaround of dubious utility clutters the
|
||||
- code used by everybody else.
|
||||
-Who: Len Brown <len.brown@intel.com>
|
||||
-
|
||||
----------------------------
|
||||
-
|
||||
What: CONFIG_APM_CPU_IDLE, and its ability to call APM BIOS in idle
|
||||
When: 2012
|
||||
Why: This optional sub-feature of APM is of dubious reliability,
|
||||
diff --git a/drivers/block/floppy.c b/drivers/block/floppy.c
|
||||
index 9955a53..40bf4c2 100644
|
||||
--- a/drivers/block/floppy.c
|
||||
+++ b/drivers/block/floppy.c
|
||||
@@ -1032,37 +1032,6 @@ static int fd_wait_for_completion(unsigned long delay, timeout_fn function)
|
||||
return 0;
|
||||
}
|
||||
|
||||
-static DEFINE_SPINLOCK(floppy_hlt_lock);
|
||||
-static int hlt_disabled;
|
||||
-static void floppy_disable_hlt(void)
|
||||
-{
|
||||
- unsigned long flags;
|
||||
-
|
||||
- WARN_ONCE(1, "floppy_disable_hlt() scheduled for removal in 2012");
|
||||
- spin_lock_irqsave(&floppy_hlt_lock, flags);
|
||||
- if (!hlt_disabled) {
|
||||
- hlt_disabled = 1;
|
||||
-#ifdef HAVE_DISABLE_HLT
|
||||
- disable_hlt();
|
||||
-#endif
|
||||
- }
|
||||
- spin_unlock_irqrestore(&floppy_hlt_lock, flags);
|
||||
-}
|
||||
-
|
||||
-static void floppy_enable_hlt(void)
|
||||
-{
|
||||
- unsigned long flags;
|
||||
-
|
||||
- spin_lock_irqsave(&floppy_hlt_lock, flags);
|
||||
- if (hlt_disabled) {
|
||||
- hlt_disabled = 0;
|
||||
-#ifdef HAVE_DISABLE_HLT
|
||||
- enable_hlt();
|
||||
-#endif
|
||||
- }
|
||||
- spin_unlock_irqrestore(&floppy_hlt_lock, flags);
|
||||
-}
|
||||
-
|
||||
static void setup_DMA(void)
|
||||
{
|
||||
unsigned long f;
|
||||
@@ -1107,7 +1076,6 @@ static void setup_DMA(void)
|
||||
fd_enable_dma();
|
||||
release_dma_lock(f);
|
||||
#endif
|
||||
- floppy_disable_hlt();
|
||||
}
|
||||
|
||||
static void show_floppy(void);
|
||||
@@ -1709,7 +1677,6 @@ irqreturn_t floppy_interrupt(int irq, void *dev_id)
|
||||
fd_disable_dma();
|
||||
release_dma_lock(f);
|
||||
|
||||
- floppy_enable_hlt();
|
||||
do_floppy = NULL;
|
||||
if (fdc >= N_FDC || FDCS->address == -1) {
|
||||
/* we don't even know which FDC is the culprit */
|
||||
@@ -1858,8 +1825,6 @@ static void floppy_shutdown(unsigned long data)
|
||||
show_floppy();
|
||||
cancel_activity();
|
||||
|
||||
- floppy_enable_hlt();
|
||||
-
|
||||
flags = claim_dma_lock();
|
||||
fd_disable_dma();
|
||||
release_dma_lock(flags);
|
||||
@@ -4504,7 +4469,6 @@ static void floppy_release_irq_and_dma(void)
|
||||
#if N_FDC > 1
|
||||
set_dor(1, ~8, 0);
|
||||
#endif
|
||||
- floppy_enable_hlt();
|
||||
|
||||
if (floppy_track_buffer && max_buffer_sectors) {
|
||||
tmpsize = max_buffer_sectors * 1024;
|
||||
--
|
||||
1.7.6.4
|
||||
|
13
kernel.spec
13
kernel.spec
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 0
|
||||
# The git snapshot level
|
||||
%define gitrev 1
|
||||
%define gitrev 2
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -631,6 +631,7 @@ Patch452: linux-2.6.30-no-pcspkr-modalias.patch
|
||||
Patch460: linux-2.6-serial-460800.patch
|
||||
|
||||
Patch470: die-floppy-die.patch
|
||||
Patch471: floppy-Remove-_hlt-related-functions.patch
|
||||
|
||||
Patch510: linux-2.6-silence-noise.patch
|
||||
Patch530: linux-2.6-silence-fbcon-logo.patch
|
||||
@ -647,7 +648,6 @@ Patch1555: fix_xen_guest_on_old_EC2.patch
|
||||
# DRM
|
||||
|
||||
# nouveau + drm fixes
|
||||
Patch1810: drm-nouveau-updates.patch
|
||||
# intel drm is all merged upstream
|
||||
Patch1824: drm-intel-next.patch
|
||||
# make sure the lvds comes back on lid open
|
||||
@ -655,8 +655,6 @@ Patch1825: drm-intel-make-lvds-work.patch
|
||||
# rhbz#729882, https://bugs.freedesktop.org/attachment.cgi?id=49069
|
||||
Patch1826: drm-i915-sdvo-lvds-is-digital.patch
|
||||
|
||||
Patch1850: drm-lower-severity-radeon-lockup.diff
|
||||
|
||||
Patch1900: linux-2.6-intel-iommu-igfx.patch
|
||||
|
||||
# Quiet boot fixes
|
||||
@ -1230,6 +1228,7 @@ ApplyPatch linux-2.6-input-kill-stupid-messages.patch
|
||||
|
||||
# stop floppy.ko from autoloading during udev...
|
||||
ApplyPatch die-floppy-die.patch
|
||||
ApplyPatch floppy-Remove-_hlt-related-functions.patch
|
||||
|
||||
ApplyPatch linux-2.6.30-no-pcspkr-modalias.patch
|
||||
|
||||
@ -1259,15 +1258,12 @@ ApplyPatch fix_xen_guest_on_old_EC2.patch
|
||||
# DRM core
|
||||
|
||||
# Nouveau DRM
|
||||
ApplyOptionalPatch drm-nouveau-updates.patch
|
||||
|
||||
# Intel DRM
|
||||
ApplyOptionalPatch drm-intel-next.patch
|
||||
ApplyPatch drm-intel-make-lvds-work.patch
|
||||
ApplyPatch drm-i915-sdvo-lvds-is-digital.patch
|
||||
|
||||
ApplyPatch drm-lower-severity-radeon-lockup.diff
|
||||
|
||||
ApplyPatch linux-2.6-intel-iommu-igfx.patch
|
||||
|
||||
# silence the ACPI blacklist code
|
||||
@ -2001,6 +1997,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri Oct 28 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Linux 3.1-git2
|
||||
|
||||
* Thu Oct 27 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Drop ia64
|
||||
- Drop alpha
|
||||
|
Loading…
Reference in New Issue
Block a user