Patch for disconnect issues with storage attached to a tegra-ehci controller
This commit is contained in:
parent
7b4b439262
commit
df483e6175
16
arm-tegra-usb-no-reset-linux33.patch
Normal file
16
arm-tegra-usb-no-reset-linux33.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- linux-3.3.4-3.fc17.x86_64_orig/drivers/usb/core/hub.c 2012-05-02 20:08:18.421685932 -0400
|
||||||
|
+++ linux-3.3.4-3.fc17.x86_64/drivers/usb/core/hub.c 2012-05-02 20:30:36.565865425 -0400
|
||||||
|
@@ -3484,6 +3484,13 @@ static void hub_events(void)
|
||||||
|
(u16) hub->change_bits[0],
|
||||||
|
(u16) hub->event_bits[0]);
|
||||||
|
|
||||||
|
+ /* Don't disconnect USB-SATA on TrimSlice */
|
||||||
|
+ if (strcmp(dev_name(hdev->bus->controller), "tegra-ehci.0") == 0) {
|
||||||
|
+ if ((hdev->state == 7) && (hub->change_bits[0] == 0) &&
|
||||||
|
+ (hub->event_bits[0] == 0x2))
|
||||||
|
+ hub->event_bits[0] = 0;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
/* Lock the device, then check to see if we were
|
||||||
|
* disconnected while waiting for the lock to succeed. */
|
||||||
|
usb_lock_device(hdev);
|
12
kernel.spec
12
kernel.spec
@ -715,12 +715,16 @@ Patch14000: hibernate-freeze-filesystems.patch
|
|||||||
|
|
||||||
Patch14010: lis3-improve-handling-of-null-rate.patch
|
Patch14010: lis3-improve-handling-of-null-rate.patch
|
||||||
|
|
||||||
|
# ARM
|
||||||
# Flattened devicetree support
|
# Flattened devicetree support
|
||||||
Patch21000: arm-omap-dt-compat.patch
|
Patch21000: arm-omap-dt-compat.patch
|
||||||
Patch21001: arm-smsc-support-reading-mac-address-from-device-tree.patch
|
Patch21001: arm-smsc-support-reading-mac-address-from-device-tree.patch
|
||||||
Patch21004: arm-tegra-nvec-kconfig.patch
|
|
||||||
|
|
||||||
# highbank patches
|
# ARM tegra
|
||||||
|
Patch21004: arm-tegra-nvec-kconfig.patch
|
||||||
|
Patch21005: arm-tegra-usb-no-reset-linux33.patch
|
||||||
|
|
||||||
|
# ARM highbank patches
|
||||||
# Highbank clock functions need to be EXPORT for module builds
|
# Highbank clock functions need to be EXPORT for module builds
|
||||||
Patch21010: highbank-export-clock-functions.patch
|
Patch21010: highbank-export-clock-functions.patch
|
||||||
|
|
||||||
@ -1317,6 +1321,7 @@ ApplyPatch nx-emu-remove-cpuinitdata-for-disable_nx-on-x86_32.patch
|
|||||||
#ApplyPatch arm-omap-dt-compat.patch
|
#ApplyPatch arm-omap-dt-compat.patch
|
||||||
#ApplyPatch arm-smsc-support-reading-mac-address-from-device-tree.patch
|
#ApplyPatch arm-smsc-support-reading-mac-address-from-device-tree.patch
|
||||||
ApplyPatch arm-tegra-nvec-kconfig.patch
|
ApplyPatch arm-tegra-nvec-kconfig.patch
|
||||||
|
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||||
|
|
||||||
#
|
#
|
||||||
# bugfixes to drivers and filesystems
|
# bugfixes to drivers and filesystems
|
||||||
@ -2326,6 +2331,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 3 2012 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||||
|
- Patch for disconnect issues with storage attached to a tegra-ehci controller
|
||||||
|
|
||||||
* Thu May 03 2012 Justin M. Forbes <jforbes@redhat.com>
|
* Thu May 03 2012 Justin M. Forbes <jforbes@redhat.com>
|
||||||
- Reenable slip and add to module-extras (rhbz 818308)
|
- Reenable slip and add to module-extras (rhbz 818308)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user