Linux 2.6.37-rc8-git3
This commit is contained in:
parent
6a82260f5d
commit
d6f08ea2fb
3
.gitignore
vendored
3
.gitignore
vendored
@ -3,4 +3,5 @@ patch-*.bz2
|
|||||||
clog
|
clog
|
||||||
*.rpm
|
*.rpm
|
||||||
kernel-2.6.*/
|
kernel-2.6.*/
|
||||||
/patch-2.6.37-rc7.bz2
|
/patch-2.6.37-rc8.bz2
|
||||||
|
/patch-2.6.37-rc8-git3.bz2
|
||||||
|
@ -13,32 +13,22 @@ and recreate the battery in order to populate the fields correctly.
|
|||||||
Signed-off-by: Matthew Garrett <mjg@redhat.com>
|
Signed-off-by: Matthew Garrett <mjg@redhat.com>
|
||||||
---
|
---
|
||||||
|
|
||||||
drivers/acpi/battery.c | 24 +++++++++++++++++-------
|
drivers/acpi/battery.c | 21 ++++++++++++++++-----
|
||||||
1 files changed, 17 insertions(+), 7 deletions(-)
|
1 files changed, 16 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
diff --git a/drivers/acpi/battery.c b/drivers/acpi/battery.c
|
diff --git a/drivers/acpi/battery.c b/drivers/acpi/battery.c
|
||||||
index 9fb9d5a..8da9c88 100644
|
index 95649d3..161e43a 100644
|
||||||
--- a/drivers/acpi/battery.c
|
--- a/drivers/acpi/battery.c
|
||||||
+++ b/drivers/acpi/battery.c
|
+++ b/drivers/acpi/battery.c
|
||||||
@@ -130,7 +130,7 @@ struct acpi_battery {
|
@@ -152,6 +152,7 @@ static int acpi_battery_technology(struct acpi_battery *battery)
|
||||||
unsigned long flags;
|
return POWER_SUPPLY_TECHNOLOGY_UNKNOWN;
|
||||||
};
|
}
|
||||||
|
|
||||||
-static int acpi_battery_update(struct acpi_battery *battery);
|
|
||||||
+static int acpi_battery_update(struct acpi_battery *battery, bool get_info);
|
+static int acpi_battery_update(struct acpi_battery *battery, bool get_info);
|
||||||
|
static int acpi_battery_get_state(struct acpi_battery *battery);
|
||||||
|
|
||||||
#define to_acpi_battery(x) container_of(x, struct acpi_battery, bat);
|
static int acpi_battery_is_charged(struct acpi_battery *battery)
|
||||||
|
@@ -605,9 +606,11 @@ static void acpi_battery_quirks2(struct acpi_battery *battery)
|
||||||
@@ -186,7 +186,7 @@ static int acpi_battery_get_property(struct power_supply *psy,
|
|
||||||
int ret = 0;
|
|
||||||
struct acpi_battery *battery = to_acpi_battery(psy);
|
|
||||||
|
|
||||||
- if (acpi_battery_update(battery))
|
|
||||||
+ if (acpi_battery_update(battery, false))
|
|
||||||
return -ENODEV;
|
|
||||||
|
|
||||||
if (acpi_battery_present(battery)) {
|
|
||||||
@@ -610,9 +610,11 @@ static void acpi_battery_quirks2(struct acpi_battery *battery)
|
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -51,7 +41,7 @@ index 9fb9d5a..8da9c88 100644
|
|||||||
result = acpi_battery_get_status(battery);
|
result = acpi_battery_get_status(battery);
|
||||||
if (result)
|
if (result)
|
||||||
return result;
|
return result;
|
||||||
@@ -631,6 +633,14 @@ static int acpi_battery_update(struct acpi_battery *battery)
|
@@ -626,6 +629,14 @@ static int acpi_battery_update(struct acpi_battery *battery)
|
||||||
}
|
}
|
||||||
if (!battery->bat.dev)
|
if (!battery->bat.dev)
|
||||||
sysfs_add_battery(battery);
|
sysfs_add_battery(battery);
|
||||||
@ -66,7 +56,7 @@ index 9fb9d5a..8da9c88 100644
|
|||||||
result = acpi_battery_get_state(battery);
|
result = acpi_battery_get_state(battery);
|
||||||
acpi_battery_quirks2(battery);
|
acpi_battery_quirks2(battery);
|
||||||
return result;
|
return result;
|
||||||
@@ -808,7 +818,7 @@ static print_func acpi_print_funcs[ACPI_BATTERY_NUMFILES] = {
|
@@ -803,7 +814,7 @@ static print_func acpi_print_funcs[ACPI_BATTERY_NUMFILES] = {
|
||||||
static int acpi_battery_read(int fid, struct seq_file *seq)
|
static int acpi_battery_read(int fid, struct seq_file *seq)
|
||||||
{
|
{
|
||||||
struct acpi_battery *battery = seq->private;
|
struct acpi_battery *battery = seq->private;
|
||||||
@ -75,7 +65,7 @@ index 9fb9d5a..8da9c88 100644
|
|||||||
return acpi_print_funcs[fid](seq, result);
|
return acpi_print_funcs[fid](seq, result);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -919,7 +929,7 @@ static void acpi_battery_notify(struct acpi_device *device, u32 event)
|
@@ -914,7 +925,7 @@ static void acpi_battery_notify(struct acpi_device *device, u32 event)
|
||||||
if (!battery)
|
if (!battery)
|
||||||
return;
|
return;
|
||||||
old = battery->bat.dev;
|
old = battery->bat.dev;
|
||||||
@ -84,7 +74,7 @@ index 9fb9d5a..8da9c88 100644
|
|||||||
acpi_bus_generate_proc_event(device, event,
|
acpi_bus_generate_proc_event(device, event,
|
||||||
acpi_battery_present(battery));
|
acpi_battery_present(battery));
|
||||||
acpi_bus_generate_netlink_event(device->pnp.device_class,
|
acpi_bus_generate_netlink_event(device->pnp.device_class,
|
||||||
@@ -948,7 +958,7 @@ static int acpi_battery_add(struct acpi_device *device)
|
@@ -943,7 +954,7 @@ static int acpi_battery_add(struct acpi_device *device)
|
||||||
if (ACPI_SUCCESS(acpi_get_handle(battery->device->handle,
|
if (ACPI_SUCCESS(acpi_get_handle(battery->device->handle,
|
||||||
"_BIX", &handle)))
|
"_BIX", &handle)))
|
||||||
set_bit(ACPI_BATTERY_XINFO_PRESENT, &battery->flags);
|
set_bit(ACPI_BATTERY_XINFO_PRESENT, &battery->flags);
|
||||||
@ -93,7 +83,7 @@ index 9fb9d5a..8da9c88 100644
|
|||||||
#ifdef CONFIG_ACPI_PROCFS_POWER
|
#ifdef CONFIG_ACPI_PROCFS_POWER
|
||||||
result = acpi_battery_add_fs(device);
|
result = acpi_battery_add_fs(device);
|
||||||
#endif
|
#endif
|
||||||
@@ -989,7 +999,7 @@ static int acpi_battery_resume(struct acpi_device *device)
|
@@ -984,7 +995,7 @@ static int acpi_battery_resume(struct acpi_device *device)
|
||||||
return -EINVAL;
|
return -EINVAL;
|
||||||
battery = acpi_driver_data(device);
|
battery = acpi_driver_data(device);
|
||||||
battery->update_time = 0;
|
battery->update_time = 0;
|
||||||
|
10
kernel.spec
10
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||||
# for example a 3 here will become 0.3
|
# for example a 3 here will become 0.3
|
||||||
#
|
#
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -82,9 +82,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 7
|
%define rcrev 8
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 3
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -1951,6 +1951,10 @@ fi
|
|||||||
# || ||
|
# || ||
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 03 2011 Kyle McMartin <kyle@redhat.com> 2.6.37-0.rc8.git3.1
|
||||||
|
- Linux 2.6.37-rc8-git3
|
||||||
|
- Merged acpi battery notification patch and -rc8.
|
||||||
|
|
||||||
* Thu Dec 23 2010 Kyle McMartin <kyle@redhat.com>
|
* Thu Dec 23 2010 Kyle McMartin <kyle@redhat.com>
|
||||||
- Pull in flexcop procfs rename patch since it's still not upstream. (#664852)
|
- Pull in flexcop procfs rename patch since it's still not upstream. (#664852)
|
||||||
|
|
||||||
|
3
sources
3
sources
@ -1,2 +1,3 @@
|
|||||||
61f3739a73afb6914cb007f37fb09b62 linux-2.6.36.tar.bz2
|
61f3739a73afb6914cb007f37fb09b62 linux-2.6.36.tar.bz2
|
||||||
c879f40313f5ee305a3e324ddde957be patch-2.6.37-rc7.bz2
|
19fc53ffe51f9b627badcd2c787b95fc patch-2.6.37-rc8.bz2
|
||||||
|
6539e48b97d6fcc3560a40da5737cfbc patch-2.6.37-rc8-git3.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user