Linux v3.9-10518-gd7ab730
This commit is contained in:
parent
93563b7419
commit
d65a84464b
@ -1,52 +0,0 @@
|
||||
From patchwork Tue Apr 23 16:30:52 2013
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: [20/21] MFD: ab8500: export ab8500_gpadc_sw_hw_convert properly
|
||||
Date: Tue, 23 Apr 2013 16:30:52 -0000
|
||||
From: Arnd Bergmann <arnd@arndb.de>
|
||||
X-Patchwork-Id: 2479831
|
||||
Message-Id: <1366734653-488286-21-git-send-email-arnd@arndb.de>
|
||||
To: linux-arm-kernel@lists.infradead.org
|
||||
Cc: Samuel Ortiz <sameo@linux.intel.com>, Arnd Bergmann <arnd@arndb.de>,
|
||||
Michel JAOUEN <michel.jaouen@stericsson.com>,
|
||||
linux-kernel@vger.kernel.org,
|
||||
M'boumba Cedric Madianga <cedric.madianga@stericsson.com>,
|
||||
Mattias WALLIN <mattias.wallin@stericsson.com>,
|
||||
Lee Jones <lee.jones@linaro.org>
|
||||
|
||||
Apparently the ab8500_gpadc_sw_hw_convert function got renamed
|
||||
from ab8500_gpadc_convert to ab8500_gpadc_sw_hw_convert in
|
||||
commit 734823462 "mfd: ab8500-gpadc: Add gpadc hw conversion",
|
||||
but the export for this function did not get changed at the
|
||||
same time, causing this allyesconfig error:
|
||||
|
||||
ERROR: "ab8500_gpadc_sw_hw_convert" [drivers/hwmon/ab8500.ko] undefined!
|
||||
|
||||
This patch fixes the export.
|
||||
|
||||
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
|
||||
Cc: M'boumba Cedric Madianga <cedric.madianga@stericsson.com>
|
||||
Cc: Lee Jones <lee.jones@linaro.org>
|
||||
Cc: Mattias WALLIN <mattias.wallin@stericsson.com>
|
||||
Cc: Michel JAOUEN <michel.jaouen@stericsson.com>
|
||||
Cc: Samuel Ortiz <sameo@linux.intel.com>
|
||||
Acked-by: Linus Walleij <linus.walleij@linaro.org>
|
||||
|
||||
---
|
||||
drivers/mfd/ab8500-gpadc.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/mfd/ab8500-gpadc.c b/drivers/mfd/ab8500-gpadc.c
|
||||
index 5f341a5..184df96 100644
|
||||
--- a/drivers/mfd/ab8500-gpadc.c
|
||||
+++ b/drivers/mfd/ab8500-gpadc.c
|
||||
@@ -269,7 +269,7 @@ int ab8500_gpadc_convert(struct ab8500_gpadc *gpadc, u8 channel)
|
||||
|
||||
return voltage;
|
||||
}
|
||||
-EXPORT_SYMBOL(ab8500_gpadc_convert);
|
||||
+EXPORT_SYMBOL(ab8500_gpadc_sw_hw_convert);
|
||||
|
||||
/**
|
||||
* ab8500_gpadc_read_raw() - gpadc read
|
@ -1,58 +0,0 @@
|
||||
@@ -, +, @@
|
||||
VMX: x86: handle host TSC calibration failure
|
||||
|
||||
If the host TSC calibration fails, tsc_khz is zero (see tsc_init.c).
|
||||
Handle such case properly in KVM (instead of dividing by zero).
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=859282
|
||||
|
||||
Signed-off-by: Marcelo Tosatti <mtosatti@redhat.com>
|
||||
Signed-off-by: Gleb Natapov <gleb@redhat.com>
|
||||
--- a/arch/x86/kvm/x86.c
|
||||
+++ a/arch/x86/kvm/x86.c
|
||||
@@ -1079,6 +1079,10 @@ static void kvm_set_tsc_khz(struct kvm_vcpu *vcpu, u32 this_tsc_khz)
|
||||
u32 thresh_lo, thresh_hi;
|
||||
int use_scaling = 0;
|
||||
|
||||
+ /* tsc_khz can be zero if TSC calibration fails */
|
||||
+ if (this_tsc_khz == 0)
|
||||
+ return;
|
||||
+
|
||||
/* Compute a scale to convert nanoseconds in TSC cycles */
|
||||
kvm_get_time_scale(this_tsc_khz, NSEC_PER_SEC / 1000,
|
||||
&vcpu->arch.virtual_tsc_shift,
|
||||
@@ -1156,20 +1160,23 @@ void kvm_write_tsc(struct kvm_vcpu *vcpu, struct msr_data *msr)
|
||||
ns = get_kernel_ns();
|
||||
elapsed = ns - kvm->arch.last_tsc_nsec;
|
||||
|
||||
- /* n.b - signed multiplication and division required */
|
||||
- usdiff = data - kvm->arch.last_tsc_write;
|
||||
+ if (vcpu->arch.virtual_tsc_khz) {
|
||||
+ /* n.b - signed multiplication and division required */
|
||||
+ usdiff = data - kvm->arch.last_tsc_write;
|
||||
#ifdef CONFIG_X86_64
|
||||
- usdiff = (usdiff * 1000) / vcpu->arch.virtual_tsc_khz;
|
||||
+ usdiff = (usdiff * 1000) / vcpu->arch.virtual_tsc_khz;
|
||||
#else
|
||||
- /* do_div() only does unsigned */
|
||||
- asm("idivl %2; xor %%edx, %%edx"
|
||||
- : "=A"(usdiff)
|
||||
- : "A"(usdiff * 1000), "rm"(vcpu->arch.virtual_tsc_khz));
|
||||
+ /* do_div() only does unsigned */
|
||||
+ asm("idivl %2; xor %%edx, %%edx"
|
||||
+ : "=A"(usdiff)
|
||||
+ : "A"(usdiff * 1000), "rm"(vcpu->arch.virtual_tsc_khz));
|
||||
#endif
|
||||
- do_div(elapsed, 1000);
|
||||
- usdiff -= elapsed;
|
||||
- if (usdiff < 0)
|
||||
- usdiff = -usdiff;
|
||||
+ do_div(elapsed, 1000);
|
||||
+ usdiff -= elapsed;
|
||||
+ if (usdiff < 0)
|
||||
+ usdiff = -usdiff;
|
||||
+ } else
|
||||
+ usdiff = USEC_PER_SEC; /* disable TSC match window below */
|
||||
|
||||
/*
|
||||
* Special case: TSC write with a small delta (1 second) of virtual
|
@ -3642,6 +3642,10 @@ CONFIG_MFD_VIPERBOARD=m
|
||||
# CONFIG_MFD_MC13XXX_I2C is not set
|
||||
# CONFIG_MFD_ARIZONA is not set
|
||||
# CONFIG_MFD_ARIZONA_I2C is not set
|
||||
# CONFIG_MFD_CROS_EC is not set
|
||||
# CONFIG_MFD_SI476X_CORE is not set
|
||||
# CONFIG_MFD_TPS65912 is not set
|
||||
# CONFIG_MFD_SYSCON is not set
|
||||
|
||||
#
|
||||
# File systems
|
||||
|
@ -145,6 +145,7 @@ CONFIG_EVENT_PROFILE=y
|
||||
CONFIG_KVM_BOOK3S_64=m
|
||||
CONFIG_KVM_BOOK3S_64_HV=y
|
||||
# CONFIG_KVM_EXIT_TIMING is not set
|
||||
CONFIG_KVM_XICS=y
|
||||
|
||||
#-- bz#607175
|
||||
#-- active memory sharing
|
||||
|
@ -136,6 +136,7 @@ CONFIG_EVENT_PROFILE=y
|
||||
CONFIG_KVM_BOOK3S_64=m
|
||||
CONFIG_KVM_BOOK3S_64_HV=y
|
||||
# CONFIG_KVM_EXIT_TIMING is not set
|
||||
CONFIG_KVM_XICS=y
|
||||
|
||||
#-- bz#607175
|
||||
#-- active memory sharing
|
||||
|
@ -244,6 +244,7 @@ CONFIG_VIRTUALIZATION=y
|
||||
CONFIG_KVM=m
|
||||
CONFIG_KVM_INTEL=m
|
||||
CONFIG_KVM_AMD=m
|
||||
CONFIG_KVM_DEVICE_ASSIGNMENT=y
|
||||
CONFIG_LGUEST=m
|
||||
CONFIG_LGUEST_GUEST=y
|
||||
|
||||
|
17
kernel.spec
17
kernel.spec
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 0
|
||||
# The git snapshot level
|
||||
%define gitrev 17
|
||||
%define gitrev 18
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -703,12 +703,11 @@ Patch21001: arm-of-dma.patch
|
||||
Patch21002: arm-lpae-ax88796.patch
|
||||
|
||||
# ARM omap
|
||||
Patch21003: 20-21-MFD-ab8500-export-ab8500_gpadc_sw_hw_convert-properly.patch
|
||||
|
||||
# ARM tegra
|
||||
Patch21005: arm-tegra-usb-no-reset-linux33.patch
|
||||
#atch21006: arm-tegra-fixclk.patch
|
||||
Patch21007: arm-tegra-sdhci-module-fix.patch
|
||||
#atch21007: arm-tegra-sdhci-module-fix.patch
|
||||
|
||||
#rhbz 754518
|
||||
Patch21235: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
|
||||
@ -725,9 +724,6 @@ Patch21247: ath9k_rx_dma_stop_check.patch
|
||||
#rhbz 903192
|
||||
Patch21261: 0001-kmsg-Honor-dmesg_restrict-sysctl-on-dev-kmsg.patch
|
||||
|
||||
#rhbz 859282
|
||||
Patch21275: VMX-x86-handle-host-TSC-calibration-failure.patch
|
||||
|
||||
Patch22000: weird-root-dentry-name-debug.patch
|
||||
|
||||
#selinux ptrace child permissions
|
||||
@ -1295,8 +1291,7 @@ ApplyPatch arm-of-dma.patch
|
||||
ApplyPatch arm-lpae-ax88796.patch
|
||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||
#pplyPatch arm-tegra-fixclk.patch
|
||||
ApplyPatch arm-tegra-sdhci-module-fix.patch
|
||||
ApplyPatch 20-21-MFD-ab8500-export-ab8500_gpadc_sw_hw_convert-properly.patch
|
||||
#pplyPatch arm-tegra-sdhci-module-fix.patch
|
||||
|
||||
#
|
||||
# bugfixes to drivers and filesystems
|
||||
@ -1417,9 +1412,6 @@ ApplyPatch ath9k_rx_dma_stop_check.patch
|
||||
#rhbz 903192
|
||||
ApplyPatch 0001-kmsg-Honor-dmesg_restrict-sysctl-on-dev-kmsg.patch
|
||||
|
||||
#rhbz 859282
|
||||
ApplyPatch VMX-x86-handle-host-TSC-calibration-failure.patch
|
||||
|
||||
#rhbz 927469
|
||||
ApplyPatch fix-child-thread-introspection.patch
|
||||
|
||||
@ -2253,6 +2245,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon May 06 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git18.1
|
||||
- Linux v3.9-10518-gd7ab730
|
||||
|
||||
* Mon May 06 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git17.1
|
||||
- Linux v3.9-10104-g1aaf6d3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user