- Temporarily disable ARM imx kernel due to missing clk patches
- Add patch to fix OMAP build - Drop DTB mac patches as rejected upstream - General ARM cleanups
This commit is contained in:
parent
ff66a4e962
commit
d0e3520271
10
arm-omap-dsp-inc.patch
Normal file
10
arm-omap-dsp-inc.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- linux-3.5.0-0.rc2.git0.1.fc17.armv7hl/arch/arm/mach-omap2/dsp.c.orig 2012-06-10 05:54:50.000000000 -0400
|
||||||
|
+++ linux-3.5.0-0.rc2.git0.1.fc17.armv7hl/arch/arm/mach-omap2/dsp.c 2012-06-10 05:55:38.000000000 -0400
|
||||||
|
@@ -20,6 +20,7 @@
|
||||||
|
|
||||||
|
#include <linux/module.h>
|
||||||
|
#include <linux/platform_device.h>
|
||||||
|
+#include <asm/memblock.h>
|
||||||
|
#include "cm2xxx_3xxx.h"
|
||||||
|
#include "prm2xxx_3xxx.h"
|
||||||
|
#ifdef CONFIG_BRIDGE_DVFS
|
@ -1,42 +0,0 @@
|
|||||||
diff -up linux-2.6.39.armv7l/arch/arm/mach-omap2/board-omap3beagle.c.fdt linux-2.6.39.armv7l/arch/arm/mach-omap2/board-omap3beagle.c
|
|
||||||
--- linux-2.6.39.armv7l/arch/arm/mach-omap2/board-omap3beagle.c.fdt 2011-08-04 16:51:12.034188064 -0500
|
|
||||||
+++ linux-2.6.39.armv7l/arch/arm/mach-omap2/board-omap3beagle.c 2011-08-04 22:13:52.801156923 -0500
|
|
||||||
@@ -591,6 +591,11 @@ static void __init omap3_beagle_init(voi
|
|
||||||
beagle_opp_init();
|
|
||||||
}
|
|
||||||
|
|
||||||
+static const char *omap3_beagle_dt_match[] __initdata = {
|
|
||||||
+ "ti,omap3-beagle",
|
|
||||||
+ NULL
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
MACHINE_START(OMAP3_BEAGLE, "OMAP3 Beagle Board")
|
|
||||||
/* Maintainer: Syed Mohammed Khasim - http://beagleboard.org */
|
|
||||||
.boot_params = 0x80000100,
|
|
||||||
@@ -600,4 +605,5 @@ MACHINE_START(OMAP3_BEAGLE, "OMAP3 Beagl
|
|
||||||
.init_irq = omap3_beagle_init_irq,
|
|
||||||
.init_machine = omap3_beagle_init,
|
|
||||||
.timer = &omap3_secure_timer,
|
|
||||||
+ .dt_compat = omap3_beagle_dt_match,
|
|
||||||
MACHINE_END
|
|
||||||
diff -up linux-2.6.39.armv7l/arch/arm/mach-omap2/board-omap4panda.c.fdt linux-2.6.39.armv7l/arch/arm/mach-omap2/board-omap4panda.c
|
|
||||||
--- linux-2.6.39.armv7l/arch/arm/mach-omap2/board-omap4panda.c.fdt 2011-08-04 16:51:12.092169023 -0500
|
|
||||||
+++ linux-2.6.39.armv7l/arch/arm/mach-omap2/board-omap4panda.c 2011-08-04 22:15:29.200157437 -0500
|
|
||||||
@@ -708,6 +708,11 @@ static void __init omap4_panda_map_io(vo
|
|
||||||
omap44xx_map_common_io();
|
|
||||||
}
|
|
||||||
|
|
||||||
+static const char *omap4_panda_match[] __initdata = {
|
|
||||||
+ "ti,omap4-panda",
|
|
||||||
+ NULL,
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
MACHINE_START(OMAP4_PANDA, "OMAP4 Panda board")
|
|
||||||
/* Maintainer: David Anders - Texas Instruments Inc */
|
|
||||||
.boot_params = 0x80000100,
|
|
||||||
@@ -717,4 +722,5 @@ MACHINE_START(OMAP4_PANDA, "OMAP4 Panda
|
|
||||||
.init_irq = gic_init_irq,
|
|
||||||
.init_machine = omap4_panda_init,
|
|
||||||
.timer = &omap4_timer,
|
|
||||||
+ .dt_compat = omap4_panda_match,
|
|
||||||
MACHINE_END
|
|
@ -1,92 +0,0 @@
|
|||||||
From 0b608345e114681f66ca0a3cf9d9434728da62ce Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ken Cox <ken@coxcampers.net>
|
|
||||||
Date: Thu, 23 Jun 2011 10:36:43 -0500
|
|
||||||
Subject: [PATCH] Support reading mac address from device tree.
|
|
||||||
|
|
||||||
If CONFIG_OF is enabled, we will try to read the mac address from the device tree. This enables us the ability to have a "static" mac address on arm boards such as the pandaboard and beagleboard which generate random mac addresses.
|
|
||||||
---
|
|
||||||
drivers/net/usb/smsc75xx.c | 17 +++++++++++++++++
|
|
||||||
drivers/net/usb/smsc95xx.c | 18 +++++++++++++++++-
|
|
||||||
2 files changed, 34 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/net/usb/smsc75xx.c b/drivers/net/usb/smsc75xx.c
|
|
||||||
index 753ee6e..ac0a200 100644
|
|
||||||
--- a/drivers/net/usb/smsc75xx.c
|
|
||||||
+++ b/drivers/net/usb/smsc75xx.c
|
|
||||||
@@ -29,6 +29,7 @@
|
|
||||||
#include <linux/crc32.h>
|
|
||||||
#include <linux/usb/usbnet.h>
|
|
||||||
#include <linux/slab.h>
|
|
||||||
+#include <linux/of_device.h>
|
|
||||||
#include "smsc75xx.h"
|
|
||||||
|
|
||||||
#define SMSC_CHIPNAME "smsc75xx"
|
|
||||||
@@ -658,6 +659,22 @@ static int smsc75xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
|
||||||
|
|
||||||
static void smsc75xx_init_mac_address(struct usbnet *dev)
|
|
||||||
{
|
|
||||||
+ void *address;
|
|
||||||
+#ifdef CONFIG_OF
|
|
||||||
+ struct device_node *np;
|
|
||||||
+
|
|
||||||
+ /* try the device tree */
|
|
||||||
+ np = of_find_node_by_name(NULL, "smsc75xx");
|
|
||||||
+ if (np) {
|
|
||||||
+ address = of_get_property(np, "local-mac-address", NULL);
|
|
||||||
+ if (address) {
|
|
||||||
+ memcpy(dev->net->dev_addr, address, ETH_ALEN);
|
|
||||||
+ netif_dbg(dev, ifup, dev->net, "MAC address read from device tree\n");
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
/* try reading mac address from EEPROM */
|
|
||||||
if (smsc75xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
|
|
||||||
dev->net->dev_addr) == 0) {
|
|
||||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
|
||||||
index bc86f4b..c83942d 100644
|
|
||||||
--- a/drivers/net/usb/smsc95xx.c
|
|
||||||
+++ b/drivers/net/usb/smsc95xx.c
|
|
||||||
@@ -29,6 +29,7 @@
|
|
||||||
#include <linux/crc32.h>
|
|
||||||
#include <linux/usb/usbnet.h>
|
|
||||||
#include <linux/slab.h>
|
|
||||||
+#include <linux/of_device.h>
|
|
||||||
#include "smsc95xx.h"
|
|
||||||
|
|
||||||
#define SMSC_CHIPNAME "smsc95xx"
|
|
||||||
@@ -639,6 +640,22 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
|
||||||
|
|
||||||
static void smsc95xx_init_mac_address(struct usbnet *dev)
|
|
||||||
{
|
|
||||||
+ void *address;
|
|
||||||
+#ifdef CONFIG_OF
|
|
||||||
+ struct device_node *np;
|
|
||||||
+
|
|
||||||
+ /* try the device tree */
|
|
||||||
+ np = of_find_node_by_name(NULL, "smsc95xx");
|
|
||||||
+ if (np) {
|
|
||||||
+ address = of_get_property(np, "local-mac-address", NULL);
|
|
||||||
+ if (address) {
|
|
||||||
+ memcpy(dev->net->dev_addr, address, ETH_ALEN);
|
|
||||||
+ netif_dbg(dev, ifup, dev->net, "MAC address read from device tree\n");
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
/* try reading mac address from EEPROM */
|
|
||||||
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
|
|
||||||
dev->net->dev_addr) == 0) {
|
|
||||||
@@ -648,7 +665,6 @@ static void smsc95xx_init_mac_address(struct usbnet *dev)
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
-
|
|
||||||
/* no eeprom, or eeprom values are invalid. generate random MAC */
|
|
||||||
random_ether_addr(dev->net->dev_addr);
|
|
||||||
netif_dbg(dev, ifup, dev->net, "MAC address set to random_ether_addr\n");
|
|
||||||
--
|
|
||||||
1.7.2.3
|
|
||||||
|
|
@ -101,35 +101,15 @@ CONFIG_DM9000_DEBUGLEVEL=4
|
|||||||
CONFIG_SMC911X=m
|
CONFIG_SMC911X=m
|
||||||
CONFIG_SMSC911X=m
|
CONFIG_SMSC911X=m
|
||||||
|
|
||||||
# Generic MTD options. Platform specific set there
|
|
||||||
CONFIG_MTD=y
|
|
||||||
CONFIG_MTD_TESTS=m
|
|
||||||
CONFIG_MTD_CMDLINE_PARTS=y
|
|
||||||
# CONFIG_MTD_AFS_PARTS is not set
|
|
||||||
# CONFIG_MTD_AR7_PARTS is not set
|
|
||||||
CONFIG_MTD_CHAR=y
|
|
||||||
CONFIG_MTD_BLKDEVS=y
|
|
||||||
CONFIG_MTD_BLOCK=y
|
|
||||||
CONFIG_SM_FTL=m
|
|
||||||
CONFIG_MTD_PHYSMAP=m
|
|
||||||
# CONFIG_MTD_PHYSMAP_COMPAT is not set
|
|
||||||
# CONFIG_MTD_GPIO_ADDR is not set
|
|
||||||
CONFIG_MTD_PLATRAM=m
|
|
||||||
CONFIG_MTD_AFS_PARTS=y
|
|
||||||
CONFIG_MTD_ARM_INTEGRATOR=y
|
|
||||||
CONFIG_MTD_IMPA7=y
|
|
||||||
# CONFIG_MTD_PISMO is not set
|
|
||||||
CONFIG_MTD_PHYSMAP_OF=m
|
|
||||||
CONFIG_MTD_OF_PARTS=y
|
|
||||||
|
|
||||||
CONFIG_MMC_SDHCI_PLTFM=m
|
CONFIG_MMC_SDHCI_PLTFM=m
|
||||||
|
|
||||||
# Generic GPIO options
|
# Generic GPIO options
|
||||||
CONFIG_GENERIC_GPIO=y
|
CONFIG_GENERIC_GPIO=y
|
||||||
|
|
||||||
CONFIG_MTD=m
|
CONFIG_MTD=m
|
||||||
|
CONFIG_MTD_TESTS=m
|
||||||
CONFIG_MTD_CMDLINE_PARTS=y
|
CONFIG_MTD_CMDLINE_PARTS=y
|
||||||
CONFIG_MTD_AFS_PARTS=y
|
# CONFIG_MTD_AFS_PARTS is not set
|
||||||
CONFIG_MTD_CHAR=m
|
CONFIG_MTD_CHAR=m
|
||||||
CONFIG_MTD_BLKDEVS=m
|
CONFIG_MTD_BLKDEVS=m
|
||||||
CONFIG_MTD_BLOCK=m
|
CONFIG_MTD_BLOCK=m
|
||||||
|
@ -40,7 +40,7 @@ CONFIG_SND_KIRKWOOD_SOC_T5325=m
|
|||||||
CONFIG_MMC_MVSDIO=m
|
CONFIG_MMC_MVSDIO=m
|
||||||
CONFIG_LEDS_NS2=m
|
CONFIG_LEDS_NS2=m
|
||||||
CONFIG_LEDS_NETXBIG=m
|
CONFIG_LEDS_NETXBIG=m
|
||||||
CONFIG_RTC_DRV_MV=m
|
CONFIG_RTC_DRV_MV=y
|
||||||
CONFIG_MV_XOR=y
|
CONFIG_MV_XOR=y
|
||||||
CONFIG_CRYPTO_DEV_MV_CESA=m
|
CONFIG_CRYPTO_DEV_MV_CESA=m
|
||||||
|
|
||||||
|
16
kernel.spec
16
kernel.spec
@ -257,11 +257,11 @@ Summary: The Linux kernel
|
|||||||
|
|
||||||
# kernel up (versatile express), tegra, omap, imx and highbank are only built on armv7 hfp/sfp
|
# kernel up (versatile express), tegra, omap, imx and highbank are only built on armv7 hfp/sfp
|
||||||
%ifnarch armv7hl armv7l
|
%ifnarch armv7hl armv7l
|
||||||
%define with_imx 0
|
|
||||||
%define with_highbank 0
|
%define with_highbank 0
|
||||||
%define with_omap 0
|
%define with_omap 0
|
||||||
%define with_tegra 0
|
%define with_tegra 0
|
||||||
%endif
|
%endif
|
||||||
|
%define with_imx 0
|
||||||
|
|
||||||
# kernel-kirkwood is only built for armv5
|
# kernel-kirkwood is only built for armv5
|
||||||
%ifnarch armv5tel
|
%ifnarch armv5tel
|
||||||
@ -714,9 +714,8 @@ Patch14000: hibernate-freeze-filesystems.patch
|
|||||||
Patch14010: lis3-improve-handling-of-null-rate.patch
|
Patch14010: lis3-improve-handling-of-null-rate.patch
|
||||||
|
|
||||||
# ARM
|
# ARM
|
||||||
# Flattened devicetree support
|
# OMAP
|
||||||
Patch21000: arm-omap-dt-compat.patch
|
Patch21000: arm-omap-dsp-inc.patch
|
||||||
Patch21001: arm-smsc-support-reading-mac-address-from-device-tree.patch
|
|
||||||
|
|
||||||
# ARM tegra
|
# ARM tegra
|
||||||
Patch21004: arm-tegra-nvec-kconfig.patch
|
Patch21004: arm-tegra-nvec-kconfig.patch
|
||||||
@ -1298,8 +1297,7 @@ ApplyPatch taint-vbox.patch
|
|||||||
#
|
#
|
||||||
# ARM
|
# ARM
|
||||||
#
|
#
|
||||||
#ApplyPatch arm-omap-dt-compat.patch
|
ApplyPatch arm-omap-dsp-inc.patch
|
||||||
#ApplyPatch arm-smsc-support-reading-mac-address-from-device-tree.patch
|
|
||||||
ApplyPatch arm-tegra-nvec-kconfig.patch
|
ApplyPatch arm-tegra-nvec-kconfig.patch
|
||||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||||
ApplyPatch arm-tegra-sdhci-module-fix.patch
|
ApplyPatch arm-tegra-sdhci-module-fix.patch
|
||||||
@ -2278,6 +2276,12 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jun 10 2012 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||||
|
- Temporarily disable ARM imx kernel due to missing clk patches
|
||||||
|
- Add patch to fix OMAP build
|
||||||
|
- Drop DTB mac patches as rejected upstream
|
||||||
|
- General ARM cleanups
|
||||||
|
|
||||||
* Sat Jun 09 2012 Josh Boyer <jwboyer@redhat.com> - 3.5.0-0.rc2.git0.1
|
* Sat Jun 09 2012 Josh Boyer <jwboyer@redhat.com> - 3.5.0-0.rc2.git0.1
|
||||||
- Linux v3.5-rc2
|
- Linux v3.5-rc2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user