Create a working config file for highbank and add highbank to the
spec file. Signed-off-by: Mark Langsdorf <mark.langsdorf@calxeda.com>
This commit is contained in:
parent
25313f2bcf
commit
d005e8b3ed
@ -1,3 +1,37 @@
|
|||||||
ONFIG_ARCH_HIGHBANK=y
|
CONFIG_ARCH_HIGHBANK=y
|
||||||
|
# CONFIG_ARM_LPAE is not set
|
||||||
|
# CONFIG_ARM_THUMBEE is not set
|
||||||
|
CONFIG_SWP_EMULATE=y
|
||||||
|
# CONFIG_CPU_BPREDICT_DISABLE is not set
|
||||||
|
# CONFIG_ARM_ERRATA_430973 is not set
|
||||||
|
# CONFIG_ARM_ERRATA_458693 is not set
|
||||||
|
# CONFIG_ARM_ERRATA_460075 is not set
|
||||||
|
# CONFIG_PL310_ERRATA_588369 is not set
|
||||||
|
# CONFIG_PL310_ERRATA_727915 is not set
|
||||||
|
# CONFIG_ARM_ERRATA_743622 is not set
|
||||||
|
# CONFIG_PL310_ERRATA_753970 is not set
|
||||||
|
# CONFIG_ARM_ERRATA_754322 is not set
|
||||||
|
# CONFIG_PL310_ERRATA_769419 is not set
|
||||||
|
|
||||||
|
# CONFIG_THUMB2_KERNEL is not set
|
||||||
|
|
||||||
|
CONFIG_ARM_TIMER_SP804=y
|
||||||
|
|
||||||
CONFIG_VFP=y
|
CONFIG_VFP=y
|
||||||
|
CONFIG_VFPv3=y
|
||||||
CONFIG_NEON=y
|
CONFIG_NEON=y
|
||||||
|
|
||||||
|
CONFIG_SATA_AHCI_PLATFORM=y
|
||||||
|
CONFIG_ATA_SFF=y
|
||||||
|
|
||||||
|
CONFIG_ETHERNET=y
|
||||||
|
CONFIG_NET_VENDOR_BROADCOM=y
|
||||||
|
CONFIG_NET_CALXEDA_XGMAC=y
|
||||||
|
|
||||||
|
CONFIG_GPIO_PL061=y
|
||||||
|
|
||||||
|
CONFIG_SERIAL_AMBA_PL010=y
|
||||||
|
CONFIG_SERIAL_AMBA_PL010_CONSOLE=y
|
||||||
|
|
||||||
|
# CONFIG_DVB_TDA1004X is not set
|
||||||
|
# CONFIG_DVB_PLL is not set
|
||||||
|
43
highbank-export-clock-functions.patch
Normal file
43
highbank-export-clock-functions.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
From 81a06eed2491273b7d6d274ae4be1d333c100ab0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mark Langsdorf <mark.langsdorf@calxeda.com>
|
||||||
|
Date: Mon, 12 Mar 2012 06:28:19 -0400
|
||||||
|
Subject: [PATCH] highbank: export clock functions
|
||||||
|
|
||||||
|
Signed-off-by: Mark Langsdorf <mark.langsdorf@calxeda.com>
|
||||||
|
---
|
||||||
|
arch/arm/mach-highbank/clock.c | 4 ++++
|
||||||
|
1 files changed, 4 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
|
diff --git diff -up linux-3.2-rc4.orig/arch/arm/mach-highbank/clock.c diff -up linux-3.2-rc4/arch/arm/mach-highbank/clock.c
|
||||||
|
index c25a2ae..cdbc575 100644
|
||||||
|
--- a/arch/arm/mach-highbank/clock.c
|
||||||
|
+++ b/arch/arm/mach-highbank/clock.c
|
||||||
|
@@ -27,14 +27,17 @@ int clk_enable(struct clk *clk)
|
||||||
|
{
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
+EXPORT_SYMBOL_GPL(clk_enable);
|
||||||
|
|
||||||
|
void clk_disable(struct clk *clk)
|
||||||
|
{}
|
||||||
|
+EXPORT_SYMBOL_GPL(clk_disable);
|
||||||
|
|
||||||
|
unsigned long clk_get_rate(struct clk *clk)
|
||||||
|
{
|
||||||
|
return clk->rate;
|
||||||
|
}
|
||||||
|
+EXPORT_SYMBOL_GPL(clk_get_rate);
|
||||||
|
|
||||||
|
long clk_round_rate(struct clk *clk, unsigned long rate)
|
||||||
|
{
|
||||||
|
@@ -45,6 +48,7 @@ int clk_set_rate(struct clk *clk, unsigned long rate)
|
||||||
|
{
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
+EXPORT_SYMBOL_GPL(clk_set_rate);
|
||||||
|
|
||||||
|
static struct clk eclk = { .rate = 200000000 };
|
||||||
|
static struct clk pclk = { .rate = 150000000 };
|
||||||
|
--
|
||||||
|
1.7.9.1
|
||||||
|
|
14
kernel.spec
14
kernel.spec
@ -277,10 +277,8 @@ Summary: The Linux kernel
|
|||||||
%define with_tegra 0
|
%define with_tegra 0
|
||||||
%define with_omap 0
|
%define with_omap 0
|
||||||
%define with_imx 0
|
%define with_imx 0
|
||||||
%endif
|
|
||||||
|
|
||||||
# disable highbank ARM kernels for the time being
|
|
||||||
%define with_highbank 0
|
%define with_highbank 0
|
||||||
|
%endif
|
||||||
|
|
||||||
# kernel-kirkwood is only built for armv5
|
# kernel-kirkwood is only built for armv5
|
||||||
%ifnarch armv5tel
|
%ifnarch armv5tel
|
||||||
@ -764,6 +762,10 @@ Patch21000: arm-omap-dt-compat.patch
|
|||||||
Patch21001: arm-smsc-support-reading-mac-address-from-device-tree.patch
|
Patch21001: arm-smsc-support-reading-mac-address-from-device-tree.patch
|
||||||
Patch21004: arm-tegra-nvec-kconfig.patch
|
Patch21004: arm-tegra-nvec-kconfig.patch
|
||||||
|
|
||||||
|
# highbank patches
|
||||||
|
# Highbank clock functions need to be EXPORT for module builds
|
||||||
|
Patch21010: highbank-export-clock-functions.patch
|
||||||
|
|
||||||
Patch21070: ext4-Support-check-none-nocheck-mount-options.patch
|
Patch21070: ext4-Support-check-none-nocheck-mount-options.patch
|
||||||
|
|
||||||
Patch21092: udlfb-remove-sysfs-framebuffer-device-with-USB-disconnect.patch
|
Patch21092: udlfb-remove-sysfs-framebuffer-device-with-USB-disconnect.patch
|
||||||
@ -1528,6 +1530,9 @@ ApplyPatch unhandled-irqs-switch-to-polling.patch
|
|||||||
|
|
||||||
ApplyPatch weird-root-dentry-name-debug.patch
|
ApplyPatch weird-root-dentry-name-debug.patch
|
||||||
|
|
||||||
|
#Highbank clock functions
|
||||||
|
ApplyPatch highbank-export-clock-functions.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2432,6 +2437,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 12 2012 Mark Langsdorf <mark.langsdorf@calxeda.com>
|
||||||
|
- Re-enable highbank config option and add new config file to support it
|
||||||
|
|
||||||
* Mon Mar 12 2012 Dave Jones <davej@redhat.com> - 3.3.0-0.rc7.git0.5
|
* Mon Mar 12 2012 Dave Jones <davej@redhat.com> - 3.3.0-0.rc7.git0.5
|
||||||
- Reenable debugging options.
|
- Reenable debugging options.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user