Linux v3.11-rc3-207-g64ccccf
This commit is contained in:
parent
390fae1d3b
commit
c8491a786b
@ -1,50 +0,0 @@
|
||||
From 1faabf2aab1fdaa1ace4e8c829d1b9cf7bfec2f1 Mon Sep 17 00:00:00 2001
|
||||
From: Eric Dumazet <edumazet@google.com>
|
||||
Date: Sat, 20 Jul 2013 03:07:16 +0000
|
||||
Subject: bridge: do not call setup_timer() multiple times
|
||||
|
||||
commit 9f00b2e7cf24 ("bridge: only expire the mdb entry when query is
|
||||
received") added a nasty bug as an active timer can be reinitialized.
|
||||
|
||||
setup_timer() must be done once, no matter how many time mod_timer()
|
||||
is called. br_multicast_new_group() is the right place to do this.
|
||||
|
||||
Reported-by: Srivatsa S. Bhat <srivatsa.bhat@linux.vnet.ibm.com>
|
||||
Diagnosed-by: Thomas Gleixner <tglx@linutronix.de>
|
||||
Signed-off-by: Eric Dumazet <edumazet@google.com>
|
||||
Tested-by: Srivatsa S. Bhat <srivatsa.bhat@linux.vnet.ibm.com>
|
||||
Cc: Cong Wang <amwang@redhat.com>
|
||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
||||
---
|
||||
diff --git a/net/bridge/br_multicast.c b/net/bridge/br_multicast.c
|
||||
index 69af490..4b99c9a 100644
|
||||
--- a/net/bridge/br_multicast.c
|
||||
+++ b/net/bridge/br_multicast.c
|
||||
@@ -619,6 +619,9 @@ rehash:
|
||||
mp->br = br;
|
||||
mp->addr = *group;
|
||||
|
||||
+ setup_timer(&mp->timer, br_multicast_group_expired,
|
||||
+ (unsigned long)mp);
|
||||
+
|
||||
hlist_add_head_rcu(&mp->hlist[mdb->ver], &mdb->mhash[hash]);
|
||||
mdb->size++;
|
||||
|
||||
@@ -1126,7 +1129,6 @@ static int br_ip4_multicast_query(struct net_bridge *br,
|
||||
if (!mp)
|
||||
goto out;
|
||||
|
||||
- setup_timer(&mp->timer, br_multicast_group_expired, (unsigned long)mp);
|
||||
mod_timer(&mp->timer, now + br->multicast_membership_interval);
|
||||
mp->timer_armed = true;
|
||||
|
||||
@@ -1204,7 +1206,6 @@ static int br_ip6_multicast_query(struct net_bridge *br,
|
||||
if (!mp)
|
||||
goto out;
|
||||
|
||||
- setup_timer(&mp->timer, br_multicast_group_expired, (unsigned long)mp);
|
||||
mod_timer(&mp->timer, now + br->multicast_membership_interval);
|
||||
mp->timer_armed = true;
|
||||
|
||||
--
|
||||
cgit v0.9.2
|
@ -1703,6 +1703,7 @@ CONFIG_WL1251=m
|
||||
CONFIG_WL1251_SPI=m
|
||||
CONFIG_WL1251_SDIO=m
|
||||
|
||||
CONFIG_RTL_CARDS=m
|
||||
CONFIG_RTLWIFI=m
|
||||
CONFIG_RTL8192CE=m
|
||||
CONFIG_RTL8192SE=m
|
||||
@ -3551,7 +3552,7 @@ CONFIG_USB_SERIAL_DEBUG=m
|
||||
CONFIG_USB_SERIAL_SSU100=m
|
||||
CONFIG_USB_SERIAL_QT2=m
|
||||
CONFIG_USB_SERIAL_FLASHLOADER=m
|
||||
|
||||
CONFIG_USB_SERIAL_SUUNTO=m
|
||||
CONFIG_USB_SERIAL_CONSOLE=y
|
||||
|
||||
CONFIG_USB_EZUSB=y
|
||||
|
@ -1,53 +0,0 @@
|
||||
From patchwork Fri Apr 26 05:03:10 2013
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: drm/exynos: fix multiple definition build error
|
||||
Date: Fri, 26 Apr 2013 05:03:10 -0000
|
||||
From: Inki Dae <inki.dae@samsung.com>
|
||||
X-Patchwork-Id: 2490831
|
||||
Message-Id: <1366952590-11652-1-git-send-email-inki.dae@samsung.com>
|
||||
To: airlied@linux.ie, dri-devel@lists.freedesktop.org
|
||||
Cc: kyungmin.park@samsung.com, sw0312.kim@samsung.com
|
||||
|
||||
This patch fixes multiple definition error like below when building it
|
||||
as moudle with device tree support.
|
||||
|
||||
drivers/gpu/drm/exynos/exynos_drm_g2d.o: In function `.LANCHOR1':
|
||||
exynos_drm_g2d.c:(.rodata+0x6c): multiple definition of `__mod_of_device_table'
|
||||
drivers/gpu/drm/exynos/exynos_drm_fimd.o:exynos_drm_fimd.c:(.rodata+0x144): first defined here
|
||||
|
||||
Signed-off-by: Inki Dae <inki.dae@samsung.com>
|
||||
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
|
||||
|
||||
---
|
||||
drivers/gpu/drm/exynos/exynos_drm_fimd.c | 2 +-
|
||||
drivers/gpu/drm/exynos/exynos_drm_g2d.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/drm/exynos/exynos_drm_fimd.c b/drivers/gpu/drm/exynos/exynos_drm_fimd.c
|
||||
index 746b282..1e02d13 100644
|
||||
--- a/drivers/gpu/drm/exynos/exynos_drm_fimd.c
|
||||
+++ b/drivers/gpu/drm/exynos/exynos_drm_fimd.c
|
||||
@@ -117,7 +117,7 @@ static const struct of_device_id fimd_driver_dt_match[] = {
|
||||
.data = &exynos5_fimd_driver_data },
|
||||
{},
|
||||
};
|
||||
-MODULE_DEVICE_TABLE(of, fimd_driver_dt_match);
|
||||
+MODULE_DEVICE_TABLE(of_fimd, fimd_driver_dt_match);
|
||||
#endif
|
||||
|
||||
static inline struct fimd_driver_data *drm_fimd_get_driver_data(
|
||||
diff --git a/drivers/gpu/drm/exynos/exynos_drm_g2d.c b/drivers/gpu/drm/exynos/exynos_drm_g2d.c
|
||||
index 47a493c..6a01ff1 100644
|
||||
--- a/drivers/gpu/drm/exynos/exynos_drm_g2d.c
|
||||
+++ b/drivers/gpu/drm/exynos/exynos_drm_g2d.c
|
||||
@@ -1525,7 +1525,7 @@ static const struct of_device_id exynos_g2d_match[] = {
|
||||
{ .compatible = "samsung,exynos5250-g2d" },
|
||||
{},
|
||||
};
|
||||
-MODULE_DEVICE_TABLE(of, exynos_g2d_match);
|
||||
+MODULE_DEVICE_TABLE(of_g2d, exynos_g2d_match);
|
||||
#endif
|
||||
|
||||
struct platform_driver g2d_driver = {
|
@ -1,32 +0,0 @@
|
||||
From 7b29fdb8cd8f92e31f550611a8c031986dba2e8f Mon Sep 17 00:00:00 2001
|
||||
From: Johannes Berg <johannes.berg@intel.com>
|
||||
Date: Fri, 03 May 2013 16:58:16 +0000
|
||||
Subject: iwlwifi: dvm: don't send BT_CONFIG on devices w/o Bluetooth
|
||||
|
||||
The BT_CONFIG command that is sent to the device during
|
||||
startup will enable BT coex unless the module parameter
|
||||
turns it off, but on devices without Bluetooth this may
|
||||
cause problems, as reported in Redhat BZ 885407.
|
||||
|
||||
Fix this by sending the BT_CONFIG command only when the
|
||||
device has Bluetooth.
|
||||
|
||||
Cc: stable@vger.kernel.org
|
||||
Reviewed-by: Emmanuel Grumbach <emmanuel.grumbach@intel.com>
|
||||
Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
|
||||
---
|
||||
diff --git a/drivers/net/wireless/iwlwifi/dvm/main.c b/drivers/net/wireless/iwlwifi/dvm/main.c
|
||||
index 3952ddf..1531a4f 100644
|
||||
--- a/drivers/net/wireless/iwlwifi/dvm/main.c
|
||||
+++ b/drivers/net/wireless/iwlwifi/dvm/main.c
|
||||
@@ -758,7 +758,7 @@ int iwl_alive_start(struct iwl_priv *priv)
|
||||
BT_COEX_PRIO_TBL_EVT_INIT_CALIB2);
|
||||
if (ret)
|
||||
return ret;
|
||||
- } else {
|
||||
+ } else if (priv->lib->bt_params) {
|
||||
/*
|
||||
* default is 2-wire BT coexexistence support
|
||||
*/
|
||||
--
|
||||
cgit v0.9.2
|
19
kernel.spec
19
kernel.spec
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 3
|
||||
# The git snapshot level
|
||||
%define gitrev 1
|
||||
%define gitrev 2
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -693,7 +693,6 @@ Patch15000: nowatchdog-on-virt.patch
|
||||
|
||||
# lpae
|
||||
Patch21001: arm-lpae-ax88796.patch
|
||||
Patch21002: drm-exynos-fix-multiple-definition-build-error.patch
|
||||
Patch21003: arm-dma-amba_pl08x-avoid-64bit-division.patch
|
||||
Patch21004: arm-sound-soc-samsung-dma-avoid-another-64bit-division.patch
|
||||
|
||||
@ -735,9 +734,6 @@ Patch25032: cve-2013-2147-ciss-info-leak.patch
|
||||
|
||||
Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||
|
||||
#rhbz 980254
|
||||
Patch25066: bridge-do-not-call-setup_timer-multiple-times.patch
|
||||
|
||||
#rhbz 977558
|
||||
Patch25055: ath3k-dont-use-stack-memory-for-DMA.patch
|
||||
|
||||
@ -745,9 +741,6 @@ Patch25055: ath3k-dont-use-stack-memory-for-DMA.patch
|
||||
Patch25056: iwl3945-better-skb-management-in-rx-path.patch
|
||||
Patch25057: iwl4965-better-skb-management-in-rx-path.patch
|
||||
|
||||
#rhbz 885407
|
||||
Patch25064: iwlwifi-dvm-dont-send-BT_CONFIG-on-devices-wo-Bluetooth.patch
|
||||
|
||||
#rhbz 979581
|
||||
Patch25069: iwlwifi-dvm-fix-calling-ieee80211_chswitch_done-with-NULL.patch
|
||||
|
||||
@ -1314,7 +1307,6 @@ ApplyPatch debug-bad-pte-modules.patch
|
||||
# ARM
|
||||
#
|
||||
ApplyPatch arm-lpae-ax88796.patch
|
||||
ApplyPatch drm-exynos-fix-multiple-definition-build-error.patch
|
||||
ApplyPatch arm-dma-amba_pl08x-avoid-64bit-division.patch
|
||||
ApplyPatch arm-sound-soc-samsung-dma-avoid-another-64bit-division.patch
|
||||
ApplyPatch arm-omap-load-tfp410.patch
|
||||
@ -1449,9 +1441,6 @@ ApplyPatch cve-2013-2147-ciss-info-leak.patch
|
||||
|
||||
ApplyPatch drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||
|
||||
#rhbz 980254
|
||||
ApplyPatch bridge-do-not-call-setup_timer-multiple-times.patch
|
||||
|
||||
#rhbz 977558
|
||||
ApplyPatch ath3k-dont-use-stack-memory-for-DMA.patch
|
||||
|
||||
@ -1459,9 +1448,6 @@ ApplyPatch ath3k-dont-use-stack-memory-for-DMA.patch
|
||||
ApplyPatch iwl3945-better-skb-management-in-rx-path.patch
|
||||
ApplyPatch iwl4965-better-skb-management-in-rx-path.patch
|
||||
|
||||
#rhbz 885407
|
||||
ApplyPatch iwlwifi-dvm-dont-send-BT_CONFIG-on-devices-wo-Bluetooth.patch
|
||||
|
||||
#rhbz 979581
|
||||
ApplyPatch iwlwifi-dvm-fix-calling-ieee80211_chswitch_done-with-NULL.patch
|
||||
|
||||
@ -2272,6 +2258,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri Aug 02 2013 Josh Boyer <jwboyer@redhat.com> - 3.11.0-0.rc3.git2.1
|
||||
- Linux v3.11-rc3-207-g64ccccf
|
||||
|
||||
* Thu Aug 1 2013 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||
- Minor ARM config update
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user