Add support for BCM20702A0 (rhbz 874791)
This commit is contained in:
parent
6d041dc4e3
commit
c7233c4b7e
43
Bluetooth-Add-support-for-BCM20702A0.patch
Normal file
43
Bluetooth-Add-support-for-BCM20702A0.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
From a5f86c3423428c8e28b6501d0e9c3929ca91f07d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jeff Cook <jeff@deserettechnology.com>
|
||||||
|
Date: Fri, 9 Nov 2012 16:39:48 -0700
|
||||||
|
Subject: [PATCH 2/2] Bluetooth: Add support for BCM20702A0 [0b05, 17b5]
|
||||||
|
|
||||||
|
Vendor-specific ID for BCM20702A0.
|
||||||
|
Support for bluetooth over Asus Wi-Fi GO!, included with Asus P8Z77-V
|
||||||
|
Deluxe.
|
||||||
|
|
||||||
|
T: Bus=07 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
|
||||||
|
D: Ver= 2.00 Cls=ff(vend.) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
|
||||||
|
P: Vendor=0b05 ProdID=17b5 Rev=01.12
|
||||||
|
S: Manufacturer=Broadcom Corp
|
||||||
|
S: Product=BCM20702A0
|
||||||
|
S: SerialNumber=94DBC98AC113
|
||||||
|
C: #Ifs= 4 Cfg#= 1 Atr=e0 MxPwr=0mA
|
||||||
|
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
|
||||||
|
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
|
||||||
|
I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
|
||||||
|
I: If#= 3 Alt= 0 #EPs= 0 Cls=fe(app. ) Sub=01 Prot=01 Driver=(none)
|
||||||
|
|
||||||
|
Cc: stable@vger.kernel.org
|
||||||
|
Signed-off-by: Jeff Cook <jeff@deserettechnology.com>
|
||||||
|
Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
|
||||||
|
---
|
||||||
|
drivers/bluetooth/btusb.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
|
||||||
|
index b167944..6dc44ff 100644
|
||||||
|
--- a/drivers/bluetooth/btusb.c
|
||||||
|
+++ b/drivers/bluetooth/btusb.c
|
||||||
|
@@ -96,6 +96,7 @@ static struct usb_device_id btusb_table[] = {
|
||||||
|
{ USB_DEVICE(0x0c10, 0x0000) },
|
||||||
|
|
||||||
|
/* Broadcom BCM20702A0 */
|
||||||
|
+ { USB_DEVICE(0x0b05, 0x17b5) },
|
||||||
|
{ USB_DEVICE(0x04ca, 0x2003) },
|
||||||
|
{ USB_DEVICE(0x0489, 0xe042) },
|
||||||
|
{ USB_DEVICE(0x413c, 0x8197) },
|
||||||
|
--
|
||||||
|
1.8.0
|
||||||
|
|
11
kernel.spec
11
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 2
|
%global baserelease 3
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -770,6 +770,9 @@ Patch22071: uapi-prefix-fix.patch
|
|||||||
|
|
||||||
Patch22073: perf-uapi-fixes2.patch
|
Patch22073: perf-uapi-fixes2.patch
|
||||||
|
|
||||||
|
#rhbz 874791
|
||||||
|
Patch22125: Bluetooth-Add-support-for-BCM20702A0.patch
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1480,6 +1483,9 @@ ApplyPatch uapi-prefix-fix.patch
|
|||||||
|
|
||||||
ApplyPatch perf-uapi-fixes2.patch
|
ApplyPatch perf-uapi-fixes2.patch
|
||||||
|
|
||||||
|
#rhbz 874791
|
||||||
|
ApplyPatch Bluetooth-Add-support-for-BCM20702A0.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2347,6 +2353,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 20 2012 Josh Boyer <jwboyer@redhat.com>
|
||||||
|
- Add support for BCM20702A0 (rhbz 874791)
|
||||||
|
|
||||||
* Tue Nov 20 2012 Peter Robinson <pbrobinson@fedoraproject.org>
|
* Tue Nov 20 2012 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||||
- Change the minimum mmap address back to 32768 on ARM systems (thanks to Jon Masters)
|
- Change the minimum mmap address back to 32768 on ARM systems (thanks to Jon Masters)
|
||||||
- Add patch to fix unified kernel build failure
|
- Add patch to fix unified kernel build failure
|
||||||
|
Loading…
Reference in New Issue
Block a user