Linux v4.1-rc7-72-gdf5f4158415b
This commit is contained in:
parent
6adde40b1c
commit
c68e8929a1
@ -1,39 +0,0 @@
|
|||||||
From: Peter Hutterer <peter.hutterer@who-t.net>
|
|
||||||
Date: Mon, 8 Jun 2015 10:17:32 -0700
|
|
||||||
Subject: [PATCH] Input: synaptics - add min/max quirk for Lenovo S540
|
|
||||||
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=1223051#c2
|
|
||||||
|
|
||||||
Cc: stable@vger.kernel.org
|
|
||||||
Tested-by: tommy.gagnes@gmail.com
|
|
||||||
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
|
||||||
Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
|
|
||||||
---
|
|
||||||
drivers/input/mouse/synaptics.c | 7 ++++++-
|
|
||||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/input/mouse/synaptics.c b/drivers/input/mouse/synaptics.c
|
|
||||||
index c69b308beb3f..7d5f31fba535 100644
|
|
||||||
--- a/drivers/input/mouse/synaptics.c
|
|
||||||
+++ b/drivers/input/mouse/synaptics.c
|
|
||||||
@@ -151,6 +151,11 @@ static const struct min_max_quirk min_max_pnpid_table[] = {
|
|
||||||
1024, 5112, 2024, 4832
|
|
||||||
},
|
|
||||||
{
|
|
||||||
+ (const char * const []){"LEN2000", NULL},
|
|
||||||
+ {ANY_BOARD_ID, ANY_BOARD_ID},
|
|
||||||
+ 1024, 5113, 2021, 4832
|
|
||||||
+ },
|
|
||||||
+ {
|
|
||||||
(const char * const []){"LEN2001", NULL},
|
|
||||||
{ANY_BOARD_ID, ANY_BOARD_ID},
|
|
||||||
1024, 5022, 2508, 4832
|
|
||||||
@@ -191,7 +196,7 @@ static const char * const topbuttonpad_pnp_ids[] = {
|
|
||||||
"LEN0045",
|
|
||||||
"LEN0047",
|
|
||||||
"LEN0049",
|
|
||||||
- "LEN2000",
|
|
||||||
+ "LEN2000", /* S540 */
|
|
||||||
"LEN2001", /* Edge E431 */
|
|
||||||
"LEN2002", /* Edge E531 */
|
|
||||||
"LEN2003",
|
|
@ -27,10 +27,10 @@ Signed-off-by: Benjamin Tissoires <benjamin.tissoires@redhat.com>
|
|||||||
1 file changed, 8 insertions(+)
|
1 file changed, 8 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/input/mouse/synaptics.c b/drivers/input/mouse/synaptics.c
|
diff --git a/drivers/input/mouse/synaptics.c b/drivers/input/mouse/synaptics.c
|
||||||
index 630af73e98c4..c69b308beb3f 100644
|
index 35c8d0ceabee..7d5f31fba535 100644
|
||||||
--- a/drivers/input/mouse/synaptics.c
|
--- a/drivers/input/mouse/synaptics.c
|
||||||
+++ b/drivers/input/mouse/synaptics.c
|
+++ b/drivers/input/mouse/synaptics.c
|
||||||
@@ -935,6 +935,14 @@ static void synaptics_report_mt_data(struct psmouse *psmouse,
|
@@ -940,6 +940,14 @@ static void synaptics_report_mt_data(struct psmouse *psmouse,
|
||||||
input_report_abs(dev, ABS_MT_PRESSURE, hw[i]->z);
|
input_report_abs(dev, ABS_MT_PRESSURE, hw[i]->z);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -9,7 +9,7 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
|||||||
1 file changed, 21 insertions(+)
|
1 file changed, 21 insertions(+)
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/am335x-bone-common.dtsi b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
diff --git a/arch/arm/boot/dts/am335x-bone-common.dtsi b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
||||||
index 9688dda39e7a..8e3e77f3121f 100644
|
index 853079eb0080..645302a6ada4 100644
|
||||||
--- a/arch/arm/boot/dts/am335x-bone-common.dtsi
|
--- a/arch/arm/boot/dts/am335x-bone-common.dtsi
|
||||||
+++ b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
+++ b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
||||||
@@ -109,6 +109,27 @@
|
@@ -109,6 +109,27 @@
|
||||||
|
@ -8,7 +8,7 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
|||||||
1 file changed, 39 insertions(+)
|
1 file changed, 39 insertions(+)
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/am335x-bone-common.dtsi b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
diff --git a/arch/arm/boot/dts/am335x-bone-common.dtsi b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
||||||
index c3255e0c90aa..1fd496fe1a68 100644
|
index dbb3f4d2bf84..b2e14381dd1c 100644
|
||||||
--- a/arch/arm/boot/dts/am335x-bone-common.dtsi
|
--- a/arch/arm/boot/dts/am335x-bone-common.dtsi
|
||||||
+++ b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
+++ b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
||||||
@@ -81,6 +81,13 @@
|
@@ -81,6 +81,13 @@
|
||||||
|
@ -9,7 +9,7 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
|||||||
1 file changed, 222 insertions(+)
|
1 file changed, 222 insertions(+)
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/am335x-bone-common.dtsi b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
diff --git a/arch/arm/boot/dts/am335x-bone-common.dtsi b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
||||||
index 1fd496fe1a68..9688dda39e7a 100644
|
index b2e14381dd1c..853079eb0080 100644
|
||||||
--- a/arch/arm/boot/dts/am335x-bone-common.dtsi
|
--- a/arch/arm/boot/dts/am335x-bone-common.dtsi
|
||||||
+++ b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
+++ b/arch/arm/boot/dts/am335x-bone-common.dtsi
|
||||||
@@ -95,6 +95,20 @@
|
@@ -95,6 +95,20 @@
|
||||||
@ -222,7 +222,7 @@ index 1fd496fe1a68..9688dda39e7a 100644
|
|||||||
/include/ "tps65217.dtsi"
|
/include/ "tps65217.dtsi"
|
||||||
|
|
||||||
&tps {
|
&tps {
|
||||||
@@ -347,4 +529,44 @@
|
@@ -366,4 +548,44 @@
|
||||||
|
|
||||||
&sham {
|
&sham {
|
||||||
status = "okay";
|
status = "okay";
|
||||||
|
11
kernel.spec
11
kernel.spec
@ -67,7 +67,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 7
|
%define rcrev 7
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 1
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -615,9 +615,6 @@ Patch26219: firmware-Drop-WARN-from-usermodehelper_read_trylock-.patch
|
|||||||
#rhbz 1226743
|
#rhbz 1226743
|
||||||
Patch26221: drm-i915-turn-off-wc-mmaps.patch
|
Patch26221: drm-i915-turn-off-wc-mmaps.patch
|
||||||
|
|
||||||
#rhbz 1223051
|
|
||||||
Patch26230: Input-synaptics-add-min-max-quirk-for-Lenovo-S540.patch
|
|
||||||
|
|
||||||
# CVE-2015-XXXX rhbz 1230770 1230774
|
# CVE-2015-XXXX rhbz 1230770 1230774
|
||||||
Patch26231: kvm-x86-fix-kvm_apic_has_events-to-check-for-NULL-po.patch
|
Patch26231: kvm-x86-fix-kvm_apic_has_events-to-check-for-NULL-po.patch
|
||||||
|
|
||||||
@ -1354,9 +1351,6 @@ ApplyPatch firmware-Drop-WARN-from-usermodehelper_read_trylock-.patch
|
|||||||
#rhbz 1226743
|
#rhbz 1226743
|
||||||
ApplyPatch drm-i915-turn-off-wc-mmaps.patch
|
ApplyPatch drm-i915-turn-off-wc-mmaps.patch
|
||||||
|
|
||||||
#rhbz 1223051
|
|
||||||
ApplyPatch Input-synaptics-add-min-max-quirk-for-Lenovo-S540.patch
|
|
||||||
|
|
||||||
# CVE-2015-XXXX rhbz 1230770 1230774
|
# CVE-2015-XXXX rhbz 1230770 1230774
|
||||||
ApplyPatch kvm-x86-fix-kvm_apic_has_events-to-check-for-NULL-po.patch
|
ApplyPatch kvm-x86-fix-kvm_apic_has_events-to-check-for-NULL-po.patch
|
||||||
|
|
||||||
@ -2224,6 +2218,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 12 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc7.git1.1
|
||||||
|
- Linux v4.1-rc7-72-gdf5f4158415b
|
||||||
|
|
||||||
* Fri Jun 12 2015 Josh Boyer <jwboyer@fedoraproject.org>
|
* Fri Jun 12 2015 Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
- CVE-2015-XXXX kvm: NULL ptr deref in kvm_apic_has_events (rhbz 1230770 1230774)
|
- CVE-2015-XXXX kvm: NULL ptr deref in kvm_apic_has_events (rhbz 1230770 1230774)
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1,3 +1,4 @@
|
|||||||
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
|
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
|
||||||
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
|
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
|
||||||
a831062aea035ee4bae52e59ccf0cf71 patch-4.1-rc7.xz
|
a831062aea035ee4bae52e59ccf0cf71 patch-4.1-rc7.xz
|
||||||
|
cfa3119ee9aa2f468cf6dc37db9f9354 patch-4.1-rc7-git1.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user