Revert OL modifications
This commit is contained in:
parent
2f7bd90ae5
commit
c5f748282b
2
.gitignore
vendored
2
.gitignore
vendored
@ -2,8 +2,6 @@ SOURCES/kernel-abi-stablelists-5.14.0-427.31.1.el9_4.tar.bz2
|
||||
SOURCES/kernel-kabi-dw-5.14.0-427.31.1.el9_4.tar.bz2
|
||||
SOURCES/linux-5.14.0-427.31.1.el9_4.tar.xz
|
||||
SOURCES/nvidiagpuoot001.x509
|
||||
SOURCES/olima1.x509
|
||||
SOURCES/olimaca1.x509
|
||||
SOURCES/rheldup3.x509
|
||||
SOURCES/rhelima.x509
|
||||
SOURCES/rhelima_centos.x509
|
||||
|
@ -2,8 +2,6 @@ e702fc158f91cbbc800ce5d7bb717902d3615788 SOURCES/kernel-abi-stablelists-5.14.0-4
|
||||
cff4c079f7c27f4b9a6d0df15efdd1240fd2ec2a SOURCES/kernel-kabi-dw-5.14.0-427.31.1.el9_4.tar.bz2
|
||||
3056b9b862af226d016a75c5112a0a60461fc3db SOURCES/linux-5.14.0-427.31.1.el9_4.tar.xz
|
||||
4fff8080e88afffc06d8ef5004db8d53bb21237f SOURCES/nvidiagpuoot001.x509
|
||||
706ae01dd14efa38f0f565a3706acac19c78df02 SOURCES/olima1.x509
|
||||
6e3f0d61414c0b50f48dc2d4c3b3cd024e1c3a43 SOURCES/olimaca1.x509
|
||||
95b9b811c7b0a6c98b2eafc4e7d6d24f2cb63289 SOURCES/rheldup3.x509
|
||||
99e571f9de4188f3b5fdf1f84ff73f6cc4bb6a0e SOURCES/rhelima.x509
|
||||
61d5a223ff0c79189505abae77e0087c4b2d2b47 SOURCES/rhelima_centos.x509
|
||||
|
@ -1,59 +0,0 @@
|
||||
From 6ca79c451f7508fc1916113fd0cdba2140c14818 Mon Sep 17 00:00:00 2001
|
||||
From: Louis Abel <label@rockylinux.org>
|
||||
Date: Wed, 20 Sep 2023 14:16:05 -0700
|
||||
Subject: [PATCH] debrand some messages
|
||||
|
||||
Modified-by: Alex Burmashev <alexander.burmashev@oracle.com>
|
||||
---
|
||||
kernel/rh_shadowman.c | 55 ++++++++++++++++++++++---------------------
|
||||
4 files changed, 34 insertions(+), 33 deletions(-)
|
||||
|
||||
diff --git a/kernel/rh_shadowman.c b/kernel/rh_shadowman.c
|
||||
index 018d5c633..d05ea0790 100644
|
||||
--- a/kernel/rh_shadowman.c
|
||||
+++ b/kernel/rh_shadowman.c
|
||||
@@ -1,39 +1 @@
|
||||
-#include <linux/kernel.h>
|
||||
-#include <linux/module.h>
|
||||
-#include <linux/printk.h>
|
||||
-
|
||||
-/* Display a shadowman logo on the console screen */
|
||||
-static int __init rh_shadowman(char *str)
|
||||
-{
|
||||
- pr_info("RRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRRRRRRRRrrrrrrrrrrrrrrrORHRrrHRRRRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRRRRRRHrr8rrrrrrrrrrrrrrrrrrrrhRRRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRHRRRRRRRRRRRrrHRHRRRHHHrrrrrrrrrrrrrHRRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRRRRRHrrrrrHrrrrrrrrrrrrrrrrrrrrRRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRHh88hhRHrrrrrrrrrrrrrrrrrrrrrrrrrrHRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRrrrrrrrrrRHRH8rrrrrrrrrrrrrrrrrrrrrrr8RRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRH8rrrrrrrrrrRHRRRRRRRRRHrrrrrrrrrrrrrrrrRrhHRHRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRROrrrrrrrrrrrORRRRRRRRRRRrrrrrrrrrrrrrHrrrrrrhRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRROrrrrrrrrrrrrrrr8RRRRHRrrrrrrrrrrrrrrrrrrrrrHRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRRRHhrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRRH. .HHHrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRR. .RRhRRHH8rrrrrrrrrrrrrrrrrrrrr8RRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRRR~ .RRRRRRRRRHHh8OOOOO8HRRHRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("R,```` RRR8 .hHRRRh\\hHH:=HRh.RRRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RR ORRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRR ,HHtaa HRRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRO. .RRRRO. . .RRRRRRR\n");
|
||||
- pr_info("RRRRRR ,RRHh, :RRRRRRRR\n");
|
||||
- pr_info("RRRRRRRR HRR :RRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRr .. ,RRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRRRt . .HRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRRRRRRRr. =RRRRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info("RRRRRRRRRRRRRRRRRRRRRRRRHHr: .:tRhRRRRRRRRRRRRRRRRRRRRRRRRRR\n");
|
||||
- pr_info(" ");
|
||||
- pr_info(" Long Live Shadowman!");
|
||||
- pr_info("576527726520686972696e6721a68747470733a2f2f7777772e7265646861742e636f6d2f6a6f6273");
|
||||
- pr_info(" ");
|
||||
- return 1;
|
||||
-}
|
||||
-
|
||||
-__setup("shadowman", rh_shadowman);
|
||||
+// This file has been intentionally left blank
|
||||
--
|
||||
2.41.0
|
||||
|
||||
|
@ -1,19 +0,0 @@
|
||||
Update message about certified hardware list.
|
||||
|
||||
Orabug: 34729535
|
||||
|
||||
Signed-off-by: Kevin Lyons <kevin.x.lyons@oracle.com>
|
||||
Reviewed-by: Laurence Rochfort <laurence.rochfort@oracle.com>
|
||||
---
|
||||
diff -ruN linux-5.14.0-160.el8.x86_64.orig/init/main.c linux-5.14.0-160.el8.x86_64/init/main.c
|
||||
--- linux-5.14.0-160.el8.x86_64.orig/init/main.c 2022-08-25 13:57:06.000000000 -0700
|
||||
+++ linux-5.14.0-160.el8.x86_64/init/main.c 2022-10-26 13:15:39.700724777 -0700
|
||||
@@ -936,7 +936,7 @@
|
||||
boot_cpu_init();
|
||||
page_address_init();
|
||||
pr_notice("%s", linux_banner);
|
||||
- pr_notice("The list of certified hardware and cloud instances for Red Hat Enterprise Linux 9 can be viewed at the Red Hat Ecosystem Catalog, https://catalog.redhat.com.\n");
|
||||
+ pr_notice("The list of certified hardware for Oracle Linux 9 can be viewed at the Oracle Linux Certification List https://linux.oracle.com/hardware-certifications\n");
|
||||
early_security_init();
|
||||
setup_arch(&command_line);
|
||||
setup_boot_config();
|
@ -1,24 +0,0 @@
|
||||
-----BEGIN CERTIFICATE-----
|
||||
MIIEETCCAvmgAwIBAgIJANw8y5k9b7SaMA0GCSqGSIb3DQEBCwUAMIGeMQswCQYD
|
||||
VQQGEwJVUzETMBEGA1UECAwKQ2FsaWZvcm5pYTEXMBUGA1UEBwwOUmVkd29vZCBT
|
||||
aG9yZXMxGzAZBgNVBAoMEk9yYWNsZSBDb3Jwb3JhdGlvbjEVMBMGA1UECwwMT3Jh
|
||||
Y2xlIExpbnV4MS0wKwYDVQQDDCRPcmFjbGUgTGludXggUkhDSyBNb2R1bGUgU2ln
|
||||
bmluZyBLZXkwHhcNMTYwNTA5MjMzNjA4WhcNMjYwNTA3MjMzNjA4WjCBnjELMAkG
|
||||
A1UEBhMCVVMxEzARBgNVBAgMCkNhbGlmb3JuaWExFzAVBgNVBAcMDlJlZHdvb2Qg
|
||||
U2hvcmVzMRswGQYDVQQKDBJPcmFjbGUgQ29ycG9yYXRpb24xFTATBgNVBAsMDE9y
|
||||
YWNsZSBMaW51eDEtMCsGA1UEAwwkT3JhY2xlIExpbnV4IFJIQ0sgTW9kdWxlIFNp
|
||||
Z25pbmcgS2V5MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAl6bUDNNZ
|
||||
jIqgsqgspwBIQ18keDxQeGnWgubZZhHrQU3GpeSRPM4lNTHc+UjMjNXrv/CENZdv
|
||||
4cETRsxT1VFhGG3CvkbQdzc8v4JOQvWSSJqmViPa1eC+yGaMRnGcFXzKsHiTLA4y
|
||||
WMjpJnVowFkwTzscRBlN0AysUg/hT/74DE0oqVnlCJNynqccNWpx8MtNRD55ay9A
|
||||
73yJinYES14rXcU3QbJoO0ZxtRz83ZACDUGX0GORT3+NbB0RK0sttogzA3eLvxKw
|
||||
umWsWZAHmTuHdWgUjSqqZr34VNLPVcsTHAW8X4bq6rRVcB2lMJ3kJfDP8BJyTn99
|
||||
37UmA+/ld47cnwIDAQABo1AwTjAdBgNVHQ4EFgQU3ZlbFVwZs6fD73cHuWniX5Y5
|
||||
Zm4wHwYDVR0jBBgwFoAU3ZlbFVwZs6fD73cHuWniX5Y5Zm4wDAYDVR0TBAUwAwEB
|
||||
/zANBgkqhkiG9w0BAQsFAAOCAQEAF7nfhWfsk4uEDquLj7nJE0wPlVvllVDugzOk
|
||||
R15pnQ7P+HTyz3sLaLJE4N5oWt6pFzDGDYEtPeoMCn1l447tX179Nf5SMZba9ut8
|
||||
3Vxbe7jAn9sQO7ArQR1swf1r101Me4+1oHq7rxPRizOOXrKeEvf5NSAUbSzzXfz6
|
||||
TEp21KTIQO7MjqpsKshRQbpPeiReaYy3A6gJftun5xekP04QTLZVBR4dL7tvZf0S
|
||||
y9SjVg158lONXHfjBekyYTzSFBn/7v+AS8S+cAGRfYteE0Syxl7zJt3GUoEWau/e
|
||||
kXHT+hd/hkdSQKZZWZo1380M1pVZZAvntLRBU6IN9SswafhiVg==
|
||||
-----END CERTIFICATE-----
|
@ -5,9 +5,9 @@ prompt = no
|
||||
x509_extensions = myexts
|
||||
|
||||
[ req_distinguished_name ]
|
||||
O = Oracle America, Inc.,c=US
|
||||
CN = Oracle CA Server
|
||||
emailAddress = support@oracle.com
|
||||
O = Red Hat
|
||||
CN = Red Hat Enterprise Linux kernel signing key
|
||||
emailAddress = secalert@redhat.com
|
||||
|
||||
[ myexts ]
|
||||
basicConstraints=critical,CA:FALSE
|
||||
|
68
SPECS/kernel.spec
Executable file → Normal file
68
SPECS/kernel.spec
Executable file → Normal file
@ -104,7 +104,7 @@ Summary: The Linux kernel
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
%else
|
||||
%define secure_boot_arch x86_64 s390x ppc64le
|
||||
%define secure_boot_arch x86_64 aarch64 s390x ppc64le
|
||||
%endif
|
||||
|
||||
# Signing for secure boot authentication
|
||||
@ -645,9 +645,6 @@ Requires: kernel-modules-core-uname-r = %{KVERREL}
|
||||
Provides: installonlypkg(kernel)
|
||||
%endif
|
||||
|
||||
Provides: oracle(kernel-sig-key) == 202204
|
||||
Conflicts: shim-ia32 <= 15.3-1.0.5.el9
|
||||
Conflicts: shim-x64 <= 15.3-1.0.5.el9
|
||||
|
||||
#
|
||||
# List the packages used during the kernel build
|
||||
@ -794,6 +791,8 @@ BuildRequires: WALinuxAgent-cvm
|
||||
# For UKI sb cert
|
||||
%if 0%{?centos}
|
||||
BuildRequires: centos-sb-certs >= 9.0-23
|
||||
%else
|
||||
BuildRequires: redhat-sb-certs >= 9.4-0.1
|
||||
%endif
|
||||
%endif
|
||||
|
||||
@ -809,10 +808,30 @@ Source1: Makefile.rhelver
|
||||
|
||||
%if %{signkernel}
|
||||
|
||||
# Name of the packaged file containing signing key
|
||||
%ifarch ppc64le
|
||||
%define signing_key_filename kernel-signing-ppc.cer
|
||||
%endif
|
||||
%ifarch s390x
|
||||
%define signing_key_filename kernel-signing-s390.cer
|
||||
%endif
|
||||
|
||||
%define secureboot_ca_0 %{_datadir}/pki/sb-certs/secureboot-ca-%{_arch}.cer
|
||||
%define secureboot_key_0 %{_datadir}/pki/sb-certs/secureboot-kernel-%{_arch}.cer
|
||||
|
||||
%define pesign_name_0 OracleSecureBootkernelsigningkey2
|
||||
%if 0%{?centos}
|
||||
%define pesign_name_0 centossecureboot201
|
||||
%else
|
||||
%ifarch x86_64 aarch64
|
||||
%define pesign_name_0 redhatsecureboot501
|
||||
%endif
|
||||
%ifarch s390x
|
||||
%define pesign_name_0 redhatsecureboot302
|
||||
%endif
|
||||
%ifarch ppc64le
|
||||
%define pesign_name_0 redhatsecureboot701
|
||||
%endif
|
||||
%endif
|
||||
|
||||
# signkernel
|
||||
%endif
|
||||
@ -897,20 +916,14 @@ Source102: rhelimaca1.x509
|
||||
Source103: rhelima.x509
|
||||
Source104: rhelima_centos.x509
|
||||
Source105: nvidiagpuoot001.x509
|
||||
# Oracle Linux IMA CA certificate
|
||||
Source106: olimaca1.x509
|
||||
# Oracle Linux IMA signing certificate
|
||||
Source107: olima1.x509
|
||||
|
||||
%if 0%{?centos}
|
||||
%define ima_signing_cert %{SOURCE104}
|
||||
%else
|
||||
%define ima_signing_cert %{SOURCE103}
|
||||
%define ima_signing_cert_ol %{SOURCE107}
|
||||
%endif
|
||||
|
||||
%define ima_cert_name ima.cer
|
||||
%define ima_cert_name_ol ima_ol.cer
|
||||
|
||||
Source150: dracut-virt.conf
|
||||
|
||||
@ -947,9 +960,6 @@ Source4000: README.rst
|
||||
Source4001: rpminspect.yaml
|
||||
Source4002: gating.yaml
|
||||
|
||||
# Oracle Linux RHCK Module Signing Key
|
||||
Source5001: olkmod_signing_key.pem
|
||||
|
||||
## Patches needed for building this package
|
||||
|
||||
%if !%{nopatches}
|
||||
@ -957,12 +967,8 @@ Source5001: olkmod_signing_key.pem
|
||||
Patch1: patch-%{patchversion}-redhat.patch
|
||||
%endif
|
||||
|
||||
# Oracle patches
|
||||
Patch1000: bug34729535-change-certified-hw-message.patch
|
||||
|
||||
# empty final patch to facilitate testing of kernel patches
|
||||
Patch999999: linux-kernel-test.patch
|
||||
Patch1000000: 1000-debrand-some-messages.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
@ -1690,7 +1696,6 @@ cp -a %{SOURCE1} .
|
||||
ApplyOptionalPatch patch-%{patchversion}-redhat.patch
|
||||
%endif
|
||||
|
||||
ApplyPatch bug34729535-change-certified-hw-message.patch
|
||||
ApplyOptionalPatch linux-kernel-test.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
@ -1770,11 +1775,6 @@ openssl x509 -inform der -in %{SOURCE101} -out rhelkpatch1.pem
|
||||
openssl x509 -inform der -in %{SOURCE102} -out rhelimaca1.pem
|
||||
openssl x509 -inform der -in %{SOURCE105} -out nvidiagpuoot001.pem
|
||||
cat rheldup3.pem rhelkpatch1.pem rhelimaca1.pem nvidiagpuoot001.pem > ../certs/rhel.pem
|
||||
# Add Oracle Linux IMA CA certificate to the kernel trusted certificates list
|
||||
openssl x509 -inform der -in %{SOURCE106} -out olimaca1.pem
|
||||
cat olimaca1.pem >> ../certs/rhel.pem
|
||||
# Add olkmod_signing_key.pem to the kernel trusted certificates list
|
||||
cat %{SOURCE5001} >> ../certs/rhel.pem
|
||||
%if %{signkernel}
|
||||
%ifarch s390x ppc64le
|
||||
openssl x509 -inform der -in %{secureboot_ca_0} -out secureboot.pem
|
||||
@ -2442,11 +2442,8 @@ BuildKernel() {
|
||||
%endif
|
||||
SBAT=$(cat <<- EOF
|
||||
linux,1,Red Hat,linux,$KernelVer,mailto:secalert@redhat.com
|
||||
linux,1,Oracle Linux,linux,$KernelVer,mailto:secalert_us@oracle.com
|
||||
linux.$SBATsuffix,1,Red Hat,linux,$KernelVer,mailto:secalert@redhat.com
|
||||
linux.ol,1,Oracle Linux,linux,$KernelVer,mailto:secalert_us@oracle.com
|
||||
kernel-uki-virt.$SBATsuffix,1,Red Hat,kernel-uki-virt,$KernelVer,mailto:secalert@redhat.com
|
||||
kernel-uki-virt.ol,1,Oracle Linux,kernel-uki-virt,$KernelVer,mailto:secalert_us@oracle.com
|
||||
EOF
|
||||
)
|
||||
|
||||
@ -2468,7 +2465,7 @@ BuildKernel() {
|
||||
$KernelUnifiedImage
|
||||
|
||||
%if %{signkernel}
|
||||
%if ! %{?oraclelinux}
|
||||
|
||||
%if 0%{?centos}
|
||||
UKI_secureboot_name=centossecureboot204
|
||||
%else
|
||||
@ -2484,7 +2481,6 @@ BuildKernel() {
|
||||
mv $KernelUnifiedImage.signed $KernelUnifiedImage
|
||||
|
||||
# signkernel
|
||||
%endif
|
||||
%endif
|
||||
|
||||
pushd $RPM_BUILD_ROOT
|
||||
@ -2562,7 +2558,7 @@ BuildKernel() {
|
||||
# prune junk from kernel-devel
|
||||
find $RPM_BUILD_ROOT/usr/src/kernels -name ".*.cmd" -delete
|
||||
|
||||
# UEFI Secure Boot CA cert, which can be used to authenticate the kernel
|
||||
# Red Hat UEFI Secure Boot CA cert, which can be used to authenticate the kernel
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer
|
||||
%if %{signkernel}
|
||||
install -m 0644 %{secureboot_ca_0} $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/kernel-signing-ca.cer
|
||||
@ -2576,8 +2572,6 @@ BuildKernel() {
|
||||
%if 0%{?rhel}
|
||||
# Red Hat IMA code-signing cert, which is used to authenticate package files
|
||||
install -m 0644 %{ima_signing_cert} $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/%{ima_cert_name}
|
||||
# Oracle Linux IMA signing cert
|
||||
install -m 0644 %{ima_signing_cert_ol} $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer/%{ima_cert_name_ol}
|
||||
%endif
|
||||
|
||||
%if %{signmodules}
|
||||
@ -3738,16 +3732,6 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Wed Aug 14 2024 Darren Archibald <darren.archibald@oracle.com> [5.14.0-427.31.1.el9_4.OL9]
|
||||
- Disable UKI signing [Orabug: 36571828]
|
||||
- Update Oracle Linux certificates (Kevin Lyons)
|
||||
- Disable signing for aarch64 (Ilya Okomin)
|
||||
- Oracle Linux RHCK Module Signing Key was added to the kernel trusted keys list (olkmod_signing_key.pem) [Orabug: 29539237]
|
||||
- Update x509.genkey [Orabug: 24817676]
|
||||
- Conflict with shim-ia32 and shim-x64 <= 15.3-1.0.5.el9
|
||||
- Remove upstream reference during boot (Kevin Lyons) [Orabug: 34729535]
|
||||
- Add Oracle Linux IMA certificates
|
||||
|
||||
* Fri Aug 09 2024 Scott Weaver <scweaver@redhat.com> [5.14.0-427.31.1.el9_4]
|
||||
- net: fix __dst_negative_advice() race (CKI Backport Bot) [RHEL-46798] {CVE-2024-36971}
|
||||
- net: annotate data-races around sk->sk_dst_pending_confirm (CKI Backport Bot) [RHEL-46798] {CVE-2024-36971}
|
||||
|
Loading…
Reference in New Issue
Block a user