3.1-rc2-git5 snapshot
Make XHCI builtin, add a patch to fix a race in the crypto framework
This commit is contained in:
parent
02587b4efa
commit
c3c2b77d29
@ -3126,7 +3126,7 @@ CONFIG_USB_SL811_HCD=m
|
||||
CONFIG_USB_SL811_HCD_ISO=y
|
||||
# CONFIG_USB_SL811_CS is not set
|
||||
# CONFIG_USB_R8A66597_HCD is not set
|
||||
CONFIG_USB_XHCI_HCD=m
|
||||
CONFIG_USB_XHCI_HCD=y
|
||||
# CONFIG_USB_XHCI_HCD_DEBUGGING is not set
|
||||
CONFIG_USB_ISP1362_HCD=m
|
||||
|
||||
|
26
crypto-register-cryptd-first.patch
Normal file
26
crypto-register-cryptd-first.patch
Normal file
@ -0,0 +1,26 @@
|
||||
commit 9d4c522a113f6caa8b792ae829a25490fa87b1a2
|
||||
Author: Herbert Xu <herbert@gondor.apana.org.au>
|
||||
Date: Fri Aug 19 16:11:23 2011 +0800
|
||||
|
||||
crypto: cryptd - Use subsys_initcall to prevent races with aesni
|
||||
|
||||
As cryptd is depeneded on by other algorithms such as aesni-intel,
|
||||
it needs to be registered before them. When everything is built
|
||||
as modules, this occurs naturally. However, for this to work when
|
||||
they are built-in, we need to use subsys_initcall in cryptd.
|
||||
|
||||
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
|
||||
|
||||
diff --git a/crypto/cryptd.c b/crypto/cryptd.c
|
||||
index e46d21a..671d4d6 100644
|
||||
--- a/crypto/cryptd.c
|
||||
+++ b/crypto/cryptd.c
|
||||
@@ -945,7 +945,7 @@ static void __exit cryptd_exit(void)
|
||||
crypto_unregister_template(&cryptd_tmpl);
|
||||
}
|
||||
|
||||
-module_init(cryptd_init);
|
||||
+subsys_initcall(cryptd_init);
|
||||
module_exit(cryptd_exit);
|
||||
|
||||
MODULE_LICENSE("GPL");
|
11
kernel.spec
11
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||
# for example a 3 here will become 0.3
|
||||
#
|
||||
%global baserelease 3
|
||||
%global baserelease 0
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 2
|
||||
# The git snapshot level
|
||||
%define gitrev 4
|
||||
%define gitrev 5
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -719,6 +719,7 @@ Patch12025: rcu-avoid-just-onlined-cpu-resched.patch
|
||||
Patch12026: block-stray-block-put-after-teardown.patch
|
||||
Patch12027: usb-add-quirk-for-logitech-webcams.patch
|
||||
Patch12028: fix-perf-build.patch
|
||||
Patch12029: crypto-register-cryptd-first.patch
|
||||
|
||||
|
||||
# Runtime power management
|
||||
@ -1345,6 +1346,7 @@ ApplyPatch block-stray-block-put-after-teardown.patch
|
||||
ApplyPatch usb-add-quirk-for-logitech-webcams.patch
|
||||
|
||||
ApplyPatch fix-perf-build.patch
|
||||
ApplyPatch crypto-register-cryptd-first.patch
|
||||
|
||||
# Runtime PM
|
||||
#ApplyPatch linux-2.6-usb-pci-autosuspend.patch
|
||||
@ -2070,6 +2072,11 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri Aug 19 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Linux 3.1-rc2-git5
|
||||
- Change XHCI to builtin (rhbz 731706)
|
||||
- Add patch to fix race between cryptd and aesni (rhbz 721002)
|
||||
|
||||
* Thu Aug 18 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Adjust provides/obsoletes to replace the cpupowerutils package
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user