kernel-5.7.0-0.rc6.20200520git115a54162a6c.1
* Wed May 20 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc6.20200520git115a54162a6c.1] - 115a54162a6c rebase - kernel.spec: fix 'make scripts' for kernel-devel package (Brian Masney) - Makefile: correct help text for dist-cross-<arch>-rpms (Brian Masney) - Add Documentation back to kernel-devel as it has Kconfig now ("Justin M. Forbes") - x86: Fix compile issues with rh_check_supported() (Don Zickus) - Updated changelog for the release based on 642b151f45dd ("CKI@GitLab") - redhat: Change Makefile target names to dist- (Prarit Bhargava) - configs: Disable Serial IR driver (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
cd543e686c
commit
bec7366f48
@ -57,7 +57,7 @@ Signed-off-by: Laura Abbott <labbott@redhat.com>
|
||||
1 file changed, 22 insertions(+)
|
||||
|
||||
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
|
||||
index 7b375421afba..d4109b5c9705 100644
|
||||
index 1faa08c8bbb4..b64444b1bd1a 100644
|
||||
--- a/drivers/iommu/iommu.c
|
||||
+++ b/drivers/iommu/iommu.c
|
||||
@@ -7,6 +7,7 @@
|
||||
@ -68,7 +68,7 @@ index 7b375421afba..d4109b5c9705 100644
|
||||
#include <linux/kernel.h>
|
||||
#include <linux/bug.h>
|
||||
#include <linux/types.h>
|
||||
@@ -2659,3 +2660,24 @@ int iommu_sva_get_pasid(struct iommu_sva *handle)
|
||||
@@ -2664,3 +2665,24 @@ int iommu_sva_get_pasid(struct iommu_sva *handle)
|
||||
return ops->sva_get_pasid(handle);
|
||||
}
|
||||
EXPORT_SYMBOL_GPL(iommu_sva_get_pasid);
|
||||
|
61
0001-x86-Fix-compile-issues-with-rh_check_supported.patch
Normal file
61
0001-x86-Fix-compile-issues-with-rh_check_supported.patch
Normal file
@ -0,0 +1,61 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Don Zickus <dzickus@redhat.com>
|
||||
Date: Thu, 14 May 2020 10:30:51 -0400
|
||||
Subject: [PATCH] x86: Fix compile issues with rh_check_supported()
|
||||
|
||||
Upstream status: RHEL only
|
||||
|
||||
The function rh_check_supported is a RHEL function to limit the
|
||||
platforms RHEL does not want to support.
|
||||
|
||||
To avoid imposing this requirement on Fedora, the function was
|
||||
wrapped with CONFIG_RHEL_DIFFERENCES so Fedora can disable this.
|
||||
|
||||
However, this has a few compile warnings that need to be cleaned up
|
||||
when disabled.
|
||||
|
||||
Move CONFIG_RHEL_DIFFERENCES to include the functions themselves
|
||||
instead of the call. As the unused functions created warnings.
|
||||
|
||||
V2: modified stub definition
|
||||
|
||||
Signed-off-by: Don Zickus <dzickus@redhat.com>
|
||||
---
|
||||
arch/x86/kernel/setup.c | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
||||
index 0fd824c4162d..a7bf9730a2ca 100644
|
||||
--- a/arch/x86/kernel/setup.c
|
||||
+++ b/arch/x86/kernel/setup.c
|
||||
@@ -750,6 +750,7 @@ static void __init trim_low_memory_range(void)
|
||||
memblock_reserve(0, ALIGN(reserve_low, PAGE_SIZE));
|
||||
}
|
||||
|
||||
+#ifdef CONFIG_RHEL_DIFFERENCES
|
||||
static bool valid_amd_processor(__u8 family, const char *model_id)
|
||||
{
|
||||
bool valid;
|
||||
@@ -874,6 +875,9 @@ static void rh_check_supported(void)
|
||||
if (acpi_disabled && !guest)
|
||||
pr_crit("ACPI has been disabled or is not available on this hardware. This may result in a single cpu boot, incorrect PCI IRQ routing, or boot failure.\n");
|
||||
}
|
||||
+#else
|
||||
+#define rh_check_supported()
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* Dump out kernel offset information on panic.
|
||||
@@ -1366,9 +1370,7 @@ void __init setup_arch(char **cmdline_p)
|
||||
efi_apply_memmap_quirks();
|
||||
#endif
|
||||
|
||||
-#ifdef CONFIG_RHEL_DIFFERENCES
|
||||
rh_check_supported();
|
||||
-#endif
|
||||
|
||||
unwind_init();
|
||||
}
|
||||
--
|
||||
2.26.2
|
||||
|
@ -74,3 +74,4 @@
|
||||
0001-e1000e-bump-up-timeout-to-wait-when-ME-un-configure-.patch
|
||||
0001-perf-cs-etm-Move-defined-of-traceid_list.patch
|
||||
0001-pwm-lpss-Fix-get_state-runtime-pm-reference-handling.patch
|
||||
0001-x86-Fix-compile-issues-with-rh_check_supported.patch
|
||||
|
@ -2939,7 +2939,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2391,7 +2391,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
# CONFIG_IR_RCMM_DECODER is not set
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
# CONFIG_IR_SHARP_DECODER is not set
|
||||
CONFIG_IR_SIR=m
|
||||
|
@ -2923,7 +2923,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2375,7 +2375,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
# CONFIG_IR_RCMM_DECODER is not set
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
# CONFIG_IR_SHARP_DECODER is not set
|
||||
CONFIG_IR_SIR=m
|
||||
|
@ -2969,7 +2969,7 @@ CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
# CONFIG_IR_RX51 is not set
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2954,7 +2954,7 @@ CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
# CONFIG_IR_RX51 is not set
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2901,7 +2901,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2886,7 +2886,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2676,7 +2676,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2659,7 +2659,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2424,7 +2424,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2264,7 +2264,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
# CONFIG_IR_RCMM_DECODER is not set
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
# CONFIG_IR_SHARP_DECODER is not set
|
||||
CONFIG_IR_SIR=m
|
||||
|
@ -2407,7 +2407,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2248,7 +2248,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
# CONFIG_IR_RCMM_DECODER is not set
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
# CONFIG_IR_SHARP_DECODER is not set
|
||||
CONFIG_IR_SIR=m
|
||||
|
@ -2400,7 +2400,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2237,7 +2237,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
# CONFIG_IR_RCMM_DECODER is not set
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
# CONFIG_IR_SHARP_DECODER is not set
|
||||
CONFIG_IR_SIR=m
|
||||
|
@ -2383,7 +2383,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2221,7 +2221,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
# CONFIG_IR_RCMM_DECODER is not set
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
# CONFIG_IR_SHARP_DECODER is not set
|
||||
CONFIG_IR_SIR=m
|
||||
|
@ -2240,7 +2240,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
# CONFIG_IR_RCMM_DECODER is not set
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
# CONFIG_IR_SHARP_DECODER is not set
|
||||
CONFIG_IR_SIR=m
|
||||
|
@ -2723,7 +2723,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2428,7 +2428,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
# CONFIG_IR_RCMM_DECODER is not set
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
# CONFIG_IR_SHARP_DECODER is not set
|
||||
CONFIG_IR_SIR=m
|
||||
|
@ -2706,7 +2706,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
CONFIG_IR_RCMM_DECODER=m
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
CONFIG_IR_SHARP_DECODER=m
|
||||
# CONFIG_IR_SIR is not set
|
||||
|
@ -2412,7 +2412,7 @@ CONFIG_IR_RC6_DECODER=m
|
||||
# CONFIG_IR_RCMM_DECODER is not set
|
||||
CONFIG_IR_REDRAT3=m
|
||||
CONFIG_IR_SANYO_DECODER=m
|
||||
CONFIG_IR_SERIAL=m
|
||||
# CONFIG_IR_SERIAL is not set
|
||||
CONFIG_IR_SERIAL_TRANSMITTER=y
|
||||
# CONFIG_IR_SHARP_DECODER is not set
|
||||
CONFIG_IR_SIR=m
|
||||
|
34
kernel.spec
34
kernel.spec
@ -30,7 +30,7 @@ Summary: The Linux kernel
|
||||
# For a stable, released kernel, released_kernel should be 1.
|
||||
%global released_kernel 0
|
||||
|
||||
%global distro_build 0.rc6.20200519git642b151f45dd.1
|
||||
%global distro_build 0.rc6.20200520git115a54162a6c.1
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -69,10 +69,10 @@ Summary: The Linux kernel
|
||||
%endif
|
||||
|
||||
%define rpmversion 5.7.0
|
||||
%define pkgrelease 0.rc6.20200519git642b151f45dd.1
|
||||
%define pkgrelease 0.rc6.20200520git115a54162a6c.1
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc6.20200519git642b151f45dd.1%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc6.20200520git115a54162a6c.1%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -564,7 +564,7 @@ BuildRequires: asciidoc
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-20200519git642b151f45dd.tar.xz
|
||||
Source0: linux-20200520git115a54162a6c.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -779,6 +779,7 @@ Patch74: 0001-arm64-allwinner-dts-a64-add-LCD-related-device-nodes.patch
|
||||
Patch75: 0001-e1000e-bump-up-timeout-to-wait-when-ME-un-configure-.patch
|
||||
Patch76: 0001-perf-cs-etm-Move-defined-of-traceid_list.patch
|
||||
Patch77: 0001-pwm-lpss-Fix-get_state-runtime-pm-reference-handling.patch
|
||||
Patch78: 0001-x86-Fix-compile-issues-with-rh_check_supported.patch
|
||||
|
||||
%endif
|
||||
|
||||
@ -1274,8 +1275,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-20200519git642b151f45dd -c
|
||||
mv linux-20200519git642b151f45dd linux-%{KVERREL}
|
||||
%setup -q -n kernel-20200520git115a54162a6c -c
|
||||
mv linux-20200520git115a54162a6c linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -1358,6 +1359,7 @@ ApplyOptionalPatch 0001-arm64-allwinner-dts-a64-add-LCD-related-device-nodes.pat
|
||||
ApplyOptionalPatch 0001-e1000e-bump-up-timeout-to-wait-when-ME-un-configure-.patch
|
||||
ApplyOptionalPatch 0001-perf-cs-etm-Move-defined-of-traceid_list.patch
|
||||
ApplyOptionalPatch 0001-pwm-lpss-Fix-get_state-runtime-pm-reference-handling.patch
|
||||
ApplyOptionalPatch 0001-x86-Fix-compile-issues-with-rh_check_supported.patch
|
||||
|
||||
%endif
|
||||
|
||||
@ -1758,13 +1760,21 @@ BuildKernel() {
|
||||
%endif
|
||||
|
||||
# then drop all but the needed Makefiles/Kconfig files
|
||||
rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
|
||||
rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
|
||||
rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
|
||||
cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/tracing
|
||||
rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/spdxcheck.py
|
||||
|
||||
# Files for 'make scripts' to succeed with kernel-devel.
|
||||
mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/security/selinux/include
|
||||
cp -a --parents security/selinux/include/classmap.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents security/selinux/include/initial_sid_to_string.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/tools/include/tools
|
||||
cp -a --parents tools/include/tools/be_byteshift.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/include/tools/le_byteshift.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
|
||||
if [ -f tools/objtool/objtool ]; then
|
||||
cp -a tools/objtool/objtool $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/tools/objtool/ || :
|
||||
fi
|
||||
@ -2766,6 +2776,16 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Wed May 20 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc6.20200520git115a54162a6c.1]
|
||||
- 115a54162a6c rebase
|
||||
- kernel.spec: fix 'make scripts' for kernel-devel package (Brian Masney)
|
||||
- Makefile: correct help text for dist-cross-<arch>-rpms (Brian Masney)
|
||||
- Add Documentation back to kernel-devel as it has Kconfig now ("Justin M. Forbes")
|
||||
- x86: Fix compile issues with rh_check_supported() (Don Zickus)
|
||||
- Updated changelog for the release based on 642b151f45dd ("CKI@GitLab")
|
||||
- redhat: Change Makefile target names to dist- (Prarit Bhargava)
|
||||
- configs: Disable Serial IR driver (Prarit Bhargava)
|
||||
|
||||
* Tue May 19 2020 CKI@GitLab <cki-project@redhat.com> [5.7.0-0.rc6.20200519git642b151f45dd.1]
|
||||
- 642b151f45dd rebase
|
||||
- pwm: lpss: Fix get_state runtime-pm reference handling (Hans de Goede)
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-20200519git642b151f45dd.tar.xz) = e4710e40f931d6ca21e7f8f77c091df48c008d67b0a39a03d074edcbce72014ffc592da799d91a3e1b878c00167a3cbb9b9331223ab1b3405e63ddc5708a30a1
|
||||
SHA512 (kernel-abi-whitelists-5.7.0-0.rc6.20200519git642b151f45dd.1.tar.bz2) = 78633c9dfaff23aad3bc36056b4d20e9e797583107ab6a5670fede003656ed4f0fc53031ffe05ae79a493508db7c04946f2495451f6e363609332eba75ed56f6
|
||||
SHA512 (kernel-kabi-dw-5.7.0-0.rc6.20200519git642b151f45dd.1.tar.bz2) = 7cc0a9b5c1240b95a25b634f43878360655e7aa92bd80c576c0d2df598ad8fe352f01c7318eb1b0be3749378417207e808f509a4fe77bcd9152d6261621801b3
|
||||
SHA512 (linux-20200520git115a54162a6c.tar.xz) = c7b931d0309933ce16e727f667bdfad198ecf9fd5f0dc6184228d670712fddda26a4c0c787eb70ef3f7fd578ec7f24d520deb3c1c991e518fcbe1a5603bc534f
|
||||
SHA512 (kernel-abi-whitelists-5.7.0-0.rc6.20200520git115a54162a6c.1.tar.bz2) = 60072362e5138681c4dfcc19c9f5eced0790af8a24ade573842aa252b8b771aceb86041b589309fb3b865cb6795d0a62086eede02785c417d993e679fd7abe54
|
||||
SHA512 (kernel-kabi-dw-5.7.0-0.rc6.20200520git115a54162a6c.1.tar.bz2) = 96522c07d75bd921390c4b0261e718bc1a473af47f5b3cbc07fa6b2608b861b62285481ae3ec5bf97cb96667f9bbac7a584bb060eba0a9dbf3e7996994f31f66
|
||||
|
Loading…
Reference in New Issue
Block a user